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Preface

This guide describes how to use Thermo Scientific Mass Frontier™ for the management, 
evaluation, and interpretation of mass spectra. 

Complete a brief survey about this document by clicking the button below.
Thank you in advance for your help.

Related Documentation
Mass Frontier includes Help and these manuals as PDF files:

• Mass Frontier User Guide

• Mass Frontier Quick Start Guide

To view product manuals

Go to Start > Programs > HighChem Mass Frontier 7.0.

To open Help

From the Mass Frontier window, choose Help > Contents Index. 

For more information, visit www.thermo.com. You can find application notes at 
www.thermo.com\appnotes. 

Contents

• Related Documentation

• Special Notices

• System Requirements

• Getting a License

• Contacting Us
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Special Notices
Make sure you follow the precautionary statements presented in this guide. The special 
notices appear in boxes.

Special notices include the following:

System Requirements
Mass Frontier requires a license. In addition, your system must meet these minimum 
requirements.

IMPORTANT  Highlights information necessary to prevent damage to software, loss of 
data, or invalid test results; or might contain information that is critical for optimal 
performance of the system.

Note  Highlights information of general interest.

Tip  Highlights helpful information that can make a task easier.

System Requirements

Hardware • Computer with Pentium™ III-compatible or later processor, with a 
minimum of 600 MHz

• 512 MB of RAM (1 GB or more recommended)
• SVGA or higher resolution color monitor
• 2 GB or more hard disk space

Software In addition to the software included on the Mass Frontier CD, you must 
have the following applications:

• Windows 7, Windows Vista™, Windows XP (SP 2), 
or Windows 2000 (SP 4) 

• Microsoft™ Office XP (recommended)
• Internet Explorer™ 7.0 (SP 1) or later
• Xcalibur™ 2.0 installed with local user access (recommended)
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Getting a License
When you first start the Mass Frontier application, the activation window opens. The system 
generates a unique serial number that you must send to Thermo Fisher Scientific Technical 
Support. When contacting Technical Support, include your name, company, e-mail or fax 
number, the serial number, and the type of license you need. Thermo Fisher Scientific 
recommends copying and pasting the serial number and sending it by e-mail. 

You will receive an Activation Key that you enter in the Activation Key box. When you click 
Activation, the program is activated according to the type of authorization your license gives 
you. You must run the Mass Frontier 7.0 application with administrator rights when entering 
the activation key.

Three types of licenses are available:

• 60-Day Evaluation Version (free of charge)

• Full Version Single License 

• Upgrade from 5.0 Single License 

The evaluation version is full-featured and automatically expires 60 days after activation. Any 
attempt to set back the system date automatically terminates this version. You can purchase 
and then activate the full version of the Mass Frontier application at any time, during or after 
the free evaluation, without reinstalling the software. The activation window with the serial 
number is located under Help > About > Activation. 

Each Activation Key is only valid for a single license. Any additional installation generates a 
different serial number that requires a different Activation Key.

For questions regarding activation, contact Thermo Fisher Scientific Technical Support in 
San Jose, CA, United States:

• E-mail: ThermoMSLicensing@thermofisher.com

• Fax: [1] (408) 965-6120

When your license is activated, go to www.highchem.com and download the latest service 
release.

For technical questions or installation problems, contact HighChem Technical Support:

• E-mail: ms@highchem.com

Use Mass Frontier in the e-mail subject line.
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Contacting Us
There are several ways to contact Thermo Fisher Scientific for the information you need. 

To contact Technical Support

Find software updates and utilities to download at mssupport.thermo.com.

To contact Customer Service for ordering information

To get local contact information for sales or service

Go to www.thermoscientific.com/wps/portal/ts/contactus.

To copy manuals from the Internet

Go to mssupport.thermo.com, agree to the Terms and Conditions, and then click 
Customer Manuals in the left margin of the window. 

To suggest changes to documentation or to Help

• Fill out a reader survey online at www.surveymonkey.com/s/PQM6P62.

• Send an e-mail message to the Technical Publications Editor at 
techpubs-lcms@thermofisher.com.

Phone 800-532-4752

Fax 561-688-8736

E-mail us.techsupport.analyze@thermofisher.com

Knowledge base www.thermokb.com

Phone 800-532-4752

Fax 561-688-8731

E-mail us.customer-support.analyze@thermofisher.com

Web site www.thermo.com/ms
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Introducing Mass Frontier

The Mass Frontier application is a software package for the management, evaluation, and 
interpretation of mass spectra. Because of the large volume of information a mass 
spectrometer can produce, management capabilities are essential in mastering your analytical 
workloads. The Mass Frontier application provides tools for processing and organizing mass 
spectral and chromatographic data. To read more about HighChem Ltd., refer to the 
HighChem Web site.

Use the Mass Frontier application to review collected data and efficiently interpret mass 
spectra. The Mass Frontier application can interpret mass spectra even when an unknown is 
not found in your library or a commercially available library. The software package includes 
the HighChem Fragmentation Library™ and a library of Spectral Trees™. 

Contents

• Overview

• Installing the Mass Frontier Application

• New Features in Mass Frontier 7.0

• Application Limitations
Thermo Scientific Mass Frontier User Guide 1
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1 Introducing Mass Frontier
Overview
Overview
The Mass Frontier application consists of multiple modules that are displayed as separate 
windows:

All the modules are located in the Mass Frontier application window. Four of the modules 
(Fragments & Mechanisms, Neural Networks, Spectra Projector, and Components Editor) are 
generated from your input data; they cannot be directly opened from the application window.

Although each of the modules is independent, the application can automatically establish a 
link between several modules (see “Exchanging Mass Spectral Data Between Modules” on 
page 65). For example, the Mass Frontier application can make a link between the Database 
Manager module and the Fragments & Mechanisms module. In this case, the application 
links the peaks in a mass spectrum in the Database Manager window with mass-to-charge 
ratios in the Fragments & Mechanisms window. You can also link records in the Database 
Manager window with objects in the Spectra Classifier and Spectra Projector windows. 

Server Manager

Structure Editor

Database Manager

Fragmentation Library

Chromatogram Processor

Components Editor

Spectra Classifier

Spectra Projector

Neural Networks

Fragments Comparator

Isotope Pattern

Periodic Table

Formula Generator

Fragments & Mechanisms

Report Creator
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 1 Introducing Mass Frontier
Overview
Server Manager

The Mass Frontier application includes the Mass Frontier Server Manager, a stand-alone 
application for management and administration of libraries on a Microsoft SQL Server™ 
relational model database server. Using the Server Manager, you can access libraries over a 
computer network. The SQL Server stores libraries that you can access from individual 
instances of the Mass Frontier application. Using the Server Manager, you create, install, 
remove, delete, import, convert, back up, and restore spectral and fragmentation libraries in 
one location for all instances of the application. 

You can create libraries only on the same computer where the SQL Server is located. For 
example, if your SQL Server is located on a network computer, you cannot create a library on 
your local computer.

To access the Server Manager from the Mass Frontier main menu, choose Library > Server 
Manager. This menu item is accessible only if the Server Manager application is installed on 
the same computer as the Mass Frontier application. If the Server Manager is installed on a 
network computer, you must start it from this location.

For a complete description of the features in the Server Manager window, see Chapter 5, 
“Library Utilities.” 

Figure 1. Server Manager window
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1 Introducing Mass Frontier
Overview
Structure Editor

The Structure Editor module is a structure drawing tool that automatically calculates the mass 
of a selected fragment and the corresponding loss. You can use the chemical structures that 
you created in this module throughout the Mass Frontier application. 

For a complete description of the features in the Structure Editor window, see Chapter 4, 
“Structure Editor Module.” 

Figure 2. Structure Editor window
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 1 Introducing Mass Frontier
Overview
Database Manager

The Database Manager module provides several ways to organize and process mass spectra, 
chemical structures, and libraries, and include the data in a spreadsheet format. This module 
supports data exchange with the Microsoft Excel™ application. You can use the advanced 
database query and search features of the module to access information needed for rapid 
compound identification. You can also create your own libraries containing spectra, MSn 
spectral trees, chromatograms, chemical structures, and extensive compound characteristics. 

For a complete description of the features in the Database Manager window, see Chapter 2, 
“Database Manager Module.”  

Figure 3. Database Manager window
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Overview
Fragmentation Library

Use the Fragmentation view on the Database Manager window to create and manage 
fragmentation mechanism databases. The Fragmentation view contains a full-featured 
graphical editor for entering fragmentation reactions that you can store in a database, together 
with complementary information for the reaction. You can query all the fields of the database, 
for example: authors, ionization method, or molecular mass. All the library structures from 
the reactions are also fully searchable. 

For a complete description of the features in the Fragmentation view, see Chapter 7, 
“Fragmentation Library.” 

The Fragmentation Library contains an expert system that automatically extracts a 
decomposition mechanism for each fragmentation reaction in the database and determines 
the compound class range where you can apply the mechanism. This expert system applies 
database mechanisms to your structure and automatically predicts the fragmentation reactions 
for a specified compound.

The Mass Frontier application includes approximately 31 000 fragmentation schemes that 
contain approximately 130 000 individual reactions collected from mass spectrometry 
literature. The collected mechanisms are stored in the HighChem Fragmentation Library.

Figure 4. Fragmentation Library mechanisms
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Overview
Figure 5. Reaction page of the Fragmentation view

Figure 6. Info page of the Fragmentation view
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1 Introducing Mass Frontier
Overview
Chromatogram Processor

The Chromatogram Processor module extracts and processes mass spectral data, including 
GC/MS or LC/MS. By using the component detection and spectra deconvolution algorithms, 
you can automatically extract individual spectra or spectral trees from complex 
chromatographic data files. This module provides visual tools for selecting particular spectra 
from MSn experiments. 

For a complete description of the features in the Chromatogram Processor window, see 
Chapter 8, “Chromatogram Processor Module.” 

Figure 7. Chromatogram Processor window
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Overview
Components Editor

In the Components Editor module, you can edit, search, and organize chromatographic 
components that are stored in a library or generated by the Components Detection and 
Spectra Deconvolution feature. This module includes management tools that you can use to 
delete unrelated components, add chemical structures, edit extensive data fields, process 
spectral trees, annotate spectral peaks, or sort search hit lists for every component in a 
processed chromatogram. 

For a complete description of the features in the Components Editor window, see Chapter 9, 
“Components Editor Module.” 

You cannot open the Components Editor module directly from the Mass Frontier application 
window. You must generate this module from your data in the Chromatogram Processor 
window. For additional information, see Chapter 8, “Chromatogram Processor Module.” 

Figure 8. Components Editor window
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Overview
Hit Selector

Use the Hit Selector feature to list the best matches found during a library search in the 
Components Editor window. For additional information, see “Searching Components” on 
page 334.

Figure 9. Hit Selector window
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Overview
Spectra Classifier

The Spectra Classifier module retrieves and organizes spectra intended for classification. 
Because you can classify spectra according to various criteria (by structural, physical, and other 
properties), organizing the spectra into different groups can be useful. You can visually 
represent these groups of spectra in different ways (using colors, symbols, and numbers) to 
highlight similarities or dissimilarities among the spectral groups. 

For a complete description of the features in the Spectra Classifier window, see Chapter 10, 
“Spectra Classifier Module.” 

Figure 10. Spectra Classifier window
Thermo Scientific Mass Frontier User Guide 11



1 Introducing Mass Frontier
Overview
Spectra Projector

The Spectra Projector module displays the results of the Principal Component Analysis (PCA) 
and Fuzzy Clustering classification methods. You can classify mass spectral data by using 2-D 
or 3-D projections where each point represents a spectrum. When you want to determine the 
class membership of an unknown spectrum, open or paste it into an existing projection. 

You cannot open the Spectra Projector module directly from the Mass Frontier application 
window. You must generate this module from the Spectra Classifier window using data from 
the Database Manager or Chromatogram Processor module. 

For a complete description of the features in the Spectra Projector window, see Chapter 11, 
“Spectra Projector Module.” 

For additional information, see Chapter 10, “Spectra Classifier Module.” 

Figure 11. Spectra Projector window
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Overview
Neural Networks

The Neural Networks module displays the results of the Neural Networks classification 
method. Mass spectra are classified using the Self-Organizing Maps (SOM) method, which is 
a special class of neural network. If two or more spectra activate the same neuron, the 
corresponding compounds will likely exhibit similar physical or chemical properties, or 
biological activities. For additional information, see  “Self-Organizing Maps” on page 343.

You cannot open the Neural Networks module directly from the Mass Frontier application 
window. You must generate this module from the Spectra Classifier window using data from 
the Database Manager or Chromatogram Processor module. 

For a complete description of the features in the Neural Networks window, see Chapter 12, 
“Neural Networks Module.” 

Figure 12. Neural Networks window
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Overview
Fragments Comparator

The Fragments Comparator module displays a series of fragments in a table format. The 
columns in the table represent individual compounds, and the rows display either 
mass-to-charge ratios or the structures of fragments. This module provides an effective 
comparison of the product ions of analogous molecules. 

For a complete description of the features in the Fragments Comparator window, see 
“Fragments Comparator Window” on page 241.

Figure 13. Table page of the Fragments Comparator window

Figure 14. Structures page of the Fragments Comparator window
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Overview
Isotope Pattern

The Isotope Pattern module displays the relevant isotopic profile when you select a structure 
or fragment in the Mass Frontier application. You can also calculate the isotope pattern from 
your molecular formula. 

For a complete description of the features in the Isotope Pattern window, see Chapter 2, 
“Database Manager Module.” 

Figure 15. Isotope Pattern window
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Overview
Periodic Table

The Periodic Table module displays the terrestrial isotopic abundance of elements and their 
multi-atomic isotopic profiles.

Figure 16. Periodic Table window
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Overview
Formula Generator

The Formula Generator module calculates a list of theoretical molecular formulas that best fit 
an m/z value. 

For a complete description of the features in the Formula Generator window, see Chapter 13, 
“Formula Generator Module.” 

Figure 17. Formula Generator window 
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Overview
Fragments & Mechanisms

The Fragments & Mechanisms module automatically generates fragments and detailed 
fragmentation and rearrangement mechanisms from your chemical structure. This module 
includes a comprehensive set of known reaction mechanisms and library mechanisms that 
support automated prediction. 

For a complete description of the features in the Fragments & Mechanisms window, see 
Chapter 6, “Fragments and Mechanisms Module.”  

You cannot open the Fragments & Mechanisms module directly from the Mass Frontier 
application window. You must generate this module from your data in the Structure Editor or 
Database Manager module. For additional information, see Chapter 4, “Structure Editor 
Module,”  or Chapter 2, “Database Manager Module.” 

Figure 18. Fragments & Mechanisms window
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 1 Introducing Mass Frontier
Overview
Report Creator

Use the Report Creator module to create customizable reports from modules displayed on the 
screen. You can print or export reports as PDF files. 

For a complete description of the features in the Report Creator window, see Chapter 15, 
“Report Creator Module.” 

Figure 19. Report Creator window
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Figure 20. Report Preview window
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 1 Introducing Mass Frontier
Installing the Mass Frontier Application
Installing the Mass Frontier Application
To install the Mass Frontier application with its components, you must have access to an 
administrator account on the Windows Vista operating system or an account with 
administrator rights on the Windows XP operating system. You also have the option to install 
the Xcalibur data system with local user access before installing the Mass Frontier 7.0 
application.

From the installation CD, you can install the Mass Frontier application and libraries as a local 
installation or as a client/server installation.

IMPORTANT  Because of the high variability of Windows versions and service packs, you 
might be prompted to install additional Microsoft system components that are in the 
Setup Launcher.
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Installing the Mass Frontier Application
Local Installation

The Mass Frontier application and libraries reside on the same computer. To run the Mass 
Frontier application locally, this computer must have the following applications:

• Microsoft SQL Server 2005 Express Edition SP3

• Mass Frontier Server Manager

• Mass Frontier

To install Mass Frontier 7.0 as a local installation

1. Click SQL Server Express 2005.

The installation of Microsoft SQL Server 2005 Express Edition begins. The installation 
can take several minutes. 

2. Click Server Manager.

The installation of the Mass Frontier Server Manager 2.0 application begins. This module 
manages the creation, installation, conversion, and removal of libraries. 

3. Click MSFileReader.

The installation of the Thermo MSFileReader begins. This module manages access to 
Thermo Scientific raw data files.

4. Click Mass Frontier. 

5. The installation of the Mass Frontier application begins.

Note  The Mass Frontier 7.0 application is bundled with Microsoft SQL Server 2005 
Express Edition SP3 and the Mass Frontier Server Manager software.

Note  If you do not have the Microsoft Backward Compatibility Components 
installed on the computer, you will be prompted to install them.

Note  If you do not have the Microsoft SQL Native Client installed on the computer, 
you will be prompted to install it.
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Client-Server Installation

In a client/server installation, you can share libraries over the network.

To run Mass Frontier as a client/server application, the libraries reside on a designated 
computer (server). This server must have the following applications:

• Microsoft SQL Server 2005 Express Edition SP3

• Mass Frontier Server Manager

Other network computers (clients) must have the following applications: 

• Mass Frontier

• Thermo MSFileReader

To install components on the server

1. Click SQL Server Express 2005.

The installation of Microsoft SQL Server 2005 Express Edition SP3 begins. The 
installation can take several minutes. 

2. Click Server Manager.

3. The installation of the Mass Frontier Server Manager 2.0 application begins. 

This module manages the creation, installation, conversion, and removal of libraries. 

To install components on a client computer

1. Click MSFileReader.

The installation of the Thermo Fisher Scientific MSFileReader application begins.

2. Click Mass Frontier. 

The installation of the Mass Frontier application begins.

Note  The Mass Frontier 7.0 application is bundled with Microsoft SQL Server 2005 
Express Edition SP3 and the Mass Frontier Server Manager software.

Note  If you do not have the Microsoft Backward Compatibility Components 
installed on the computer, you will be prompted to install them.

Note  If you do not have the Microsoft Backward Compatibility Components and the 
Microsoft SQL Native Client installed on the computer, you will be prompted to 
install them.
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New Features in Mass Frontier 7.0
New Features in Mass Frontier 7.0
The Mass Frontier 7.0 application includes new features in the Database Manager, 
Chromatogram Processor, and Report Creator modules.

New Database Manager Features

The Database Manager module has new features in its tree comparison and automatic 
fragment annotation algorithms.

• Tree Comparison

The Mass Frontier tree comparison function has added these new features:

– You can insert the left tree from the current record, Clipboard, or searched tree (if the 
current record is the result of a tree search). The right tree is the current record.

– The first group of options (Type, Method, Match Stage, and Ignore Top Stage) 
affects the calculation of the match factor. The meaning of the parameters is the same 
as for the tree search in previous versions of the Mass Frontier application.

– Sync Best Match: If you select a spectrum in the left or right tree, the most similar 
spectrum is selected in the opposite tree. If no spectrum matches, the text “No sync 
match found” appears under this check box.

– Total Best Match: The two spectra with the highest match factors are selected in both 
trees.

– Copy to Compare Spectra: You can show selected spectra in the Compare Spectra 
tab. 

• Automatic Fragment Annotation

The automatic fragment annotation algorithm now includes the following new features:

– Improvements that consider all precursors within the range of the isolation width. 

– Modifications of the explained peaks affecting the precursor fragments of all the 
dependent nodes.

– The ability to annotate peaks under the specified threshold.

For information about the new Database Manager features, see Chapter 2, “Database 
Manager Module.” 
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New Features in Mass Frontier 7.0
New Chromatogram Processor Features

The Chromatogram Processor module in the Mass Frontier 7.0 application includes changes 
to the FISh algorithm, thresholding, baseline correction, smoothing, joint component 
detection, action handling, component search, and chromatogram access.

• FISh algorithm

Enhancements to the FISh algorithm include these features:
– Use of the m/z list as a model.
– Extending the model by mass shifts.
– The ability to perform FISh with neutral loss analysis for MS/MS scans.
– Detection of integrated components.
– The ability to automatically localize the site of modification through color coding of 

fragments common to the parent component.
– A more intuitive graphical user interface with flexible, comprehensive options and the 

ability to define the FISh model with one click.

• Thresholding, correcting baselines, and smoothing

A new wizard is available for thresholding, baseline correction, and smoothing. 

• Joint component detection

A new wizard is available for joint component detection. 

• Tools

The Chromatogram Processor module includes two new tools:
– Slide bars to help you visualize processing parameters.
– Actions that you can apply to chromatograms (base peak chromatograms, selected 

ion chromatograms, forced mass tolerance, thresholding, FISh, baseline correction, 
smoothing, and component detections) in the Chromatogram Processor window. 
You can save these actions to a file and load them. You can also drag them and drop 
them between Chromatogram Processor windows. In addition, you can activate and 
deactivate them, and reorder, modify, and remove them. 

• Components search

You can directly access the component search and the hit selector from the 
Chromatogram Processor window. The results of the component search appear in short 
form in the ToolTips.

• Save/open chromatogram

You can save and load chromatograms with components, extracted ion chromatograms 
(XICs), selections, and actions in the new format.

For information about the new Chromatogram Processor features, see Chapter 8, 
“Chromatogram Processor Module.” 
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New Report Creator

With this new module, you can create comprehensive, flexible, reusable reports and then 
customize them.

For complete information about the Report Creator, see Chapter 15, “Report Creator 
Module.” 
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Application Limitations
Application Limitations
Although the Mass Frontier application is fully featured, there are application limitations.

• The application deals primarily with small organic structures rather than peptides and 
other biologically-related molecules. The Structure Editor and other modules dealing 
with structures have a limit of 199 non-hydrogen atoms per structure. When you exceed 
this number, a message appears, which reminds you of this limitation.

• The application is designed for pure substances only. It does not accept mixtures. The 
system considers a mixture to be two or more structures, depicted in the same window, 
which are not connected by a bond (represented as a line). If you try to generate 
fragments and mechanisms from a mixture, a message alerts you that this action is not 
permitted. The Check Structures option will also detect mixtures as an error. For 
additional information, see Chapter 4, “Structure Editor Module.” 

• However, library utilities support mixtures to ensure backward compatibility with 
commercial libraries. You may add mixtures to a user library, but the Fragmentation 
Library does not support mixtures.

• New aspects of the Mass Frontier system have greatly extended the automated generation 
of fragments and mechanisms, but some restrictions still remain. For additional 
information, see “Previewing Unimolecular Reactions” on page 193. The Mass Frontier 
application offers the ability to select reagent gases for chemical ionization. However, it 
cannot modify the relative ionization potentials of reagent gases. Negative ionization 
(deprotonation) is only supported using the Fragmentation Library. For additional 
information, see Chapter 7, “Fragmentation Library.”  There are no general rules for 
negative ionization. Because “soft” ionization techniques are mainly low energetic 
experiments, which often yield complex skeletal and “random” rearrangements, the 
predictability of these fragmentation and rearrangement processes is not as high as what 
can be attained by electron impact ionization. You can improve the degree of 
predictability by using compound specific fragmentation mechanisms in the 
Fragmentation Library module.

• The Mass Frontier application is primarily designed for neutral and single charged 
molecules. As a consequence you can attach the charge symbol (+ or –) to only one atom. 
If the charge multiplicity is described, in general you can use the unspecified charge 
location option in the Structure Editor window. None of the modules support biradicals.

• This application supports high resolution mass spectra with an m/z range of 1–3000 mass 
units. Classification modules allow only 800 peaks per spectrum. If a spectrum contains 
more than 800 peaks, the classification procedure selects the 800 most prominent peaks. 
For additional information, see Chapter 10, “Spectra Classifier Module.” 

• All spectral modules support spectral trees except Spectra Classifier, which uses total 
composite spectra generated from spectral trees. For additional information, see 
Chapter 3, “Spectral Tree Module.” 
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Database Manager Module

The Database Manager module manages spectral and structural information in a SQL Express 
database. 

The Database Manager module includes library maintenance utilities that let you create and 
organize spectral and chromatographic libraries with chemical structures. Because the Mass 
Frontier application supports ion structures and spectral tree representation, you can also 
create true MSn libraries. Advanced library query and search features provide access to the 
information you need to identify compounds and can help you interpret unknown spectra. 
The Database Manager module provides a flexible set of search restrictions to target your 
search results. 

Contents

• Using the Database Manager Window

• Using the Info Page

• Using the Mass Differences Page

• Using the Compare Spectra Page

• Using the Compare Trees Page

• Working with Spectral Records

• Displaying Isotope Patterns

• Assigning Fragments to Spectral Peaks

• Exchanging Mass Spectral Data Between Modules

• Using the Library Pane

• Processing Data-Reduced Chromatograms

• Using the Search Utilities
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The following figure identifies key toolbar buttons, panes, and tabs in the Database Manager 
window.

Figure 21. Database Manager window
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Using the Database Manager Window
Structural and spectral data are organized in spreadsheet-like pages with a variety of 
supplementary information. To organize your libraries, search results, and other data, you can 
move spectra-structure pairs from one Database Manager window to another. 

The Database Manager module provides a customizable tool for creating reports that you can 
either print directly or copy to a word processor to create more advanced reports.

For each record in the Database Manager window, you can view the mass spectrum, a list of 
peaks, or the compound identification information and the neutral losses spectrum (when the 
molecular mass is available). You can also compare two spectra.  

This section includes the following topics:

• Opening a Database Manager Window

• Using the Detachable Panes

• Using Libraries in the Database Manager Window

• Using Records in the Database Manager Window

Opening a Database Manager Window

The number of Database Manager windows that you can simultaneously open is limited only 
by your system resources so that you have unconstrained flexibility in handling spectral and 
structural data. 

Follow these procedures:

• To open an empty Database Manager window

• To load mass spectra into the Database Manager window

• To load search results in a Database Manager window

• To zoom and pan in the graphical display

To open an empty Database Manager window

Do one of the following:

Click the Database Manager button, , in the Mass Frontier toolbar.

–or –

Choose Tools > Database Manager from the Mass Frontier main menu. 

An empty Database Manager window opens.
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To load mass spectra into the Database Manager window

1. Choose File > Open > Mass Spectrum from the Mass Frontier main menu.

The Open Spectrum dialog box opens.

2. Select an .msp or .jdx file and click Open.

The mass spectra file opens on the Spectrum page.

To load search results in a Database Manager window

1. Choose Search > any criteria from the Mass Frontier main menu.

The Library Search dialog box opens for the selected type of search. Each dialog box 
contains parameters specific to the type of criteria you are searching, but all Library 
Search dialog boxes include a Libraries area and a merge results option.

2. In the Libraries area, select the Active option for all the libraries you want to search.

3. Select or clear the Merge Results into Active Database Manager Window option.

• When selected, the application displays the search results in the current Database 
Manager window and adds the search results to the Work spreadsheet.

• When cleared, the application displays the search results in a new Database Manager 
window.

4. Click OK in the Library Search dialog box.

The application searches the selected libraries and adds the search results to the Work 
spreadsheet in the specified Database Manager window.
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To zoom and pan in the graphical display

• Click the Hand button, , in the Mass Frontier toolbar and drag the hand to pan 
horizontally or vertically.
Similarly, hold down the H keyboard key or the Spacebar to change the cursor to the 
hand.

• Click the Zoom Out button, , in the Mass Frontier toolbar.

• Click the Zoom In button, , in the Mass Frontier toolbar.

• Click the Zoom to Box button, , in the Mass Frontier toolbar and describe a 
rectangle. 
Similarly, hold down the Z keyboard key and describe a rectangle.

• Click the Zoom Reset button, , in the Mass Frontier toolbar to return to full scale.

• Click the Zoom Undo button, , in the Mass Frontier toolbar to undo the last zoom 
operation.

• Click the Zoom Redo button, , in the Mass Frontier toolbar to restore the last zoom 
operation.

• Use the scroll wheel on the mouse to zoom the entire display. 
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Using the Detachable Panes

Spectral tree and structure panes are detachable windows that you can place anywhere inside 
or outside of a Database Manager window. 

Follow these procedures:

• To detach the spectral tree or structure pane

• To turn the spectral tree or structure panes off and on

To detach the spectral tree or structure pane

1. Click the header of the spectral tree or structure pane.

2. Drag the panes to a new location anywhere on your desktop.

At any time, you can reattach the pane to the Database Manager window.

3. To reattach a pane, do the following:

a. Click the header of the pane.

b. Move your cursor to the left or right edge of the upper pane of the Database Manager 
window.

When the pane is ready to reattach, the frame snaps to the location reserved for it in 
the Database Manager window. 

Tip  The snap is triggered by the location of the cursor on the edge of the upper 
pane, not the location of the detached pane.
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c. Release the mouse.

To turn the spectral tree or structure panes off and on

1. Click the Show Spectral Tree button, , to turn on the Spectral Tree pane.

This is a useful feature when, for example, you are dealing with single stage spectra (not 
MS/MS) and do not need a spectral tree pane.

2. Click the Show Structure button, , to turn on the Structure pane.

These toggle features work even when the panes are detached from the Database Manager 
window.

Tip  You do not have to attach the Spectral Tree pane to the left side of the 
window and the Structure pane to the right side (the default locations). You can 
swap sides or attach both panes to one side of the Database Manager window.

When the cursor touches the 
edge, the detached pane snaps 
into place.
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Using Libraries in the Database Manager Window

In the Database Manager window, all installed libraries are represented as tabbed pages in the 
lower pane. 

To add a library to the Database Manager window, use the Install Library feature in the Server 
Manager window. Similarly, to remove a library, use the Uninstall Library feature in the Server 
Manager window. The Mass Frontier software package includes the HighChem Spectral Tree 
Library (electrospray ionization (ESI) positive and negative) and the HighChem 
Fragmentation Library.

To open a library, click the library tab in the Database Manager window. To switch between 
spectral and fragmentation displays, click the Tree or Fragmentation tabs on the right side of 
the upper pane.
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Using Records in the Database Manager Window

A single record in the Database Manager window contains one spectrum with a structure 
(when available) or one spectral tree with associated structures (when available) and 
complementary information associated with the record. See “Using the Info Page” on page 38. 

Each record is visually represented as a single row in the Spreadsheet view. Triangular 
symbols,  or , point to the active record. The structure, spectrum, spectral tree, and any 
other available information are displayed for the active record in the upper pane of the 
Database Manager window. See “Using the Library Pane” on page 66.

Figure 22. Displaying an active record in the Database Manager window
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Using the Info Page
In addition to the mass spectrum or spectral tree and the chemical structure, each record on 
the Info page can include compound identifications, property, and origin information. The 
Info page contains editable fields organized by groups and subgroups. You cannot edit fields 
that display information automatically calculated from a chemical structure (formula, 
molecular mass, and so on) or acquisition settings adopted from a file. Text in noneditable 
fields is grayed out. 

The information on the Info page is divided into four groups:

• Compound

Names, ID numbers, physical properties, and biological activity information

• Tree (associated with the entire tree)

Comments, operator, instrument, and sample information

• Node (associated with a tree node [allows one chromatogram per tree node])

Chromatographic data 

• Spectrum (associated with the selected parallel spectrum)

File, MS/MS, and scan information

Make sure you understand the connection between data on the Info page and the spectral tree 
hierarchy. 

Each parallel spectrum contains its own data in the Spectrum group because you can acquire 
parallel spectra under different experimental conditions (collision energy, isolation width, and 
so on) that you must store independently. In the Mass Frontier application, you can select 
items that you want displayed on the Info page for each library. See “Using the Info Page” on 
page 38.

Note  Both the Tree and the Fragmentation pages have Info tabs. The contents are 
identical.
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Figure 23. Info page

When a record is saved in a library, all data on the Info page is automatically stored in the 
SQL database. To permanently store any change, update, or deletion on the Info page, save 
the corresponding record in the library.

The list of information associated with a record might contain a large number of items that 
remain largely unused. 

You can select items to appear on the Info page for each library. 
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To exclude items from the information list

1. Choose Options > Info Tab Layout from the Mass Frontier main menu. 

The Info Tab Layout dialog box opens. The left pane lists all the available information 
groups and items that you can display in the Database Manager window. The right pane 
mirrors the current Database Manager display for the selected library.

2. Click the tab for the library you want to edit.

3. To hide any item of information, do the following:

a. Select the item in the left pane.

b. Right-click and choose Hide from the shortcut menu or click Hide at the top of the 
pane.

The item is not available in the left pane. Until you click Apply, the items are still 
represented in the right pane.

Note  To show a hidden item, repeat step 3, clicking Show instead of Hide.
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4. To hide an entire group of information, do the following:

a. Select the group heading in the left pane.

b. Right-click and choose Hide from the shortcut menu, or click Hide at the top of the 
pane.

All items in the group are not available in the left pane. Until you click Apply, the items 
are still represented in the right pane.

5. In the Apply To area, do one of the following:

a. Select the Current Library option.

b. Click Apply.

c. Verify your changes in the right pane.

d. To make changes to another library, repeat step 2 through step 5.

–or–

a. Select the Selected Libraries option.

b. Select the check box for each library that you want to apply the changes to.

c. Click Apply.

d. Verify your changes for each library in the right pane.

6. To make changes to another libraries, repeat step 2 through step 5.

7. Click OK.

Note  To show a hidden group, repeat step 4, clicking Show instead of Hide.
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Using the Mass Differences Page
Use the Mass Differences page in the Database Manager window to select any peak and view 
the mass differences to the right and left (possible precursor-product ions). You can move the 
m/z scale using the track bar at the top of the page. When molecular mass information is 
available, the zero value of the m/z scale automatically starts at the molecular mass—that is, a 
standard neutral loss spectrum is displayed. In this case, a blue selection bar in the track bar 
marks the shift of the m/z scale with respect to molecular mass. You can enlarge the graphic to 
see the number for less prominent peaks when there are a large number of peaks close to each 
other.

Figure 24. Mass Differences page
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Using the Compare Spectra Page
Use the Compare Spectra page in the Database Manager window to compare two spectra. 

• The bottom spectrum is from the active record currently selected in the Spreadsheet view.

• The middle spectrum displays the difference between the top and bottom spectrum. 

• The top spectrum is initially blank.

You can add the currently selected record to the top spectrum or paste a record from the 
Clipboard. 

After a spectrum search, the first spectrum in the results list is automatically pasted to the top 
pane so that you can view the peak differences of spectra in the active spectrum and the 
queried spectrum.

The peaks in the top and bottom spectra have different colors. For the middle spectrum, the 
application derives the difference peak color from the spectrum that has a more abundant 
peak at a particular m/z value.

Figure 25. Compare Spectra page

Table 1. Compare Spectra parameters 

Parameter Description

Add Adds the currently selected spectra to the top pane.

Paste Pastes the spectra on the Clipboard to the top pane.

Searched Adds the queried spectrum to the top pane.

Difference Spectrum Displays the difference between the top and bottom spectrum. 

Active Spectrum The active record currently selected in the Spreadsheet view.
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Using the Compare Trees Page
Use the Compare Trees page in the Database Manager window to compare trees from 
different Database Manager windows.

Figure 26. Compare Trees page

Table 2. Compare Trees parameters

Parameter Description

Type Similarity or Identity

Method Specifies a HC Low, NIST, or HC Low-High peak comparison 
method.

Match Stage Uses an identity search with the MSn stage of the tree spectra. The 
stage of both nodes must be the same.

Ignore Top Stage Excludes the top-level tree (full scan, source CID). Use this only 
when you select Match Stage.

Sync Best Match Select the most similar spectrum in the second tree.

Total Best Match Select the most similar spectrum in both trees.

Copy to Compare 
Spectra

Copies these to the Compare Spectra page. See “Using the 
Compare Spectra Page” on page 43.
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Working with Spectral Records
In the Database Manager window, you can modify the records in a user library by copying 
records from other libraries, importing records from Microsoft Excel spreadsheets, or 
modifying the structures for the records.

You can exchange mass spectra between the Database Manager window and the Excel 
spreadsheet by using the export and import features. For additional information, see 
“Exporting Data to an Excel Spreadsheet” on page 388 or “Importing Spectra from an Excel 
Spreadsheet” on page 391.

This section includes the following topics:

• Managing Spectral Records

• Exporting Data to an Excel Spreadsheet

• Importing Spectra from an Excel Spreadsheet

• Adding Structures to a Record
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Managing Spectral Records

You can copy or move records to different locations in the Spreadsheet view in the same 
Database Manager window. This lets you organize and maintain your experimental data or 
search results. 

Follow these procedures:

• To open a mass spectrum from a file

• To save one or more spectra

• To select multiple records in the Work spreadsheet

• To select multiple records in a database spreadsheet

• To copy records

• To cut records

• To paste records to the Work spreadsheet

• To copy spectra from the Chromatogram Processor

To open a mass spectrum from a file

1. Do one of the following:

Click the Open button, , in the Mass Frontier toolbar and choose Mass Spectrum 
from the menu.

–or– 

Choose File > Open > Mass Spectrum from the Mass Frontier main menu. 

The Open Spectrum dialog box opens. By default, both NIST MSP and JCAMP-DX file 
types are displayed.

2. Select a file and click Open.

The application adds the records in the selected file to the spreadsheet in the Work library.

To save one or more spectra

1. Select one or more records that contain the spectra you want to save.

See “To select multiple records in the Work spreadsheet” on page 47.

2. Do one of the following:

Click the Save button, , in the Mass Frontier toolbar and choose Spectrum from 
the menu.

–or– 

Choose File > Open > Spectrum from the Mass Frontier main menu. 

The Save MS Spectrum dialog box opens. 
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3. Select the data format in the Save as Type list.

4. Type the file name in the File Name box and click Save.

To select multiple records in the Work spreadsheet

Do one of the following:

Select the first record, hold down the SHIFT key, and select the last record.

–or–

Drag the cursor from the first record to the last record. 

To select multiple records in a database spreadsheet

Hold down the CTRL key while you select multiple records.

To copy records

1. Select the records in the Database Manager spreadsheet.

2. Do one of the following:

Click the Copy button, , in the Mass Frontier toolbar and choose Selected Rows 
from the menu.

–or–

Choose Edit > Copy > Selected Rows from the Mass Frontier main menu.

–or–

Right-click and choose Copy > Selected Rows from the shortcut menu.

When you copy a record, the application copies the graphic of the selected mass spectrum to 
the Clipboard. When you select more than one record, the application copies only the graphic 
of the spectrum in the first record to the Clipboard. You can then paste this graphic into any 
Windows application.

Tip   Mass Frontier is a 32-bit application, so you can use long names to save 
structures. You can save spectra by their actual names, such as 
1-Amino-2-hydroxyindane.mol. 

To save a spectrum with a long name, use CTRL+C to copy the name from the Info 
page, and then paste the name in the File Name box.

Note   In a read-only database library spreadsheet, you cannot use the SHIFT key or 
drag the cursor to select a range of records.

Note  You cannot copy records from the copy-protected HighChem Fragmentation 
Library. 
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To cut records

1. Select the records in the Database Manager spreadsheet.

You can cut only from an editable library.

2. Do one of the following:

Click the Cut button, , in the Mass Frontier toolbar and choose Selected Rows 
from the menu.

–or–

Choose Edit > Cut > Selected Rows from the Mass Frontier main menu.

–or–

Right-click and choose Delete > Selected Rows from the shortcut menu.

When you cut a record, the graphic of the selected mass spectrum is copied to the Clipboard. 
When you select more than one record, only the graphic of the spectrum in the first record is 
copied to the Clipboard. You can then paste this graphic into any Windows application. 

To paste records to the Work spreadsheet

1. Select the Work spreadsheet.

2. Do one of the following:

Click the Paste button, , in the Mass Frontier toolbar and select Rows from the 
menu.

–or–

Choose Edit > Paste > Rows from the Mass Frontier main menu.

–or–

Right-click and choose Paste > Rows from the shortcut menu.

To copy spectra from the Chromatogram Processor 

1. In the Chromatogram Processor window, right-click the Spectrum page and choose 
Copy > Copy MS Spectrum from the shortcut menu.

2. In the Database Manager window, right-click the Spectrum page and choose 
Paste > Spectrum from the shortcut menu.

You can now extract spectral scans and move them to the Database Manager window for 
further processing.
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Exporting Data to an Excel Spreadsheet

You can export four types of data from the Database Manager window to an Excel 
spreadsheet: text tables, graphics, mass spectra in numerical table format, and spectral trees 
(see “Copying and Pasting a Spectral Tree” on page 116). Because you can access all these 
types at the same time, you must specify the type of data you want to move to the Excel 
spreadsheet.

Follow these procedures:

• To export data records

• To export mass spectrum or mass differences graphics

• To export a mass spectrum in numerical table format

• To use an Excel spreadsheet as an editor

To export data records

1. Select one or more records on the Spreadsheet page in the Database Manager window.

2. Do one of the following:

Click the Copy button, , in the Mass Frontier toolbar and choose Selected Rows 
from the menu.

–or–

Choose Edit > Copy > Selected Rows from the Mass Frontier main menu.

3. Click the Excel spreadsheet to make it active.

4. Right-click the Excel spreadsheet, and choose Paste from the shortcut menu.

The application pastes the records into the spreadsheet.
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To export mass spectrum or mass differences graphics

1. Choose Microsoft Office > New Microsoft Excel Worksheet from the Mass Frontier 
main menu.

2. Do one of the following in the Database Manager window:

Click the Spectrum tab.

–or–

Click the Mass Differences tab.

The mass spectrum or mass differences spectrum must be visible before you can copy it. 
For detailed information about the content of the spectrum and mass differences pages, 
see Chapter 2, “Database Manager Module.” 

3. Do one of the following:

Click the Copy button, , in the Mass Frontier toolbar and choose Spectrum from 
the menu.

–or–

Choose Edit > Copy > Spectrum from the Mass Frontier main menu.

4. Click the Excel spreadsheet to make it active.

5. Right-click the Excel spreadsheet, and choose Paste Special from the shortcut menu.

The Paste Special dialog box opens.

6. Select Picture (Enhanced Metafile) and click OK.

The application pastes the spectra graphics into the spreadsheet.
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To export a mass spectrum in numerical table format

1. In a Database Manager window, click the Data tab to make the m/z and abundance table 
visible.

2. Do one of the following:

Click the Copy button, , in the Mass Frontier toolbar and choose Spectrum from 
the menu.

–or–

Choose Edit > Copy > Spectrum from the Mass Frontier main menu.

3. Click the Excel spreadsheet to make it active.

4. Right-click the Excel spreadsheet, and choose Paste from the shortcut menu. 

The application pastes the record data into the spreadsheet.

To use an Excel spreadsheet as an editor

Export a spectrum or tree to an Excel spreadsheet, edit it, and then import the edited 
spectrum or tree into the Database Manager window.

Using the Excel application’s editing features is useful when, for example, you have an 
experimental spectrum with several noise peaks at high m/z values that you want to delete 
or you want to extract part of a spectrum that is important to your report or presentation. 
For obvious reasons, do not add, delete, or alter prominent peaks.
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Importing Spectra from an Excel Spreadsheet

You can import mass spectra or spectral trees stored in an Excel spreadsheet to the Database 
Manager window (see “Copying and Pasting a Spectral Tree” on page 116). You can organize 
spectral tables horizontally or vertically. 

To import spectra from an Excel spreadsheet

1. Make sure your table contains mass spectra.

2. Select the table you want to export into the Mass Frontier application.

3. Right-click the Excel spreadsheet, and choose Copy from the shortcut menu.

4. Choose Edit > Paste > Spectrum in the Mass Frontier main menu.

To correctly interpret m/z values and abundance

Follow one of these conventions:

• When the spectral table is vertical, the first column must be the m/z value and the 
second must be abundance.

• When the spectra are vertically oriented, the first column is abundance, and the 
second column is the m/z value, label the first row of the first column “Abundance” 
and the first row of the second column “m/z.”

• When the spectral table is horizontally oriented, the first row must be the m/z value 
and the second row must be abundance.

• When the spectra are oriented horizontally, the first row is abundance, and the 
second row is the m/z value, label the first column of the first row “Abundance” and 
the first column of the second row “m/z.

”

Note  The Mass Frontier application supports standard tables with separated numbers, so 
you can also import spectra from other applications.

IMPORTANT  The third column can be accuracy in AMU. When the accuracy column is 
not present, the application uses the default value from the Tolerance Settings on the 
Options dialog box. See “Specifying Mass/Abundance Options” on page 381.
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Adding Structures to a Record

The Database Manager module uses chemical structures at every stage, and you can add these 
chemical structures to a corresponding record. You can create user libraries with structures 
including isotopes, ions, radicals, and optically active compounds. You can use structures in 
the Database Manager window in connection with the Fragments & Mechanism window to 
check the consistency of a mass spectrum and chemical structure. You can use the Database 
Manager features to perform structural elucidation by modifying the input structure and 
regenerating product fragments.

Follow these procedures:

• To add a structure to a record that contains a tree

• To add a structure to a peak

• To paste a structure to a record

• To import structures into records

• To assign a structure to a peak

• To add formatted text to a peak

• To add an annotation to a peak

To add a structure to a record that contains a tree

1. Select the appropriate node by clicking any spectrum in that node.

When dealing with spectral trees, structures are associated with nodes and not with an 
entire tree. 

2. Assign fragments for product spectra.

This is useful for elucidation and database maintenance of collision-induced dissociation 
(CID) spectra.

The top level node, MS1, holds structural information about the neutral compound. A 
structure displayed in the Database Manager window is associated with a selected node. You 
can add a structure not only to a spectrum or tree node but also to any peak.

To add a structure to a peak

1. Click the Assign Structure to m/z Value button, , in the Database Manager toolbar.

The Structure Editor – Database Manager dialog box opens.

2. Draw a fragment or open a structure.

For detailed instructions about using the Structure Editor, see “Structure Editor Module” 
on page 125.

Note  Do not confuse this button with its generic equivalent in the Mass Frontier 
toolbar, which opens a Structure Editor window that does not automatically connect 
the fragment to its spectral peak.
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3. When you finish the fragment, click OK.

Based on the fragment's m/z value, the application automatically connects your structure 
to its spectral peak in the Spectrum pane.

4. To connect the fragment to a different peak, drag the connecting circle at the baseline to 
any other peak. 

5. To resize the drawn fragment, click the fragment and drag the handles.

To paste a structure to a record

1. Copy the structure to the Clipboard.

You can copy a structure into the Database Manager window from anywhere in the Mass 
Frontier application. 

2. In the Database Manager spreadsheet, select the record you want to paste the structure 
into.

3. When processing a tree, select the node you want to paste the structure into.

4. Choose Edit > Paste > Structure from the Mass Frontier main menu.

When you add a structure to a record or replace an existing structure, the word “Updated” 
appears at the bottom of the structure pane. When you change anything in the record, 
including the structure, a small circle is displayed in the ID Number column in the 
spreadsheet. After you have added or changed a structure, the application automatically 
calculates and updates the molecular formula and molecular mass.

When you add a structure to a tree node or replace an existing structure, the Restore Precursor 
m/z button, , at the bottom of the structure pane becomes active, if the molecular mass of 
the structure differs from the existing precursor m/z value. Using this button, you can set the 
precursor m/z value of the active product spectrum according to the molecular mass of the 
drawn structure.

Note  Structures assigned to spectral peaks are not searchable.
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To import structures into records

1. In the Database Manager spreadsheet, select the records you want to add structures to.

2. Choose File > Open > Structure from the Mass Frontier main menu.

3. Select a .mol, .mcs, or .tml file and click Open.

To assign a structure to a peak

1. In the Database Manager window, click the Data tab.

The Data page lists all peaks in the spectrum. 

2. Select the row of the peak.

3. Click the Structure Editor button, , in the Fragment column.

The Structure Editor opens. 

4. In the Structure Editor, create the structure you want to assign to the selected peak, and 
click OK.

The structure is added to the peak.

For details about using the Structure Editor, see Chapter 4, “Structure Editor Module.” 

To add formatted text to a peak

1. In the Database Manager window, click the Data tab.

The Data page lists all peaks in the spectrum. 

2. Select the row of the peak.

Note  You cannot search structures assigned to spectral peaks. Structures are assigned to 
the m/z value so the annotation does not require a peak to be present in a spectrum.
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3. Click the Spectrum tab.

4. Click the Assign Text to m/z Value button, .

5. Move the cursor to the Spectrum page.

The cursor changes to a special text cursor.

6. Click the Spectrum page where you want to place the text.

The Annotation dialog box opens.

7. Enter your text.

8. To draw a line connecting the peak to the annotation, select the Show Connection Line 
check box.

9. Click OK.

The application places the text on the Spectrum page. 

Note  Text is assigned to the m/z value, so the annotation does not require that a peak be 
present in a spectrum.
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To add an annotation to a peak

1. In the Database Manager window, click the Data tab.

The Data page lists all peaks in the spectrum. 

2. Select the row of the peak.

3. Click the Annotation button, , in the Annotation column.

The Annotation dialog box opens.

4. Enter your text.

5. To draw a line connecting the peak to the annotation, select the Show Connection Line 
check box.

6. Click OK.

7. To view the annotated text, click the Spectrum tab.

The Spectrum page displays the annotated text with the optional connecting line.
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Displaying Isotope Patterns
The Isotope Pattern module displays the relevant isotopic profile when you select a structure 
or fragment in the Mass Frontier application. You can also calculate the isotope pattern from a 
your molecular formula. 

Follow these procedures:

• To display the isotope pattern for a structure

• To display the mass, abundance, and accuracy values

• To display the mass tolerance settings

• To save the spectrum as a NIST MSP file

• To zoom and pan in the graphical display

To display the isotope pattern for a structure

1. Select a structure in the Database Manager window.

2. Choose Tools > Isotope Pattern from the Mass Frontier main menu.

The Pattern page of the Isotope Pattern window opens.

3. To copy the spectra image, click the Copy as Image button, .
58 Mass Frontier User Guide Thermo Scientific



 2 Database Manager Module
Displaying Isotope Patterns
To display the mass, abundance, and accuracy values

1. Click the Values tab.

The Values page of the Isotope Pattern window opens.

2. To copy the data, click the Copy as Data button, .

To display the mass tolerance settings

1. Click the Parameters tab.

The Parameters page of the Isotope Pattern window opens.

2. Enter a maximum abundance value.
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3. Select a mass tolerance value.

The application supports these tolerance types:
• Unit

• Resolving power M/ΔM
• ppm 1 000 000 x ΔM/M
• Mass Accuracy (ΔM in AMU or ΔM in MMU)

where:

M = m/z (mass-to-charge ratio)

ΔM = M2–M1 (M1, M2 are two adjacent peaks)

Peaks (m/z values) that fall into the ΔM band are merged into a single peak (m/z value).

4. To open the Tolerance Settings dialog box where you can specify additional tolerance 
parameters, click the Program Settings button, . 

To save the spectrum as a NIST MSP file

1. From any page of the Isotope Pattern window, click the Save button, .

The Save MS Spectrum dialog box opens.

2. Type a name for the NIST MSP file (.msp), and click Save.

The application saves the report in the …\HighChem\Mass Frontier 7.0 \Spectra folder.

To zoom and pan in the graphical display

• Click the Hand button, , in the Mass Frontier toolbar and drag the hand to pan 
horizontally or vertically.
Similarly, hold down the H keyboard key or the Spacebar to change the cursor to the 
hand.

• Click the Zoom Out button, , in the Mass Frontier toolbar.

• Click the Zoom In button, , in the Mass Frontier toolbar.

• Click the Zoom to Box button, , in the Mass Frontier toolbar and describe a 
rectangle. 
Similarly, hold down the Z keyboard key and describe a rectangle.

• Click the Zoom Reset button, , in the Mass Frontier toolbar to return to full scale.

• Click the Zoom Undo button, , in the Mass Frontier toolbar to undo the last zoom 
operation.

• Click the Zoom Redo button, , in the Mass Frontier toolbar to restore the last zoom 
operation.

• Use the scroll wheel on the mouse to zoom the entire display. 
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Assigning Fragments to Spectral Peaks
Use the Mass Frontier application for the automated prediction of fragments from a structure. 
If you start the generation of fragments from Database Manager window and the active record 
contains a structure (an MS1 structure for Spectral Tree), the application automatically links 
the generated fragments with peaks in the spectra according to their m/z values. For additional 
information, see “Linking Generated Fragments with a Spectrum” on page 216.

Follow these procedures:

• To predict fragments from a structure

• To automatically assign generated fragments to peaks

• To manually assign a fragment structure to a peak

To predict fragments from a structure

1. Choose Tools > Fragments and Mechanisms from the Mass Frontier main menu.

The Reaction Restrictions dialog box opens.

2. Specify your criteria and click OK.

For details about using the Reaction Restrictions dialog box, see Chapter 6, “Fragments 
and Mechanisms Module.” 

The Fragments & Mechanisms window displays possible fragments for each explained 
peak.

Note  The selected record must contain an MS1 structure in the spectral tree.
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The application links the generated fragments with peaks in the spectrum (spectra in the 
spectral tree) according to their m/z values. On the Spectrum page, the explained peaks 
are highlighted in red. See “Linking Generated Fragments with a Spectrum” on page 216.

3. To display the mechanisms leading to an explained peak, click Mechanisms in the 
Fragments & Mechanisms window and then do one of the following:

In the Fragments & Mechanisms window, select the m/z value of a peak.

–or–

a. On the Spectrum page of the Database Manager window, hold your cursor over a 
highlighted peak.

A yellow triangle indicates the active peak.

b. Click the peak.

The Fragments & Mechanisms window displays all mechanisms leading to the selected 
peak.

Figure 27. Fragments & Mechanisms window
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To automatically assign generated fragments to peaks

1. Choose Tools > Fragments and Mechanisms from the Mass Frontier main menu.

The Reaction Restrictions dialog box opens.

2. Specify your criteria and click OK.

For details about using the Reaction Restrictions dialog box, see Chapter 6, “Fragments 
and Mechanisms Module.” 

The Fragments & Mechanisms window opens. This window must remain open to assign 
the fragments to peaks in the Database Manager window.

3. In the Database Manager window, click the Spectrum tab.

4. Right-click the Spectrum page and choose Auto Annotation > Generated Fragments 
from the shortcut menu.

The Auto Fragment Annotation of Peaks dialog box opens.

5. Specify your criteria and click OK.

The application reports the number of new fragments that are added to the spectrum.

Note  This command is not available unless the Fragments & Mechanisms window 
remains open.
Thermo Scientific Mass Frontier User Guide 63



2 Database Manager Module
Assigning Fragments to Spectral Peaks
To manually assign a fragment structure to a peak

1. Click the Assign Structure to m/z Value button, , in the Database Manager toolbar.

The Structure Editor – Database Manager dialog box opens.

2. Draw a fragment or open a structure.

For detailed instructions for using the Structure Editor, see “Structure Editor Module” on 
page 125.

3. When you finish the fragment, click OK.

Based on the fragment m/z value, the application automatically connects your structure to 
its spectral peak in the Spectrum pane.

4. To connect the fragment to a different peak, drag the connecting circle at the baseline to 
any other peak. 

5. To resize the drawn fragment, click the fragment and drag the handles.

Note  Do not confuse this button with its generic equivalent in the Mass Frontier 
toolbar, which opens a Structure Editor that does not automatically connect the 
fragment to its spectral peak.

Note  You cannot search structures assigned to spectral peaks.
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Exchanging Mass Spectral Data Between Modules
From the Database Manager window, you can import mass spectra directly from a file, the 
Chromatographic Processor, an Excel spreadsheet, or the Xcalibur data system. You can open 
as many Database Manager windows as your system allows and exchange mass spectra 
between these windows. The Mass Frontier application can automatically establish a link 
between Database Manager records and other modules that need to access spectral or 
structural data. 

You can link equivalent spectral information to access the original data that was supplied as 
input for one of the many interpretation methods available in the application. 

The direct feedback between source (records and mass spectra) and results (mechanisms, bar 
code spectra, classes, and projections) helps you keep track of all the modules that originate 
from a single source. This feature makes the simultaneous use of multiple modules easier, 
further supporting more sophisticated problem-solving approaches.

For additional information, see “Linking Generated Fragments with a Spectrum” on 
page 216, “Bar Code Spectra” on page 220, or “Accessing Spectra from a Spectra Projector 
Window” on page 367.
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Using the Library Pane
The Library pane in the Database Manager window includes vertical tabs for the Spreadsheet 
and Structures views and horizontal tabs for the installed libraries.

This section includes the following topics:

• Spreadsheet View

• Structures View

View tabs

Library tabs
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Spreadsheet View

The Spreadsheet view is organized with each record represented by a single row. The columns 
contain supplementary record information. To move a row, use the cut-and-paste functions. 
The Database Manager window does not support dragging rows. To sort a column, click the 
column header.

When you open a Database Manager window, the Work spreadsheet is empty. You can add 
records to the Work spreadsheet by conducting a search, opening spectra, or pasting records or 
stand-alone spectra. A Work spreadsheet can contain a maximum of 32000 records. For the 
current record, the application displays the associated spectrum or tree and structure 
(optional) in the upper pane. An arrow, , in the first column indicates which record is 
current. You can select more than one record, but the row with the triangle symbol is always 
the current one.

Figure 28. Spreadsheet view

Current 
compound

Selected 
compounds

Active 
compounds
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Structures View

The Structures view displays the library compounds in graphical format.

To preview all structures

1. Click the Structures tab.

The structures are organized in numbered cells. 

2. To resize a structure, drag the column or row dividers. 

Note  In the Structures view, you can select only a single record (structure).
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Processing Data-Reduced Chromatograms
Library storage of data-reduced chromatograms is not a replacement for the standard certified 
archiving procedures that the FDA (21 CFR Part 11) requires, but rather an accompaniment 
to them.

Follow these procedures:

• To import a data-reduced chromatogram from the Chromatogram Processor

• To edit or search components in data-reduced chromatograms

• To preview a chromatogram in the Chromatogram Processor window

• To access the original chromatographic data set

To import a data-reduced chromatogram from the Chromatogram Processor

1. In the Chromatogram Processor, right-click any of the panes and choose Copy > Copy 
Chromatogram from the shortcut menu.

For detailed information about using the Chromatogram Processor module, see 
Chapter 8, “Chromatogram Processor Module.” 

2. In the Database Manager window, select the appropriate level in the Spectral Tree pane.

3. Right-click and choose Paste > Chromatogram from the shortcut menu.

The application adds the chromatogram to the tree and replaces the Spectrum tab with a 
Chromatogram tab.

Chromatograms are highlighted in blue in the Spectral Tree to easily distinguish them 
from other records.

You can save data-reduced chromatograms in the Database Manager window to any 
library using the same procedure as for saving spectra or trees. 

Chromatogram 
record
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To edit or search components in data-reduced chromatograms 

1. In the Chromatogram Processor, click the Components Editor button, . 

The Components Editor window opens.

2. To search trees, do the following:

a. Choose Search > Tree from the Mass Frontier main menu.

The Library Search dialog box opens.

b. In the Libraries area, select the libraries to search.

c. Click OK.

For additional information about the Library Search parameters, see “Spectral Tree 
Search” on page 74.

Note  This feature is enabled only after you have generated components by using one 
of the Components Detection and Spectra Deconvolution features in the 
Chromatogram Processor.
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3. To search chromatographic scans, do the following:

a. Choose Search > Tree from the Mass Frontier main menu.

The Library Search dialog box opens.

b. In the Libraries area, select the libraries to search.

c. Click the Advanced tab.

d. In the Search In area, select the Chromatograms check box.

e. Click OK.

To preview a chromatogram in the Chromatogram Processor window 

1. In the Spectral Tree pane, select the chromatogram you want to preview.

2. Click the Chromatogram Processor button, , in the Database Manager toolbar. 

The Chromatogram Database Viewer opens.

The application recalls the file path to the original chromatographic data for every 
chromatographic library entry.

3. To preview other chromatograms, click the record in the Spectral Tree pane.

To access the original chromatographic data set

1. In the Database Manager window, locate the record in the library.

2. Click the Chromatogram Processor button, , in the Database Manager toolbar. 

The Chromatogram Database Viewer opens.

3. Click the Reload Original Data File button, , in the Chromatogram Database 
Viewer toolbar. 

The original data opens in a new Chromatogram Processor window.
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Using the Search Utilities
The Mass Frontier application features several query and search functions available for 
retrieving spectra, trees, chromatograms, or structures from libraries. You can simultaneously 
search every library using these search options.

Search menu commands

Search option Description

Tree Searches for the library spectral tree most closely matching an 
unknown spectral tree or subtree. For additional information, see 
“Spectral Tree Search” on page 74.

Spectrum Searches for the library spectra most closely matching an 
unknown spectrum. For additional information, see “Spectrum 
Search” on page 79.

(Sub)Structure Searches for an exact match for the query structure (structure 
search), or searches for an exact match for the structure subset 
(substructure search). For additional information, see 
“(Sub)Structure Search” on page 84.

Name Incremental name search. For additional information, see “Name 
Search” on page 91.

Formula Searches for compounds with a specified molecular formula. For 
additional information, see “Formula Search” on page 92.

Molecular Mass Searches for compounds with a specified molecular mass. For 
additional information, see “Molecular Mass Search” on page 94.

ID Number Searches for library entries with a specified ID number. For 
additional information, see “ID Number Search” on page 96.

CAS Number Searches for one or more compounds with a specified Chemical 
Abstract Service registry number. For additional information, see 
“CAS Number Search” on page 97.

Fragmentation Data Searches for fragmentation data associated with a compound. 
For additional information, see “Fragmentation Data Search” on 
page 98.

Retention Time Searches for library entries with a range of specified retention 
times. For additional information, see “Retention Time Search” 
on page 101.
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To perform a search

1. Choose Search > your specific search type. 

The Search <search type> dialog box opens. 

2. Select the library or libraries to be searched. 

3. Specify additional search criteria.

For detailed explanations of search criteria by search type, see the appropriate section:

• Spectral Tree Search

• Spectrum Search

• (Sub)Structure Search

• Name Search

• Formula Search

• Molecular Mass Search

• ID Number Search

• CAS Number Search

• Fragmentation Data Search

• Retention Time Search

4. Do one of the following:

In the Library Search dialog box, select the Merge Results into Active Database 
Manager Window check box.

The application adds the search results to the end of the Work library in the Spreadsheet 
view in an active Database Manager window. 

–or–

Clear the Merge Results into Active Database Manager Window check box.

The application opens a new Database Manager window to display the search results. 

5. Click OK.

When the search is successful, the application stores the results in the Spreadsheet view in the 
current Database Manager window or a new Database Manager window. 

Note  If the Merge Results into Active Database Manager Window check box is not 
available, there is no active Database Manager window. The application opens a new 
Database Manager window to display the search results. 
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Spectral Tree Search

The Mass Frontier application processes MSn spectra in hierarchically consistent spectral trees 
that you can search in spectral or chromatographic libraries. The Advanced page in the 
Spectral Tree Search dialog box contains options for spectral tree searching. See “Advanced 
page of the Spectral Tree Search dialog box” on page 77. 

Each node in spectral trees can consist of four types of spectra (average, composite, parallel, 
and source CID) and you can specify the type of spectra to search.

Use the Source CID Spectra option when dealing with source CID spectra. When you have a 
library that consists exclusively of source CID spectra and your unknown spectrum is also a 
source CID, you should exclude other spectra types from the search. If no such library is 
available, you can search source CID spectra in product CID spectra, but pay careful 
attention to the search results. Source CID spectra might contain fragmentation products 
from all the ions present in the source, including adduct or cluster ions, while product CID 
spectra are preferably generated from protonated or deprotonated ions.

Two combinations relate to the tree search:

• Search a single spectrum in library trees 

See “Spectrum Search” on page 79.

• Search a tree in library trees 

When you search a single spectrum in library trees, the Mass Frontier application compares 
the spectrum to every spectrum in the tree hierarchy and individually calculates the match 
factor. You can search a single spectrum in the top level only (full scan, source CID), 
everywhere except for the top level (first stage) or everywhere in the tree.

When you search a tree (unknown) against spectral trees in a library, the application compares 
the spectrum according to a special logic. See “Searching an unknown against a library” on 
page 75. It compares the corresponding spectra on an identical level (MSn stage) with a 
common precursor m/z by using an algorithm based on the optimized dot-product. The 
application ignores a spectrum that appears on one side only, which does not adversely affect 
74 Mass Frontier User Guide Thermo Scientific



 2 Database Manager Module
Using the Search Utilities
the search result. If there are several corresponding spectra (single node with average, 
composite, parallel, or other spectra), the Mass Frontier application accepts the best match 
(optimistic approach). The total match factor is calculated from all the non-zero match 
factors.

Figure 29. Searching an unknown against a library

You can search a spectral tree using two options. You can include or exclude the top tree level 
(full scan, source CID) from a search, and the MSn stage of the tree spectra can be identical 
(identity search) or not identical (subtree search):

The Spectral Tree Search dialog box includes the following pages:

• Tree page of the Spectral Tree Search dialog box

• Advanced page of the Spectral Tree Search dialog box
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Figure 30. Tree page of the Spectral Tree Search dialog box

Table 3. Tree parameters 

Parameter Description

Selected Spectrum 
Search

Changes this search to a Spectrum search. See “Spectrum Search” 
on page 79. 

Tree Search Default search type.

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.
The Off option ignores the search constraints defined in the 
Search Constraints dialog box.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.

Paste Tree Available when you have a copied spectral tree on the Clipboard. 
Lets you search for a spectral tree other than the currently selected 
spectral tree in the Database Manager window.
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Figure 31. Advanced page of the Spectral Tree Search dialog box

Table 4. Advanced parameters  (Sheet 1 of 2)

Parameter Description

Search Type

Identity Locates a library spectrum that closely matches an unknown. 
Provides an exact match of query and library structure.

Similarity Retrieves spectra library entries of similar compounds when the 
unknown is not in the library or its spectrum is distorted so badly 
that a reliable match is not possible.

Search in Nodes

Average Spectra Searches the average spectra in the spectral tree nodes.

Composite Spectra Searches the composite spectra in the spectral tree nodes.

Parallel Spectra Searches the parallel spectra in the spectral tree nodes.

Source CID Spectra Searches source collision-induced dissociation spectra in the 
spectral tree nodes.

Search In 

Spectra Searches spectra.

Chromatograms Searches chromatograms: components, selected scans, or both.
Thermo Scientific Mass Frontier User Guide 77



2 Database Manager Module
Using the Search Utilities
Method

HighChem Low 
Res

Specifies a HighChem Low Res tree comparison method.

NIST Specifies a NIST tree comparison method.

HighChem Low + 
High Res

Specifies a HighChem Low + High Res tree comparison method.

Search Selected 
Spectrum in MS^n 
Trees

Top Level Only
(SCID, Single 
Stage MS)

Searches only the top-level tree (full scan, source CID).

Ignore Top Level 
(Full Scan with 
Unspecific Ions)

Excludes the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.

Search Tree in MS^n 
Trees

Match Stage Uses an identity search with the MSn stage of the tree spectra.

Ignore Top Level 
(Full Scan with 
Unspecific Ions)

Excludes the top-level tree (full scan, source CID).

Paste Tree Available when you have a copied spectral tree on the Clipboard. 
Lets you search for a spectral tree other than the currently selected 
spectral tree in the Database Manager window.

Table 4. Advanced parameters  (Sheet 2 of 2)

Parameter Description
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Spectrum Search

The Mass Frontier application uses search algorithms developed by HighChem and the 
National Institute of Standards and Technology (NIST). The HighChem Low Res and NIST 
algorithms are based on the optimized dot-product function, and an additional term that is 
based on ratios of peak intensities. The HighChem Low + High Res algorithm is based on 
weight distance between spectra. The application includes peak accuracies when it calculates 
the match factor.

The query spectrum can originate from the Database Manager, Components Editor, or 
Chromatogram Processor modules by selecting a spectral scan in a chromatogram. In 
addition, you can paste the query spectrum from the Clipboard into the search dialog box. In 
this case, you can copy the spectrum into the Mass Frontier application only.

With the spectrum search option you can choose between Identity or Similarity searches. 
Identity searching is designed to locate a library spectrum that closely matches an unknown. 
You use similarity searching to retrieve spectra library entries of similar compounds when the 
unknown is not in the library or its spectrum is distorted so badly that a reliable match is not 
possible.

After doing a spectrum search, the application stores the search results in the Work library in 
the Spreadsheet view. After the search is complete, the application adds a match factor column 
(Match) to the Spreadsheet view. See “Spectrum search results” on page 80. The match factor 
is a number from 1 to 999 that specifies the measure of similarity between the query spectrum 
and the library reference spectrum. A match factor of 999 means a perfect match. To draw 
your attention to a match greater than 930, a “lightning” icon, , is displayed in the Match 
column of the Spreadsheet view.

The Spectrum Search dialog box includes the following pages:

• Spectrum page in the Spectrum Search dialog box

• Advanced page in the Spectrum Search dialog box
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Figure 32. Spectrum search results

If the Identity search does not provide an acceptable match—that is, the unknown has not 
been positively identified—you might use a Similarity search. In this case, the algorithm does 
not use the high mass peak index, but uses wider abundance ranges instead. The search results 
from a Similarity search can be of value in deducing structure, especially in establishing a 
structural proposal for an unknown spectrum.

To establish a structural proposal for an unknown, you can switch to the Structures view. 
From the search results of similar compounds you might recognize some common structural 
features, which are displayed in the structures grid. You can copy the structures to the 
Structure Editor and put the pieces of the structural “puzzle” together to create an initial 
structure. You can then paste this structure back into a Database Manager window to the 
record that holds the unknown spectrum. After this, comparing the peaks in the spectrum 
with generated fragments can provide valuable information about the consistency of the 
proposed structure and unknown spectrum. If the m/z values of the fragments do not match 
the spectrum, you can modify the structure and repeat this procedure. However, if the 
structures in the search results are highly diverse and dissimilar, you must combine this 
approach with other methods.
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Figure 33. Spectrum page in the Spectrum Search dialog box

Table 5. Spectrum parameters

Parameter Description

Selected Spectrum 
Search

Default. 

Tree Search Changes this search to a Tree search. See “Spectral Tree Search” on 
page 74. 

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.
The Off option ignores the search constraints defined in the 
Search Constraints dialog box.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.

Paste Tree Available when you have a copied spectral tree on the Clipboard. 
Lets you search for a spectral tree other than the currently selected 
spectral tree in the Database Manager window.
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Figure 34. Advanced page in the Spectrum Search dialog box

Table 6. Advanced parameters  (Sheet 1 of 2)

Parameter Description

Search Type

Identity Locates a library spectrum that closely matches an unknown. 
Provides an exact match of query and library structure.

Similarity Retrieves spectra library entries of similar compounds when the 
unknown is not in the library or its spectrum is distorted so badly 
that a reliable match is not possible.

Search in Nodes

Average Spectra Searches the average spectra in the spectral tree nodes.

Composite Spectra Searches the composite spectra in the spectral tree nodes.

Parallel Spectra Searches the parallel spectra in the spectral tree nodes.

Source CID Spectra Searches source collision-induced dissociation spectra in the 
spectral tree nodes.

Search In 

Spectra Searches spectra.

Chromatograms Searches chromatograms: components, selected scans, or both.
82 Mass Frontier User Guide Thermo Scientific



 2 Database Manager Module
Using the Search Utilities
Method

HighChem Low 
Res

Specifies a HighChem Low Res spectrum comparison method.

NIST Specifies a NIST spectrum comparison method.

HighChem Low + 
High Res

Specifies a HighChem Low + High Res spectrum comparison 
method.

Search Selected 
Spectrum in MS^n 
Trees

Top Level Only
(SCID, Single 
Stage MS)

Searches only the top-level tree (full scan, source CID).

Ignore Top Level 
(Full Scan with 
Unspecific Ions)

Excludes the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.

Search Tree in MS^n 
Trees

Match Stage Uses an identity search with the MSn stage of the tree spectra.

Ignore Top Level 
(Full Scan with 
Unspecific Ions)

Excludes the top-level tree (full scan, source CID).

Paste Spectrum Available when you have a copied spectrum on the Clipboard. 
Lets you search for a spectrum other than the currently selected 
spectrum in the Database Manager window.

Table 6. Advanced parameters  (Sheet 2 of 2)

Parameter Description
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(Sub)Structure Search

You can make a structure or substructure query from the Structure Editor window, the 
Database Manager window, or a fragment copied from the Fragments & Mechanism window. 

Structure and substructure searches are important features for retrieving library entries. The 
structure search is the most straightforward method for finding compounds in a library. 
Because the rules of systematic nomenclature do not necessarily lead to a unique name for 
each compound, a name search can be ineffective in many cases. Drawing or importing a 
structure query is easier than typing a complicated name or CAS number.

While a structure search (Identity search) provides an exact match of query and library 
structure, a substructure search retrieves compounds that contain a common structural subset, 
called a substructure. The exact substructure must be embedded in each molecule retrieved. 
The exact match in structure and substructure searches has a notable exception: it ignores 
stereo bonds because optical activity does not play a significant role in mass spectrometry. All 
other structural features such as bond multiplicity, atom state, and skeletal arrangement must 
match exactly. You have the option to ignore charges, radicals, and unspecified charge sites, 
and the option to disregard isotopes. See “(Sub)Structure Search Rules” on page 89.

A substructure search offers two additional search options: Substructure Best Match and 
Substructure Match Ring Bonds. A substructure can sometimes fit at several locations of a 
larger structure. When the Substructure Best Match option representing the closest match is 
found, it appears in red on the Structure page. See “(Sub)Structure search results” on page 85. 
Using this option lengthens calculation times. Because fragmentation mechanisms on rings 
significantly differ from acyclic moieties, searching substructures that exactly match the ring 
membership is useful for each bond. Using this option also lengthens calculation times.

Use a (sub)structure search for multiple purposes: 

• To study mass spectra of structurally related molecules.

• To positively identify an unknown or to interpret a mass spectrum. Compounds retrieved 
through a substructure search can provide analogies to the fragmentation processes in the 
spectrum under consideration.

When searching structures with an unspecified charge site or substituents, be aware of the 
search rules that apply. You can perform a structure similarity search using substituents.

The (Sub)Structure Search dialog box includes the following pages:

• Data page in the (Sub)Structure Search dialog box

• Advanced page in the (Sub)Structure Search dialog box

Note  A substructure search ignores the number and positions of hydrogen atoms.
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Figure 35. (Sub)Structure search results
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Figure 36. Data page in the (Sub)Structure Search dialog box

Table 7. Data parameters

Parameter Description

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.

The Off option ignores the search constraints defined in the 
Search Constraints dialog box.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.

Paste SubStructure Available when you have a copied substructure on the Clipboard. 
Lets you search for a substructure other than the currently 
selected substructure in the Database Manager window.
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Figure 37. Advanced page in the (Sub)Structure Search dialog box

Table 8. Advanced parameters  (Sheet 1 of 2)

Parameter Description

Search Type

Identity Locates a library spectrum that closely matches an unknown. 
Provides an exact match of query and library structure.

Substructure Retrieves compounds that contain a common structural subset, 
called a substructure.

Ignore Charges, 
Radicals and 
Adducts

Ignores charges, radicals, and adducts in the substructure search.

Ignore Isotopes Ignores isotopes in the substructure search.

Substructure Best 
Match

Available only with the Substructure option. A substructure can 
sometimes fit at several locations of a larger structure. When the 
Substructure Best Match option representing the closest match is 
found, it appears in red on the Structure page. Using this option 
lengthens calculation times.
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Substructure Match 
Ring Bonds

Available only with the Substructure option. Because 
fragmentation mechanisms on rings significantly differ from 
acyclic moieties, searching substructures that exactly match the 
ring membership is useful for each bond. Using this option 
lengthens calculation times.

Search in Root 
Structure

Searches for the specified molecular mass in the root structure.

Search in MS^n Trees

Top Level Only Searches only the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.

Search in 
Fragmentation 
Scheme

Top Level Only Searches only the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.

Paste SubStructure Available when you have a copied substructure on the Clipboard. 
Lets you search for a substructure other than the currently 
selected substructure in the Database Manager window.

Table 8. Advanced parameters  (Sheet 2 of 2)

Parameter Description
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(Sub)Structure Search Rules

When searching structures with an unspecified charge site or substituents (see “Editing Atom 
Properties” on page 141), the following search rules apply.

Table 9. SubStructure search rules  (Sheet 1 of 2)

Search type Query Library Search result

S True

S False

I True

I True

I False

S True

S True
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I True

S False

I True

S True

S False

I True

I False

S = Substructure search
I = Identity search

Table 9. SubStructure search rules  (Sheet 2 of 2)

Search type Query Library Search result
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Name Search

The name search option provides incremental search capabilities, or a type-ahead feature. As 
you start typing a portion of a name, the application displays a list of compounds that begin 
with the letters typed. The chemical structure is displayed for the highlighted name. You can 
use the up and down arrows to browse the displayed names. 

The name search covers all three name types—IUPAC, Synonyms\References, and 
Commercial Product—as defined on the Info page. 

Figure 38. Name Search dialog box

Table 10. Name Search parameters 

Parameter Description

Enter Name Text that the search process matches in the selected libraries.

Anywhere in the Name Matches the entered text anywhere it appears in the name. 

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.
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Formula Search

The formula search option searches for all compounds with a specific molecular formula. You 
can use lowercase letters to enter the formula, unless it leads to an ambiguous query (for 
example, “si” could be interpreted as Si or SI). Use the correct case to avoid misinterpretation.

The Formula Search dialog box includes the following pages:

• Formula page in the Formula Search dialog box

• Advanced page in the Formula Search dialog box

Figure 39. Formula page in the Formula Search dialog box

Table 11. Formula parameters

Parameter Description

Enter Formula Specifies the formula to search for.

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.

The Off option ignores the search constraints defined in the 
Search Constraints dialog box.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.
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Figure 40. Advanced page in the Formula Search dialog box

Table 12. Advanced parameters

Parameter Description

Search in Root 
Structure

Searches for the specified molecular mass in the root structure.

Search in MS^n Trees

Top Level Only Searches only the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.

Search in 
Fragmentation 
Scheme

Top Level Only Searches only the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.
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Molecular Mass Search

The molecular mass search option retrieves all compounds matching the queried molecular 
mass with a mass tolerance of 0.5 mass units. The results are ranked according to their 
closeness to the queried molecular mass.

The Molecular Mass Search dialog box includes the following pages:

• Molecular Mass page in the Molecular Mass Search dialog box

• Advanced page in the Molecular Mass Search dialog box

Figure 41. Molecular Mass page in the Molecular Mass Search dialog box

Table 13. Molecular Mass parameters

Parameter Description

Enter Molecular Mass Specifies the molecular mass of the compounds. The search 
results include all compounds that match the specified whole 
number with a tolerance of 0.5 mass units.

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.

The Off option ignores the search constraints defined in the 
Search Constraints dialog box.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.
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Figure 42. Advanced page in the Molecular Mass Search dialog box

Table 14.  Advanced parameters

Parameter Description

Search in Root 
Structure

Searches for the specified molecular mass in the root structure.

Search in MS^n Trees

Top Level Only Searches only the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.

Search in 
Fragmentation 
Scheme

Top Level Only Searches only the top-level tree (full scan, source CID).

Everywhere Searches the entire tree.
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ID Number Search

Each library entry is individually numbered. The ID number option searches for a single ID 
number or for a range of ID numbers. The ID search dialog box contains two edit boxes to 
input the ID range: From and To boxes. To retrieve a single ID number, leave the To box 
blank. The Max. ID box displays the maximum ID number that can be found. 

Figure 43. ID Number Search dialog box 

Note  When you delete a record from a library, the Spreadsheet view decrements the ID 
numbers of records with a higher ID than the deleted record. This means that deleting 
one or more records leaves no ID number gaps in the library.

Table 15. ID Number parameters 

Parameter Description

From/To Specifies a range of record numbers from the first column of the 
library Spreadsheet view.

Max ID Specifies the highest record number in the Spreadsheet view.

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.
The Off option ignores the search constraints defined in the 
Search Constraints dialog box.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.
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CAS Number Search

The Chemical Abstract Service (CAS) registry number search option is available for all 
libraries. Do not enter dashes when entering CAS numbers; the dashes automatically appear.

Figure 44. CAS Number Search dialog box 

Table 16. CAS Number parameters

Parameter Description

Enter CAS Number Specifies the 8-digit CAS number.

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.

The Off option ignores the search constraints defined in the 
Search Constraints dialog box.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.
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Fragmentation Data Search

The fragmentation data search option searches for a compound on the Info page. See “Using 
the Info Page” on page 38.

The Fragmentation Data Search dialog box includes the following pages:

• Data page in the Fragmentation Data Search dialog box

• Advanced page in the Fragmentation Data Search dialog box

Figure 45. Data page in the Fragmentation Data Search dialog box

Table 17. Data parameters  (Sheet 1 of 2)

Parameter Description

Title Specifies the keywords to search for.

Author Name of any of the authors as specified in the Fragmentation 
Scheme data on the Info page. See “Using the Info Page” on 
page 38.
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Journal Name of the journal as specified in the Fragmentation Scheme 
data on the Info page. See “Using the Info Page” on page 38.

Volume Volume number as specified in the Fragmentation Scheme data 
on the Info page. See “Using the Info Page” on page 38.

Year Year of the publication as specified in the Fragmentation Scheme 
data on the Info page. See “Using the Info Page” on page 38.

Page from / Page to Page range as specified in the Fragmentation Scheme data on the 
Info page. See “Using the Info Page” on page 38.

Comment Comment as specified in the Fragmentation Scheme data on the 
Info page. See “Using the Info Page” on page 38.

Instrument Name of the instrument as specified in the Fragmentation 
Scheme data on the Info page. See “Using the Info Page” on 
page 38.

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.

Table 17. Data parameters  (Sheet 2 of 2)

Parameter Description
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Figure 46. Advanced page in the Fragmentation Data Search dialog box

Table 18. Advanced parameters

Parameter Description

Records

Active/Inactive/Any Active status of records as specified in the Active column of the 
Spreadsheet view for the library.

Polarity

+/–/Any Polarity as specified in the Fragmentation Scheme data on the 
Info page. See “Using the Info Page” on page 38.

Ionization Method Method of ionization as specified in the Fragmentation Scheme 
data on the Info page. See “Using the Info Page” on page 38.

Mass Analyzer Mass analyzer as specified in the Fragmentation Scheme data on 
the Info page. See “Using the Info Page” on page 38.

Ion Activation Method of ion activation as specified in the Fragmentation 
Scheme data on the Info page. See “Using the Info Page” on 
page 38.
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Retention Time Search

Each spectrum of a tree or stand-alone spectrum of a record can include a retention time value 
(Spectrum Info/Scan Info/RT item on the Info page). Using the retention time search, you 
can retrieve spectra whose retention time values fit into a range of retention values.

Figure 47. Retention Time Search dialog box

Table 19. Retention Time parameters  (Sheet 1 of 2)

Parameter Description

Enter RT / +/– Retention time range to search.

Format

Decimal Specifies the retention time in base 10.

Hexagesimal Specifies the retention time in base 60.

Libraries Specifies the libraries to search. You can search both read-only 
and user libraries.

Constraints The On option applies the search constraints defined in the 
Search Constraints dialog box. See “Search Constraints” on 
page 103.

The Off option ignores the search constraints defined in the 
Search Constraints dialog box.
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Search In

Spectra Searches spectra.

Chromatograms Searches chromatograms: components, selected scans, or both.

Merge Results… • When selected, the application displays the search results in 
the current Database Manager window and adds the search 
results to the Work spreadsheet.

• When cleared, the application displays the search results in a 
new Database Manager window.

Table 19. Retention Time parameters  (Sheet 2 of 2)

Parameter Description
102 Mass Frontier User Guide Thermo Scientific



 2 Database Manager Module
Using the Search Utilities
Search Constraints

You can restrict all search types, except the name search, by a set of constraints. The dialog 
boxes for each of these searches contain an option for activating constraints and a button for 
editing search constraints. When you click Edit, the Search Constraints dialog box opens for 
setting specific criteria to search selected libraries for matches. See “Search Constraints dialog 
box with default settings” on page 104.

Four constraint types are available: Molecular Mass range, Number of Atoms range, Allowed 
Elements, and Good-Bad List. Searches conducted with activated constraints can be time 
consuming because each library entry is examined to find those that match the criteria you 
have set. The search constraints are especially useful when you have large libraries and want to 
retrieve search results that are of interest for your specific problem.

Use the Good List (required substructures) when you want to focus your search results on the 
particular compound classes you are most interested in. The Bad List (forbidden 
substructures) eliminates from a result list all structures containing unwanted functional 
groups. For example, you can use the Good-Bad List in a search of acids with a specific 
molecular formula, or you can search for spectra similar to an unknown, with the requirement 
that ketones may not appear in the result list. 

The following example shows a Search Constraints dialog box with C, N, and O as allowed 
elements. The Good-Bad list is set for esters as a required (good) functional group and for 
naphthalene as a forbidden (bad) functional group. 

Figure 48. Search Constraints example

Carbon, Nitrogen, and Oxygen 
are allowed elements

Esters group is required (good).
Naphthalene group is forbidden (bad).
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Figure 49. Search Constraints dialog box with default settings

Table 20. Search Constraints parameters

Parameter Description

Molecular Mass
From/To

Searches for molecular masses in the specified range.

Number of Atoms
From/To

Searches for compounds with the number of atoms in the 
specified range.

Allowed Elements Specifies the elements you want to include in your search.

Allow All Selects the check boxes for all elements.

Disallow All Clears the check boxes for all elements.

Good-Bad List Specifies the required (good) and forbidden (bad) substructures to 
used to refine your search. Each check box can be in one of three 
states: Required, Ignored, or Forbidden. 

Ignore All Clears all substructures in the Good-Bad list.

Legend Displays the check box symbols used to indicate Required, 
Ignored, or Forbidden substructures in the Good-Bad list. 

Restore Defaults Resets the default values for all areas on the page.
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Spectral Tree Module

The  Mass Frontier application uses spectral tree representation for MSn spectra. The tree 
structure best reflects the hierarchical spectra dependencies in tandem experiments. The 
graphical user interface provides for the management and processing of spectral trees. You can 
reconstruct spectral trees from data files, automatically extract them from data-dependent 
chromatographic components, or manually create them. For additional information, see 
“Using Components Detection and Spectra Deconvolution” on page 299.

All the spectral modules support trees except the Spectra Classifier, which uses total composite 
spectra generated from trees. The Mass Frontier application uses a newly developed algorithm 
for comparing spectral trees, which is integrated in the database search procedures.

With spectral tree components, you can do any of these tasks:

• Store and search trees in libraries.

• Annotate every node spectrum.

• Create chromatographic libraries.

• Exchange trees between modules using copy-and-paste commands.

• Export and import spectral trees from or to an Excel spreadsheet in text format. 

Contents

• Spectral Tree Window

• Generating a Spectral Tree

• Copying and Pasting a Spectral Tree

• Spectral Tree Node Items

• Searching Spectral Trees

• Spectral Tree Chromatograms

Note  Most management and processing actions distinguish between a single spectrum 
and a tree. When handling data that contains trees, be very clear whether you want to 
apply a particular action to an entire tree or a selected single spectrum. The displayed 
information is also associated with the tree, the spectrum, or both depending on the 
information type. For additional information, see “Using Records in the Database 
Manager Window” on page 37.
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Spectral Tree Window

Spectral Tree Arrangement

The  Mass Frontier application uses spectral tree representation for MSn spectra. A spectral 
tree consists of the following components.

Table 21. Spectral Tree components

Components Description

Levels Symbolize MSn stages starting at n=1.

Nodes Holders of node items.

Node connectors Graphical symbols of precursor m/z values, or precursor m/z ranges 
if the isolation width is included.

Node items Stand for the product or calculated spectra of identical precursor 
m/z values or m/z ranges or for chromatograms.
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Node product spectra, called parallel spectra, represent spectra acquired at various collision 
energies and isolation widths or that use wideband activation. They can also be zoom spectra, 
source CID spectra, or any other spectra that enhance reproducibility in compound 
identification. If a node contains more than two parallel spectra, the average and composite 
spectra are automatically calculated. In addition to spectra, each node can contain a 
chromatogram (see “Spectral Tree Chromatograms” on page 123).

Figure 50. Parallel spectra

Figure 51. Nodes

You can store complete trees in a library and update them at any time. For additional 
information, see Chapter 5, “Library Utilities.”  Any complementary information associated 
with a single stage spectrum or a chromatogram can be associated with a node spectrum or 
node chromatogram (see “Using the Info Page” on page 38).

Note  Chemical structures are associated with nodes and not with entire trees. This means 
you can assign fragments for product spectra. The top-level node MS1 should hold the 
structure of the neutral compound.

Parallel product spectra 
from any precursor ion 
can be stored and 
searched (various 
collision energies, 
average and composite, 
SCID, wide-band 
activation, isolation 
width).
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Spectral Tree Layout

A spectral tree consists of levels, nodes, node connectors, and node items. Node items are 
divided into five groups that are differentiated by the displayed color: Single, Average, 
Composite, Source CID spectrum, and Chromatogram. 

Because display and editing actions affect the selected node item, its color helps distinguish 
item selection.  For additional information, see “Manually Create and Edit a Spectral Tree” on 
page 114.

To change color settings 

1. Choose Options > Settings from the Mass Frontier main menu.

The Options dialog box opens.

2. Click Spectrum in the Layouts section.

The Spectrum page of the Options: Spectrum & Tree Layout dialog box opens.

3. Click the MS Tree tab. 

The MS Tree page opens.

4. Make your color selections and click OK.
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Generating a Spectral Tree
You can use any of these methods to create a spectral tree:

• Reconstruct a Tree from Multiple Raw Data Files

• Reconstruct a Tree from a Single Raw Data File

• Generate Trees from Chromatographic Components

• Manually Create and Edit a Spectral Tree

The tree reconstruction automatically assigns node spectra to specific node utilities in 
addition to creating levels, nodes, and node connections.
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Reconstruct a Tree from Multiple Raw Data Files

The spectral tree reconstruction feature reads Xcalibur raw data files and automatically creates 
a tree according to the precursor m/z and isolation width values. All files (spectra) in a 
directory should be from an identical chemical entity (compound or chromatographic 
component)—one directory per tree per compound. This feature works on Xcalibur raw data 
files acquired using direct injection and a single MSn stage. Each file in a directory can be 
separately acquired at a specific collision energy and can be a wideband activation spectrum or 
a zoom or source CID spectrum. The sample preparation can also be diverse (pH, 
concentration, buffer, and so on). Example files are available in the following directory on a 
Windows XP system:

C:\Documents and Settings\All Users\Documents\ HighChem\
Mass Frontier 7.0\Chromatograms

To import trees using tree reconstruction

1. Do one of the following:

Right-click the tree pane in Database Manager and choose Import > MS Trees from the 
shortcut menu.

–or –

Choose File > Import > MS Trees from the Mass Frontier main menu.

The Select Directories dialog box opens.

2. In the Directories pane, select a directory to import. 

You can view the contents of the selected directory in the Directory Content pane.

Note  The directory location on the Windows Vista operating system varies depending on 
the version.
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3. Click Add Directory.

The selected directory appears in the Directories Ready for Import pane.

4. Repeat steps 2 and 3 for as many directories as you want.

5. Click Import.

The imported directories create MSn libraries. 
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Reconstruct a Tree from a Single Raw Data File

You can create a spectral tree for a reference compound by reading various MSn spectra 
acquired through direct infusion in one run and stored in a single raw data file. 

To create a spectral tree from a single run using tree reconstruction 

1. Do one of the following:

Choose Tools > Chromatogram Processor from the Mass Frontier main menu.

–or–

Click the Chromatogram Processor icon, , in the Mass Frontier toolbar.

The Open Chromatogram dialog box opens.

2. Select a direct infusion file and click Open. 

The file opens in the Chromatogram Processor window. 

3. Do one of the following:

Click the Components Detection & Spectra Deconvolution icon and choose Direct 
Infusion from the menu.

–or–

Right-click and choose Component Detection > Direct Infusion from the shortcut 
menu.

The Direct Infusion Spectral Tree Construction dialog box opens. For additional 
information, see “Direct Infusion Algorithm” on page 315.
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Figure 52. Direct Infusion Spectral Tree Construction dialog box

4. Specify your parameters and click Calculate.

5. When the process finishes, click Close.

6. In the Chromatogram Processor window, click a component triangle in the TIC pane.

The reconstructed spectral tree is displayed in the lower pane. 

Figure 53. Chromatogram Processor window
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Generate Trees from Chromatographic Components

You can generate spectral trees from chromatographic components. To create a tree from a 
chromatogram, use the Component Detection & Spectra Deconvolution feature in the 
Chromatogram Processor module. For additional information, see “Using Components 
Detection and Spectra Deconvolution” on page 299. 

Manually Create and Edit a Spectral Tree

You can manually create and edit spectral trees in the Spectral Tree pane in the Database 
Manager window. You can construct a tree by creating an empty tree framework, adding new 
nodes, and then successively pasting or importing spectra into the nodes. 

Follow these procedures:

• To open a Spectral Tree window from the toolbar

• To add a new node

• To define the precursor m/z value

• To edit the node caption of a parallel spectrum or chromatogram

To open a Spectral Tree window from the toolbar

Click the Spectral Tree icon, , in the Database Manager toolbar.

To add a new node

1. Right-click the parent node and choose Add > Add Node from the shortcut menu.

This command is available only for editable libraries.

2. Fill an empty node with a spectrum from the Clipboard or import one from a file.

a. Right-click the node and choose Paste > Paste Parallel Spectrum. 

This command is available only when the Clipboard contains a spectrum. 

b. To add another empty node product spectrum (parallel spectrum), right-click the 
node and choose Add > Add Parallel Spectrum. 

A node can contain only one empty parallel spectrum. If you add more than one 
parallel spectrum to the node, the application automatically generates the average and 
composite parallel spectra, which are differentiated by color. 

If you import a raw data file into the node, the application calculates the average spectrum 
from all scans. 

You cannot import a chromatogram raw data file into a spectrum node. To create a node with 
a chromatogram, paste a data-reduced chromatogram from the Chromatogram Processor 
module. For additional information, see “Spectral Tree Chromatograms” on page 123 and 
“Searching Chromatographic Libraries” on page 182.
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To define the precursor m/z value

Do one of the following:

Type the value in the edit box in the Structure pane.

–or–

a. Paste or draw the ionic product fragment into the Structure pane. 

b. Click the Restore Precursor m/z icon, , in the lower right corner of the 
Structure pane. 

For additional information, see “To paste a structure to a record” on page 54.

A tree must have precursor m/z values and the isolation width of the product nodes. The Mass 
Frontier application automatically determines the default value of the isolation width, but you 
can manually change it.

To edit the node caption of a parallel spectrum or chromatogram

Double-click the caption label and type the new formatted text into the Annotation 
dialog box.

Precursor -ion m/z value

Node caption
Isolation 
width range
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Copying and Pasting a Spectral Tree
You can exchange trees among windows, records, chromatographic components, or 
applications (for example, Excel). 

For additional information, see “Using Records in the Database Manager Window” on 
page 37 or “Processing Data-Reduced Chromatograms” on page 69.

Follow these procedures:

• To copy a spectral tree from a Chromatogram Processor to a Database Manager

• To copy a spectral tree from a Database Manager to an Excel spreadsheet

• To copy a spectral tree from a Chromatogram Processor to an Excel spreadsheet

Figure 54. Copying data in a Mass Frontier window
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To copy a spectral tree from a Chromatogram Processor to a Database Manager 

1. Right-click the Chromatogram Processor spectrum pane and choose 
Copy > Copy MS Tree from the shortcut menu.

2. In the Database Manager tree pane, right-click and chose Paste > Tree from the shortcut 
menu.

The application pastes your spectral tree and the associated spectrum in the Database 
Manager tree pane.

To copy a spectral tree from a Database Manager to an Excel spreadsheet

1. Right-click the Database Manager tree pane and choose Copy > Tree from the shortcut 
menu.

Note  There is no shortcut menu in the tree pane itself; you must right-click the 
spectrum pane.

Right-click here
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2. In the Excel spreadsheet, right-click and chose Paste from the shortcut menu.

The application pastes your spectral tree graphic in the spreadsheet.

To copy a spectral tree from a Chromatogram Processor to an Excel spreadsheet

1. Right-click the Chromatogram Processor spectrum pane and choose Copy > Copy MS 
Tree from the shortcut menu.

2. In the Excel spreadsheet, right-click and chose Paste from the shortcut menu.

The application pastes your spectral tree graphic in the spreadsheet.

Note  There is no shortcut menu in the tree pane itself; you must right-click the 
spectrum pane.

Right-click here
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Spectral Tree Node Items
Some mass spectrometry techniques can generate spectra whose appearance depends on the 
experimental conditions and sample preparation. To manage and search diverse product 
spectra with an identical precursor ion for a single chemical entity, the Mass Frontier 
application uses spectral trees that can contain nodes with several node items. The node item 
stands for any product or calculated spectrum of an identical precursor m/z value or m/z range 
(node spectra), or for a chromatogram.

Node product spectra represent spectra that were acquired at various collision energies and 
isolation widths or that use wideband activation. They can also be zoom spectra, source CID 
spectra, or any other spectra that enhance reproducibility in compound identification. If a 
node contains more than two parallel spectra, the application automatically calculates the 
average and composite spectra. In addition to spectra, each node can contain a 
chromatogram.

You might use node spectra for any of these reasons:

• They can significantly contribute to correct compound identification in a tree library 
search.

• They allow the study of fragmentation processes by changing the experimental 
conditions.

• They permit the efficient organization of product spectra. 

The spectral node strategy strengthens the robustness of all the mathematical processing 
methods and, compared to simple spectra averaging, does not distort the highly nonlinear 
peak ratio progress.

You can easily access node spectra from a library and create or edit them using the graphical 
interface. Every tree item has an editable annotation caption.

You can select node items by clicking the edge of the spectral or chromatographic node item, 
or by browsing in the box displayed below the tree. 
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Searching Spectral Trees
You can use the Mass Frontier application for processing MSn spectra in hierarchically 
consistent spectral trees that can be searched in spectral or chromatographic libraries. Select 
from various options on the Advanced page in the Spectra or Tree Search dialog box. Each 
node in spectral trees can consist of four types of spectra (average, composite, parallel, and 
source CID), and you can specify the type of spectra that is searched. For additional 
information, see “Processing Data-Reduced Chromatograms” on page 69 or “Spectral Tree 
Arrangement” on page 106.

To perform a spectral tree search

1. Do one of the following:

Click the Search button, , in the Database Manager window and choose Tree 
from the menu.

–or–

Choose Search > Tree from the Mass Frontier main menu.

The Tree page of the Spectral Tree Search dialog box opens.

2. Select either the Selected Spectrum Search option or the Tree Search option.

3. In the Libraries area, select the Active check box for the libraries you want to search.
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4. Click the Advanced tab.

The Advanced page of the Spectral Tree Search dialog box opens.

5. In the Search in Nodes area, select the types of nodes you want to search.

If you have a library that consists exclusively of source CID spectra and your unknown 
spectrum is also a source CID, select only the Source CID Spectra check box. If no such 
library is available, you can search source CID spectra in product CID spectra, but use 
care regarding the search results. Source CID spectra might contain fragmentation 
products from all the ions present in the source, including adduct or cluster ions, while 
product CID spectra are preferably generated from protonated or deprotonated ions.

6. If you selected the Selected Spectrum Search option on the Tree page, select one of the 
following search options.

The application compares the spectrum to every spectrum in the tree hierarchy and 
individually calculates the math factor. 

• Top Level Only—Searches only the top-level tree (full scan, source CID).

• Ignore Top Level—Excludes the top-level tree (full scan, source CID).

• Everywhere—Searches the entire tree.
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7. If you selected the Tree Search option on the Tree page, select one of the following search 
options.

• Ignore Top Level—Excludes the top-level tree (full scan, source CID).

• Match Stage—Uses an identity search with the MSn stage of the tree spectra.

When you search a tree (unknown) against spectral trees in a library, the application compares 
the spectrum according to a special logic. It compares the corresponding spectra on an 
identical level (MSn stage) with a common precursor m/z by using an algorithm based on the 
optimized dot-product. The application ignores a spectrum that appears on one side only, 
which does not adversely affect the search result. If there are several corresponding spectra 
(single node with average, composite, parallel, or other spectra), the Mass Frontier application 
accepts the best match (optimistic approach). The total match factor is calculated from all the 
non-zero match factors.
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Spectral Tree Chromatograms
The Mass Frontier application supports spectral trees that can contain nodes with 
data-reduced chromatograms. You can assign chromatograms to every node, which lets you 
store product ion chromatograms for a particular precursor m/z value.

For additional information, see “Searching Chromatographic Libraries” on page 182, 
“Copying and Pasting a Spectral Tree” on page 116 or “Manually Create and Edit a Spectral 
Tree” on page 114.

In contrast to spectra, the application limits you to only one chromatogram per node. Tree 
chromatograms with components or selected scans are fully searchable. You can review or 
reload a node chromatogram from the original data file in the Chromatogram Database 
Viewer. For additional information, see “Processing Data-Reduced Chromatograms” on 
page 69.

To open the Chromatogram Database Viewer 

Click the Show Complete Chromatogram icon, , in the Database Manager toolbar. 

The Chromatogram Database Viewer window opens.

You can edit node chromatogram components or selected scans in the Components 
Editor window. For additional information, see Chapter 9, “Components Editor 
Module.”  
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4

Structure Editor Module

Structural information is essential for interpreting and investigating structure-spectra 
relationships because mass spectra reflect the structural features of molecules. With the 
Structure Editor drawing tool, you can interactively handle all kinds of structural 
information. Use the Structure Editor to edit, import, export, and check chemical structures. 

Contents

• Working with the Structure Editor

• Customizing the Structure Layout

• Using Templates

• Modifying Atoms and Bonds

• Using Toolbar Functions

• Displaying the Monoisotopic Molecular Mass
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Working with the Structure Editor
You can open multiple Structure Editor modules in the Mass Frontier application. Use the list 
in the Mass Frontier main window to switch between them.

The Structure Editor supports two kinds of structure formats: 

• Molecular Design Ltd. MOL or SDF files with the .mol or .sdf extension

• HighChem, Maximal Compressed Structure format with the .mcs extension

These formats are also supported in the Database Manager module. Templates are stored in 
MCS format, using the .tml extension. For additional information, see “Using Templates” on 
page 137. 

The Mass Frontier application restricts searches using a set of structural constraints or the 
“Good-Bad” list. For example, you can instruct the system to conduct a library search 
comparing an unknown spectrum with only the spectra of ketones. This feature provides 
many possibilities for targeting your search results. For additional information, see “Search 
Constraints” on page 103.

The “Good-Bad” structures are stored in the …\Constraints directory, and the structures are 
saved in MCS format (.mcs). The Mass Frontier application automatically retrieves all MCS 
structures from the Constraints directory and puts them in a “Good-Bad” list in the 
Constraints dialog box.

Follow these procedures:

• To open the Structure Editor window

• To begin drawing a chemical structure

• To change the size of the Structure Editor window

• To restore the default state of the Structure Editor

• To open a structure

• To save a structure
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To open the Structure Editor window

Do one of the following:

Click the Structure Editor button, , in the Mass Frontier toolbar.

–or– 

Choose Tools > Structure Editor from the Mass Frontier main menu.

The Structure Editor window opens.

Figure 55. Structure Editor window
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To begin drawing a chemical structure

1. Click any of the buttons in the vertical toolbar. 

The cursor changes shape to represent the current drawing mode. 

2. Do one of the following:

Click the drawing area to place an element.

–or–

Drag the cursor to create elements such as single/double/triple bonds or a chain.

All elements are recursive—that is, the application draws a new element each time you click.

To change the size of the Structure Editor window

Drag the borders of the Structure Editor to change the width or height.

With a smaller window, you can have several open modules on your application window; 
a larger window gives you more drawing area.

To restore the default state of the Structure Editor

Do one of the following:

Click the Default Mode button, , in the upper left corner of the window.

–or–

Right-click the drawing area and choose Default Mode from the shortcut menu.

By default, no drawing element is selected. The plain arrow cursor indicates that the 
Structure Editor is in the default state. 

Note  Holding your cursor over each drawing button displays a ToolTip that describes the 
type of structure each element creates.
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To open a structure

Click the Open Structure button, , select a structure, and click Open. 

When you open a file that contains more than one structure (.sdf file), only the first 
structure in the file is loaded into the Structure Editor.

To save a structure

1. Do one of the following:

Click the Save Structure button, .

–or–

Choose File > Save > Structure from the Mass Frontier main menu.

2. Specify a structure name in the .mol format.

Because Mass Frontier is a 32-bit application, you can save structures under their actual 
names, regardless of length (for example, 1-Amino-2-hydroxyindane.mol).
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Customizing the Structure Layout 
You can change the way structures and other objects are displayed in the Structure Editor 
drawing area. The various layout items help tailor the graphics to your individual report or 
publication needs.

The structure layout settings apply to all structures in the application. Changing a structure 
layout item affects all structures in the Structure Editor, Database Manager, Fragments and 
Mechanisms, and Fragments Comparator modules. 

Follow these procedures:

• To open the Structure Layout dialog box

• To return all options to their defaults

• To display carbon symbols

• To display hydrogen symbols

• To display the symbols for hydrogen atoms attached to carbon atoms

• To edit the font for atoms

• To change the appearance of bonds

• To change the color of the background and selected atoms

• To enter a text note

• To change the text notes
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To open the Structure Layout dialog box

1. Choose Options > Settings from the Mass Frontier main menu.

The Options dialog box opens.

2. Click Structure in the Layouts section.

The Atom & Bond page of the Structure Layout dialog box opens.

To return all options to their defaults

1. Click Restore Default.

The Restore Default Setup dialog box opens.

2. Do one of the following:

To reset the default values for only the options in the selected category (in this case, the 
Structure pages), select the Only for Active Category option.

–or–

To reset all the settings in the Options dialog box to their defaults, select the All 
Categories option.

3. Click OK. 
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To display carbon symbols

In the Atom area, select the Show Carbon Symbols check box.

Carbon symbols are displayed in the Sample area.

To display hydrogen symbols

In the Atom area, select the Show Hydrogens Automatically check box.

Hydrogen symbols are displayed in the Sample area.

By default, the Structure Editor displays hydrogen symbols for heteroatoms only. It does 
not display the symbols for hydrogen atoms attached to carbon atoms. 

To display the symbols for hydrogen atoms attached to carbon atoms

In the Atom area, select both the Show Carbon Symbols and the Show Hydrogens 
Automatically check boxes.

Hydrogen symbols and hydrogen atoms attached to carbon atoms are displayed in the 
Sample area.

When you draw non-isotopic explicit hydrogen atoms, the application removes them in 
the Fragments and Mechanisms module because they can make the mechanism network 
unclear, especially for complex hydrogen rearrangement steps. A substructure search 
ignores the number and positions of hydrogen atoms.
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To edit the font for atoms

1. In the Atom area, click the Font button, .

The Font dialog box opens.

2. Specify the way you want your font to appear and click OK.

To change the appearance of bonds

In the Bond area, select the Length, Thickness, or Color for your symbols.

Tip  (For black-and-white print only) If you have set bright colors for bonds or atoms, 
the lines and fonts might appear indistinct. To avoid this problem, specify darker 
colors for all structural items, including spectra, chromatograms, and mechanisms.
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To change the color of the background and selected atoms

1. Click the Additional tab.

The Additional page of the Structure Layout dialog box opens.

2. In the Colors area, do the following:

a. Select a color for the background of the drawing area in the Structure Editor, as in the 
following example.

When you copy the structures to the Clipboard or print the structures, the 
background color remains white.

b. Select a color for the selected atoms in the drawing area.

Use the Sample area to identify an appropriate combination of colors for the 
background and selected atoms. 
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To enter a text note

1. Click the Text button, .

2. Click the drawing area to place the text.

3. Type the text.

4. Confirm the text by clicking outside the text area or clicking any button in the Structure 
Editor window.

You can label a structure or display a text note on the screen or on the printout. You can create 
up to 127 separate text notes. To change the font, color, size, or background of the text notes, 
see “To change the text notes” on page 136.

Note  Text notes are not associated with structures. The Open, Save, Copy, and Paste 
commands apply only to structures. When you use these commands, the Structure Editor 
ignores the text notes even when you select a structure together with a text. Additionally, 
you can perform structure-handling routines, such as resizing, rotating, or mirroring only 
on structures.
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To change the text notes

1. Click the Additional tab.

The Additional page of the Structure Layout dialog box opens.

2. In the Text area, click the Font button, .

The Font dialog box opens.

3. Specify the way you want your font to appear and click OK.

4. To add a box around the text, do the following:

a. Select the Text Box check box.

b. From the Colors list, select a fill color for the text box.

Example filled text box:
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Using Templates
The Mass Frontier application comes with more than 200 predefined templates. 

Follow these procedures:

• To open the Templates dialog box

• To insert a template structure into the Structure Editor

• To build your own templates

To open the Templates dialog box

Click the Templates button, .

The Templates dialog box opens.

To insert a template structure into the Structure Editor

1. Select a group of templates in the directory list. 

The upper pane displays the structures of the selected group.

2. Click an atom or bond of a structure, depending on whether you want to attach the 
template to an atom or a bond of a structure in the Structure Editor.

The Templates dialog box closes.
Thermo Scientific Mass Frontier User Guide 137



4 Structure Editor Module
Using Templates
3. Click the drawing area of the Structure Editor to place or attach the selected template 
structure.

4. Right-click and choose Default Mode from the shortcut menu to stop placing the 
selected structure. 

The application continues to place the selected template structure each time you click 
until you return to default mode or select another drawing tool. 

To build your own templates

1. Draw a template structure in the Structure Editor.

2. Click the Save Structure button, , or choose File > Save from the Mass Frontier 
main menu.

The Save Structure dialog box opens.

3. Select the Template (*.tml) format in the Save as Type list of the Save Structure dialog 
box.

The application stores each group of templates in a separate subdirectory of the template 
root directory. Subdirectories are named after compound groups (for example, Steroids). 
The files within each subdirectory are named after actual structures using the .tml 
extension (for example, Cholesterol.tml). 

4. Navigate to the following directory:

Program Files\HighChem\Mass Frontier 7.0\Templates

5. To save your template to an existing templates folder, do the following:

a. Select the folder.

b. In the File Name box, name the template.

c. Click Save.

6. To save your template to a new templates folder, do the following:

a. Right-click the Save Structure dialog box.

b. Choose New > Folder from the shortcut menu.

c. Name and select the new folder.

d. In the File Name box, name the template.

e. Click Save. 
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Modifying Atoms and Bonds
Any modification that you make to a structure applies only to the selected atoms or bonds. 
When you initiate a (Sub)Structure search, the application automatically searches for the 
selected atoms or bonds. For additional information, see “(Sub)Structure Search” on page 84.

This section includes the following topics:

• Selecting Atoms and Bonds

• Editing Atom Properties

• Editing Bond Properties

• Understanding Unspecified Bond Locations

• Understanding Unspecified Charge Sites

Selecting Atoms and Bonds

The Structure Editor uses function buttons and menus to manipulate the atom and bond 
structures.

Follow these procedures:

• To select a group of atoms

• To select all of the atoms and bonds in the structure

• To choose a selection mode

• To move a structure

To select a group of atoms 

Do one of the following:

To select a group of atoms that are adjacent to each other, drag the cursor to form a 
rectangle around the atoms.

–or–

To select a group of atoms that are not adjacent to each other, hold down the SHIFT key 
and select the individual atoms. 

To select all of the atoms and bonds in the structure

Do one of the following:

Click the Select All button, .

–or–

Double-click anywhere in the drawing area of the Structure Editor, except on atoms or 
bonds. 
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To choose a selection mode

Do one of the following:

Right-click the Default Mode button, , and choose the appropriate selection mode 
from the shortcut menu.

–or–

Right-click anywhere in the drawing area of the Structure Editor, and choose Lasso 
Selection or Rectangle Selection from the shortcut menu.

To move a structure 

1. Select the atoms or bonds you want to move.

2. Drag the selected structures to the new location.

Lasso Selection Rectangle Selection
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Editing Atom Properties

Use the Atom Properties dialog box to change the charge state or isotope of an atom or to 
change the entire element. 

Follow these procedures:

• To edit only the element of a single atom

• To edit the element, charge, radical, or nucleon number of a single atom

• To edit only the element of multiple atoms

• To replace an element with a substituent

To edit only the element of a single atom

1. Select the atom you want to change.

2. Do one of the following:

To change an element that has a single-character symbol—C, H, N, O, B, F, K, P, S, I, V, 
W, Y, U, and R— press the appropriate key on the keyboard. 

–or–

To change to chlorine (Cl) or bromine (Br), use SHIFT+C or SHIFT+B, respectively.

The application applies the selected element symbol to the selected atom. 

To edit the element, charge, radical, or nucleon number of a single atom

1. Do one of the following:

Click the Atom Properties button, , and then click the atom you want to change.

–or–

Right-click and choose Default Mode from the shortcut menu, and then double-click the 
atom you want to change.

The Atom Properties dialog box opens.
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2. Make changes by clicking the appropriate Element button, selecting the Charge and 
Radical check boxes, or entering a value in the Nucleon Number box.

3. To change the atom to an element not listed in the Element area, do the following:

a. Click Periodic Table. 

The Periodic Table opens. For additional information, see “Report Creator” on 
page 19.

b. Select an element on the periodic table. 

c. Click OK.

4. In the Atom Properties dialog box, click OK.

Changes you make in the Atom Properties dialog box affect only the selected atom.

To edit only the element of multiple atoms

1. Hold down the SHIFT key and click each atom you want to change.

You can change only the element of multiple atoms. You cannot change the other 
parameters available on the Atom Properties dialog box.

2. Do one of the following:

To change an element that has a single-character symbol—C, H, N, O, B, F, K, P, S, I, V, 
W, Y, U, and R— press the appropriate key on the keyboard. 

–or–

To change to chlorine (Cl) or bromine (Br), use SHIFT+C or SHIFT+B, respectively.

The element symbol is applied to all selected atoms.

To replace an element with a substituent

1. Do one of the following:

Click the Atom Properties button, , and then click the atom you want to change.

–or–

Right-click and choose Default Mode from the shortcut menu, and then double-click the 
atom you want to change.

The Atom Properties dialog box opens.
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2. Click R-Substituent.

The Substituent Index area appears in the dialog box.

3. Select a value for the substituent index, or clear the Substituent Index check box.

4. Click OK.

The symbol “R” represents a substituent. Substructure search and fragments generation 
algorithms consider substituents with identical indexes as equal and substituents with 
different indexes as not equal. For additional information, see Chapter 6, “Fragments and 
Mechanisms Module.”  

When searching structures with substituents, specific search rules apply. For additional 
information, see “(Sub)Structure Search Rules” on page 89. 
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Editing Bond Properties

Use the Bond Properties dialog box to change bond multiplicity, bond style, and bond color. 

To change the multiplicity of a bond

Click , or , or  and then click the bond you want to change. 

These commands are recursive; the application changes the selected bond each time you 
click. The cursor indicates the type of bond you are using.

To change the multiplicity, color, line style, or aromaticity of a bond

1. Click the Bond Properties button, , and then click the bond you want to change.

The Bond Properties dialog box opens.

2. To change the multiplicity of the selected bond, select Single, Double, or Triple in the 
Multiplicity area.

3. To change the line style used to display the bond, select a style in the Style list.

Only single bonds use Wedged line styles.

4. To change the color used to display the bond, select a color in the Color list.

5. To force aromaticity to the selected bond, select the Force Aromaticity check box.

The Mass Frontier application automatically recognizes aromatic bonds in an appropriate 
six-membered ring or in polyaromatic structures. However, if unusual semiaromatic or 
aromatic resonance structures are required, the aromatic bond can be forced to a selected 
bond or bonds.

6. Click OK.

This cursor creates 
a triple bond
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Understanding Unspecified Bond Locations

Mass spectrometry cannot always provide information about the exact position of a functional 
group on a chain or ring portion of a structure. In several application areas, however, even 
incompletely characterized molecules can be sufficient to study a particular phenomenon. A 
typical example is metabolite characterization in an early drug discovery process where 
knowing the precise location of the site of biotransformation action is of little importance. 

For displaying and calculating the monoisotopic mass or the isotopic pattern of a fragment or 
molecule with an unspecified bond location (see “Isotope Pattern” on page 15), use the Ellipse 
tool, . The ellipse visually defines the region on a structure where you can potentially 
attach a functional group. To correctly interpret an unspecified bond location, the ellipse must 
enclose one or more atoms of the core structure and a single atom of a functional group that is 
not attached to the core structure. 
 

Understanding Unspecified Charge Sites

Use the Mass Frontier application for processing structures where the charge site is not 
specified. This kind of molecule representation is important when using ionic structures 
because the favored ionization site or the explicit charge site during fragmentation reactions is 
often unclear. You can choose from several ion types in the system.

Note  The Ellipse tool is available only in the Structure Editor module. You cannot use a 
structure with an unspecified bond location in other Mass Frontier modules. The Mass 
Frontier application does not support the generation of fragments and mechanisms from 
such structures.
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To create an ionic structure with an unspecified charge site

Select one of the ion types from the list at the bottom of the Structure Editor. 

Every structure with an unspecified charge site has this symbol, , on the upper left 
part of the structure.

Be aware of potential complications when you use an unspecified charge site with 
fragment prediction. If you attempt to generate fragments from a structure with an 
unspecified charge location, the system internally predicts all the relevant combinations of 
the structures with an explicit charge location. This process significantly slows the 
calculations and increases the number of predicted fragments. When possible, avoid 
unspecified charge sites in predicting fragments and mechanisms. For additional 
information, see “Base Page” on page 201. 
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Using Toolbar Functions
You can manipulate a structure using several buttons in the Structure Editor toolbar.

Follow these procedures:

• To resize a structure

• To copy a structure or part of a structure to the Clipboard

• To paste a structure to the Structure Editor

• To rotate a structure in the Structure Editor

• To mirror a structure

• To clean a structure 

• To check a structure

To resize a structure

1. Select the structure or part of the structure you want to resize.

2. Click the Resize button, .

3. Drag one of the small rectangles on the structure edge and release the mouse button.

Dragging one of the diagonal rectangles keeps the aspect ratio constant during structure 
resizing.

To copy a structure or part of a structure to the Clipboard

1. Select the structure or part of the structure you want to copy.

2. Click the Copy button, , or choose Edit > Copy from the Mass Frontier main menu.

The Mass Frontier application supports use of the Windows Clipboard for the exchange of 
structural information between modules. In addition, you can use copy-and-paste functions 
inside the Structure Editor. To efficiently draw larger structures, use the copy-and-paste 
functions.

In addition to structure exchange between modules, you can use the Mass Frontier application 
for structure export to other applications that deal with structural information. When you 
copy a structure, the application automatically copies two different formats to the Clipboard: 
structural information in .mol format and graphics in Windows Metafile Format (.wmf). 

Note  The application copies only the selected atoms and their associated bonds.
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When you paste a structure into the structure editing software, the application automatically 
uses the .mol format. When you paste the structure into a text editor, spreadsheet, or other 
application that works with graphics, the application automatically uses the graphical 
information.

Figure 56. Structure Exchange using copy-and-paste commands

To paste a structure to the Structure Editor

Click the Paste button, , or choose Edit > Paste from the Mass Frontier main menu.

When you copy a structure or fragment anywhere in the application or in a third-party 
structure drawing tool, you can paste it to the Structure Editor. If necessary, you can 
change or correct the structure, and then return it to its original location. This is 
especially useful for structural elucidation. For example, you can copy a structure from 
the Database Manager window, paste it to the Structure Editor, make appropriate 
changes, and then move it back to the Database Manager. If the spectrum and the 
structural proposal are not consistent, you can repeat the process.

When you copy a structure or fragment in a program other than the Mass Frontier 
application, you can paste this structure as long as the external structure drawing software 
supports .mol format and this format is activated. The majority of drawing tools for 
structures support .mol format with this format set as the default. If you paste a structure 
from an external source, it might appear larger in the Mass Frontier application than in 
the original software. If this occurs, make the structure smaller using the Resize tool.
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To rotate a structure in the Structure Editor

1. Select the structure or part of the structure you want to rotate.

2. Click the Rotate button, .

The center of rotation is indicated by a small circle with a cross in the middle, .

3. Move the center of rotation by dragging the circle with a cross.

4. Drag any of the small rectangles on the structure edge to rotate the selected structure 
around the center.

To mirror a structure

1. Select the structure or part of the structure you want to mirror.

2. Click the Mirror button, .

3. Click one of the small rectangles on the structure edge.

• The top and bottom rectangles flip the selected structure along a horizontal axis.

• The left and right rectangles flip the selected structure along a vertical axis.

To clean a structure 

1. Do one of the following:

Select an entire structure.

–or–

Select only the atoms you want to clean.

The selected atoms must be connected.

2. Click the Clean button, .

The Clean function helps you create a professional look for your structures. 
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After finishing a structure drawing, always check for errors before proceeding with any other 
procedure. When you generate the fragments and mechanisms, the application automatically 
checks the structure for errors and, if any error is discovered, the generation automatically 
discontinues. Before you run Fragments and Mechanisms, the Fragmentation Library window 
automatically performs a structure check.

To check a structure

1. Click the Check Structure button, .

The Structure check tool searches for formal errors and unusual structural features. If a 
structure is formally incorrect or if the Structure check tool finds its validity questionable, 
the Structure Check Results message box lists the errors and warnings. 

2. Click OK to close this dialog box.

The Mass Frontier application automatically selects the atoms and bonds that are 
considered incorrect. The system considers structures that are not connected as mixtures 
and reports them as errors, but it does not select the mixtures.

Note  In some complicated cases, the Clean function can lead to structures that you might 
not find satisfactory. If this occurs, choose Edit > Undo from the Mass Frontier main 
menu.

Note  This option does not perform quantum mechanical or thermodynamical 
calculations that address possible structural stability.
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Displaying the Monoisotopic Molecular Mass
When you select part of a structure, the Structure Editor displays the molecular formula and 
monoisotopic molecular mass of the selected atoms and the corresponding loss in the status 
bar of the Structure Editor. For additional information, see “Monoisotopic Mass” on 
page 381.

Information about the molecular formula and monoisotopic molecular mass is useful for 
simple consistency checking of a mass spectrum and chemical structure.

Figure 57. Molecular formula and monoisotopic molecular mass
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5

Library Utilities

The Mass Frontier application provides several methods for creating and maintaining mass 
spectral, chromatographic, and fragmentation libraries. To help you visually distinguish 
between libraries, each library has its own icon. You can select an icon for the user libraries 
you create, but the application automatically assigns icons to the HighChem MSn libraries. 
You can install up to 255 libraries at once. 

The Mass Frontier Server Manager is a stand-alone application for managing and 
administering libraries on the Microsoft SQL Server (SQL Server). 

The Mass Frontier application supports both low- and high-resolution mass spectra. You can 
store mass spectra as single spectra or as MSn trees with multiple node spectra. You can also 
store and search data-reduced chromatograms with selected scans or components. You can 
update any record in a library except the HighChem MSn libraries, which are read-only.

The Mass Frontier application unifies spectral and fragmentation libraries into a single library 
format.

Contents

• Using the Server Manager

• Using the Microsoft SQL Server 2005 Express Edition

• Using the HighChem Spectral Tree Library

• Managing Library Records in the Database Manager

• Searching Chromatographic Libraries
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Using the Server Manager
Not only can you access libraries over a computer network by using the Mass Frontier Server 
Manager, but you can access a library on the SQL Server from multiple instances of the Mass 
Frontier application. Use the Server Manager to manage spectral and fragmentation libraries 
for all instances of the Mass Frontier application. You can also use the Server Manager to find 
and manage servers over computer networks. 

This section includes the following topics:

• Using the Server Manager

• Managing Servers

• Managing Libraries

• Importing the NIST/EPA/NIH Mass Spectral Database

• Error Logs

To open the Server Manager 

Choose Library > Server Manager from the Mass Frontier main menu. 

This menu item is accessible only if the Server Manager is installed on the same computer 
as the Mass Frontier software. If the Server Manager is installed on a network computer, 
start the Server Manager from this location. 

Figure 58. Mass Frontier Server Manager window
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Setting Up the Server Manager

To access the SQL Server through the Server Manager, you must configure both the firewall 
protecting the SQL Server and the SQL Server browser so that they can receive incoming 
connections. 

At startup, the Server Manager attempts to find and connect to the server located on the local 
computer. If it cannot find this server or if you want to work with servers on other computers, 
you can do one of the following:

Choose Server > Add Server Manually to add a server (link) in the Server Manager 
window.

–or–

Choose Server > Enumerate Available Servers to search all available servers on the 
network.

When you regularly or exclusively work with a specific server, you can set it as the default.

To specify a default server

1. Choose Tools > Options from the Server Manager menu.

The Options dialog box opens.

2. Select the Add Server Automatic option.

3. Select the Add as Default option.

Note  Enumerating servers on a computer network can be time-consuming, 
depending on the network size. Some network configurations do not allow automated 
identification of servers using enumeration. In this case, you must manually connect 
the server. For instructions, see “To manually connect to a server” on page 156.
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4. Type the name of the default server or click Add and locate the server.

5. Click OK.

Managing Servers

You can manage your server connections from the Server Manager window.

Follow these procedures: 

• To manually connect to a server

• To connect to a preferred server from the Available Servers list

• To interrupt a server connection

• To remove a server from the Library Explorer list

To manually connect to a server

1. Choose Server > Add Server Manually. 

The Add Server dialog box opens.

2. To specify the computer, do one of the following:

Click the Select Computer icon, , and browse to a computer.

–or–

Type the computer name.

The available servers for the selected computer are listed in the Server list. 

3. To specify the server, do one of the following:

Select from the available servers in the Server list.

–or–

Type the server name (for example, MASSFRONTIER70). 

Note  To connect to a server that was installed with the Mass Frontier 4.0, 5.0, or 6.0 
applications, you must reconfigure the server for network functionality (see “To 
reconfigure a previous version of the Mass Frontier SQL Server” on page 170). Server 
configuration has no effect on the Mass Frontier application and its libraries.
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4. (Optional) To automatically enumerate computers on the network, click the Enumerate 
Network Computers icon, . 

5. Click Add.

The server name appears in the Available Servers pane in the Server Manager window. 

To connect to a preferred server from the Available Servers list 

1. Select the server in the Available Servers pane.

2. Do one of the following:

Click the Connect Server icon, . 

–or– 

Right-click and choose Connect Server from the shortcut menu. 

The application connects to the selected server and displays the server and the list of 
available libraries installed on the server in the Library Explorer pane. 

To interrupt a server connection

1. Select the server in the Library Explorer pane or the Available Servers pane. 

2. Do one of the following:

Click the Disconnect Selected Server icon, , in the Library Explorer toolbar.

–or–

Choose Server > Disconnect Server from the Server Manager main menu.

You can reconnect to the server at any time. For additional information, see “To manually 
connect to a server” on page 156. 

Note  You can manage libraries (install, remove, create, or delete) only when a server is 
connected.
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To remove a server from the Library Explorer list 

1. Select the server in the Library Explorer pane. 

2. Do one of the following:

Click the Remove Server from Library Explorer icon, , in the Library Explorer 
toolbar.

–or–

Choose Server > Remove Server from the Server Manager main menu.

The Server Manager removes the server only from the Library Explorer list; it is not 
removed from your computer. To return the server to the Library Explorer list, see “To 
manually connect to a server” on page 156. 
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Managing Libraries

You can store spectral data and fragmentation mechanisms in user libraries. Because creating a 
user library is easy, you can organize your mass spectral, chromatographic, fragmentation, and 
structural data in separate user libraries.

Follow these procedures: 

• To create a new user library

• To install a library

• To remove a library

• To permanently remove a library

• To back up a library

• To restore a library from backup files

• To reindex a library

• To shrink a library

• To convert a library to Mass Frontier 7.0 format

• To refresh a library list

• To reconfigure a previous version of the Mass Frontier SQL Server
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To create a new user library

1. Choose Library > Create Library from the Server Manager main menu. 

The New Library window opens.

2. Type the library name. 

You can use only the characters a–z, A–Z, 0–9, and SPACE.

3. Select a library icon. 

By default, new libraries use a blue beaker, but there are many icons from which to 
choose.

4. If you must change the default directory (not recommended), do the following:

a. Click the Path column in the Database Files table. 

A browse button appears on the far right. 

b. Click the button and navigate to a new directory. 

5. To create the new library, click Create.

When the library is successfully created, the icon and name are displayed in the Library 
Explorer. 

You can create an unlimited number of user libraries, but the SQL Server can hold a 
maximum of 255 libraries at one time. If you require more libraries and have reached the 
maximum, remove a library that you do not need and then create or install a new library. 

Note  You can create a library only on the same computer where the SQL Server is located. 
For example, if your SQL Server is located on a network computer, you cannot create a 
library on your local computer.
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To install a library

1. Do one of the following:

Choose Library > Install Library from the Server Manager main menu. 

–or– 

Select the server name in the Library Explorer pane, right-click and choose Install 
Library from the shortcut menu. 

The Locate Library File browser opens.

2. Select a library file with the .mdf extension and click OK.

The Install Library dialog box opens.

3. To install another library, click Browse and select a library file with the .mdf extension.

Repeat this step for as many libraries as you want to install.

4. Click Install.

When the library is successfully installed, a new library item appears in the Library 
Explorer pane. 

If the application encounters a problem installing a library, an error icon, , appears 
next to the library item in the list of libraries. To see the details of the problem, 
double-click the library item. 

5. To remove a library from the list of previously chosen libraries, select the library item and 
click Remove.
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To remove a library

1. Select the library in the Library Explorer pane. 

2. Do one of the following:

Choose Library > Uninstall Library from the Server Manager main menu. 

–or– 

Right-click and choose Uninstall Library from the shortcut menu. 

The Uninstall Library window opens.

You cannot remove a library with an already established connection to the application. 

Note  You can install a library only on the same computer where the SQL Server is 
located. For example, if your SQL Server is located on a network computer, you cannot 
install a library on your local computer. If you have a library file on a local computer, you 
must copy it to the computer where the SQL Server is located.

Tip  You can install a library only when the data is in the Mass Frontier library format 
(version 4.0 or later). For libraries in NIST format (NIST Library and user libraries from 
the Mass Frontier 3.0 and earlier versions), use the Import NIST Library command. For 
additional information, see “Importing the NIST/EPA/NIH Mass Spectral Database” on 
page 171.

Notes  

• Too many installed libraries can slow the performance of the system; removing 
unused libraries can improve system performance. 

• You cannot copy or delete database files (.mdf ) when a library is installed.
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3. (Optional) To find out if another user is connected to the library, click  Connections 
in the Select a Page pane. 

4. (Optional) To remove a library that has an established connection, select the Close 
Existing Connections check box. 

Applications that are connected to a removed library do not work properly. You can use 
the Close Existing Connections feature if an application remains connected after an 
unexpected termination.

5. (Optional) To remove backup information from the system database, select the Delete 
Backup and Restore History Information for Library check box. 

To optimize processing speed, keep this option cleared.

6. Click Uninstall.

Removing a library does not delete it. The application removes the library reference without 
the loss of spectral, structural, and fragmentation information. At any time, you can reinstall a 
library that has been removed. For additional information, see To install a library. 

To permanently remove a library

1. Select the library in the Library Explorer pane.

2. Do one of the following:

Choose Library > Delete Library from the Server Manager main menu. 

–or– 

Right-click and choose Delete Library from the shortcut menu. 

The Delete Library window opens.

You cannot remove a library with an already established connection to the application. 

3. (Optional) To find out if another user is connected to the library, click  Connections 
in the Select a Page pane. 
Thermo Scientific Mass Frontier User Guide 163



5 Library Utilities
Using the Server Manager
4. (Optional) To remove a library that has an established connection, select the Close 
Existing Connections check box. 

Applications that are connected to a removed library do not work properly. You can use 
the Close Existing Connections feature if an application remains connected after an 
unexpected termination.

5. (Optional) To remove backup information from the system database, select the Delete 
Backup and Restore History Information for Library check box. 

To optimize processing speed, keep this option cleared.

6. Click Delete.

The Delete Library option irreversibly removes the library and all associated files from the 
hard disk. No recovery action is possible unless you back up the library before deleting it. For 
additional information, see To back up a library. 

To back up a library

1. Select the library in the Library Explorer pane.

2. Do one of the following:

Choose Library > BackUp Library from the Server Manager main menu. 

–or– 

Right-click and choose BackUp Library from the shortcut menu. 

The Backup Library window opens.

IMPORTANT  Do not back up or restore libraries by using a copy-and-paste operation; 
use only the Server Manager’s backup and restore procedures. 
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3. (Optional) Edit the text in the Name and Description boxes.

The text in these fields helps identify the specific backup when you restore a library. For 
additional information, see To restore a library from backup files.

4. (Optional) To change the default destination of the backup file, click Replace and specify 
the directory and file name.

5. (Optional) To see the size and time stamp of the backup file, click Contents.

6. Click Backup.

Use this backup procedure to continuously store changes from previous backups into the same 
file. The application automatically creates a time stamp for each backup. 

To restore a library from backup files

1. Select the source library in the Library Explorer pane.

2. Do one of the following:

Choose Library > Restore Library from the Server Manager main menu. 

–or– 

Right-click and choose Restore Library from the shortcut menu. 

The Restore Library window opens.

3. In the Select the Backup Set to Restore list, select the check box of the data set you want 
to restore.

Use the time stamp to identify the correct data set. You can restore library data from 
previous backups into a new library or into an existing library.
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4. Type a new destination library name in the Database list. 

You can select a library name from the list, but this action irreversibly overwrites the data 
in that library.

5. Click Restore.

You cannot restore a library with an already established connection to the application. 

6. (Optional) To find out if another user is connected to the library, click  Connections 
in the Select a Page pane. 

7. (Optional) To remove a library that has an established connection, select the Close 
Existing Connections check box. 

Applications that are connected to this library do not work properly. You can use the 
Close Existing Connections feature if an application remains connected after an 
unexpected termination.

Tip  If you restore library data into an existing library, you will irreversibly overwrite 
its data. Instead, restore the backup library to a new destination library with a unique 
name.

Note  Data restoration is a resource-consuming operation. During restoration, the server 
might be busy so that other actions in the Server Manager might not work properly. Wait 
until restoration finishes to proceed.
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To reindex a library 

1. Select the library in the Library Explorer pane.

2. Do one of the following:

Choose Library > Reindex Library from the Server Manager main menu. 

–or– 

Right-click and choose Reindex Library from the shortcut menu. 

The Reindex Library window opens.

Figure 59. Reindex Library window 

This feature defragments the library index and can increase performance. 

3. Click ReIndex.

Depending on the amount of stored data, reindexing requires from several minutes to 
several hours to perform. The Progress pane reports the completion status.

IMPORTANT  Make backup copies of libraries before reindexing them. For additional 
information, see “To back up a library” on page 164.
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To shrink a library 

1. Select the library in the Library Explorer pane.

2. Do one of the following:

Choose Library > Shrink Library from the Server Manager main menu. 

–or– 

Right-click and choose Shrink Library from the shortcut menu. 

The Shrink Library window opens.

Some operations, such as Conversion or Import Library, cause inflation of library files that 
might require reducing the size of the library. For additional information, see “To convert a 
library to Mass Frontier 7.0 format” on page 169 or “Importing the NIST/EPA/NIH Mass 
Spectral Database” on page 171.

The Mass Frontier 7.0 application uses library formatting that is not compatible with 
previous versions. To use libraries created in older versions of the application, you must 
convert them to the new format. Converting a library requires connecting to its 
corresponding SQL Server.

Because previous versions of the SQL Server were not configured for network operations, you 
must reconfigure your previous version of the SQL Server to enable network operations. For 
additional information, see “To reconfigure a previous version of the Mass Frontier SQL 
Server” on page 170.

Note  Make backup copies of libraries before you shrink them. For additional 
information, see To back up a library.
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To convert a library to Mass Frontier 7.0 format

1. Select the library in the Library Explorer pane.

2. Do one of the following:

Choose Library > Convert Library from the Server Manager main menu. 

–or– 

Right-click and choose Convert Library from the shortcut menu. 

The Convert Library window opens.

3. From the Destination Server list, select a server.

4. To select a destination for the imported library, do one of the following:

a. Select the Create New option to create a new library for the converted library.

b. Type the name of the new library and click Create New.

The New Library dialog box opens.

–or–

a. Select the Overwrite Existing option to place data into an existing library on the 
selected server.

b. Select the destination library from the list. 

5. Click Convert. 

Note  If the selected library is already in Mass Frontier 7.0 format, the Convert 
Library commands are not available.
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To refresh a library list 

1. Select the library folder in the Library Explorer pane.

The application does not automatically update the list of available libraries. To see the 
current list of libraries, you must manually refresh the list. 

The Refresh Library List icon is enabled only when a library folder is selected.

2. Click the Refresh Library List icon, . 

To reconfigure a previous version of the Mass Frontier SQL Server

1. From the Windows taskbar, choose Start > Run.

2. In the Open box, type svrnetcn and click OK.

The SQL Server Network Utility dialog box opens.

Figure 60. SQL Server Network Utility dialog box

3. In the Instances on This Server list, select an instance of SQL Server to configure.

4. In the Disabled Protocols list, select Named Pipes and TCP/IP.

5. Click Enable >>.

The application moves the selected protocols to the Enabled Protocols list.

6. Click OK.

7. Restart the SQL Server Service or restart your computer. 

Note  Because previous versions of the SQL Server were not configured for network 
operations, you must reconfigure your previous version of the SQL Server to enable 
network operations. For additional information, see To reconfigure a previous version 
of the Mass Frontier SQL Server.
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Importing the NIST/EPA/NIH Mass Spectral Database

The  Mass Frontier application supports NIST/EPA/NIH Mass Spectral Database 2005 
(NIST 2005 Library). You can either install the NIST 2005 Library—if the library is in the 
Mass Frontier format—or import it in NIST (.mdf) file format. While the NIST library is 
importing, the data is converted to the Mass Frontier database format (SQL Server). This 
process can take up to several hours. 

Follow these procedures:

• To import the NIST Library or any user library in NIST format

• To specify mass spectra, ionization mode, or precursor-ion data from a NIST spectra

To import the NIST Library or any user library in NIST format

1. Choose Library > Import NIST Library from the Server Manager main menu.

The Import NIST Library dialog box opens.

2. In the Library to Import area, click Browse and select the NIST library.

3. In the Destination Server list, select a server.
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4. To select a destination for the imported library, do one of the following:

a. Select the New option to create a new library for the imported library.

b. Type the name of the new library and click Create.

The New Library dialog box opens. For additional information, see To create a new 
user library.

–or–

c. Select the Existing option to place data into an existing library on the selected server.

d. Select the destination library from the list. 

5. Click Import.

The Mass Frontier application does not recognize the mass spectra type, ionization mode, or 
precursor-ion information from a NIST spectra. 

To specify mass spectra, ionization mode, or precursor-ion data from a NIST spectra

1. In the Select a Page pane, select Options.

The Options page opens. 

Figure 61. Options page of the Import NIST Library dialog box

2. Specify the options for MS or MS/MS imported spectra.

3. Click Import.

When the import job is completed, the Import NIST Library dialog box closes.
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Error Logs

When the Mass Frontier application encounters problems with libraries or the Server 
Manager, it saves the errors to two error log files: the native SQL Server error log and the 
Server Manager error log.

Follow these procedures:

• To open the Server Manager error log

• To open the SQL Server error log

To open the Server Manager error log

1. Choose File > Program Error Log from the Server Manager main menu.

The Manager Errors log file opens.

Figure 62. Manager Errors log file

2. To copy the log text to the Clipboard, click Copy.

The Copy command copies all text in the log; you cannot select only a portion of the text 
to copy.

3. To delete all entries in the log, click Clear.

You cannot undo this command. 
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To open the SQL Server error log

1. Choose Server > SQL Server Error Log from the Server Manager main menu.

The SQL Server Error Log window opens.

2. Select a specific log file from the Error Logs list.

The SQL Server maintains six error logs. Each time you start a new instance of the SQL 
Server, a new log file begins.

3. To save the current log file to a text file, click Save to File.

The Save to File command saves all text in the log; you cannot select only a portion of the 
text to save.
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Using the Microsoft SQL Server 2005 Express Edition
The Mass Frontier library utilities are based on the Microsoft SQL Server 2005 Express 
Edition (SQL Express). SQL Express is a database engine based on core SQL Server 
technology. It is a reliable storage engine and query processor for desktop applications. SQL 
Express is a royalty-free, distributable database engine that is fully compatible with SQL 
Server. SQL Express is included in the Mass Frontier installation.

SQL Express is the background application for the Mass Frontier application. Library utilities 
are integrated in the graphical interface; you do not directly interact with the database engine. 

The SQL Express database engine creates databases with a maximum file size of 4 GB. Any 
libraries created in the application cannot exceed this file size. If you try to store data above 
this limit, the Mass Frontier application informs you that this action cannot be completed and 
you should store the extra data in a new library. 

This file size issue occurs more often with chromatographic libraries than with spectral 
libraries. For example, the NIST 2002 database with 175000 spectra takes up 800 MB in the 
SQL Express format. However, if you must create large spectral or chromatographic databases, 
you can upgrade SQL Express to the higher SQL Server editions (for example, Enterprise, 
Standard, or Personal) that have terra byte capacity. The Mass Frontier libraries are fully 
compatible with other editions of the SQL Server. A database expert must individually set up 
later SQL Server editions. For additional information on how to upgrade SQL Express, 
contact Microsoft or the HighChem, Ltd. database group.

SQL Express is managed by the Mass Frontier Server Manager. 

To start the Server Manager

Choose Library > Server Manager from the Mass Frontier main menu.

Figure 63. Server Manager window
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Using the HighChem Spectral Tree Library
The HighChem spectral trees (MSn spectra) are available in the Mass Frontier application. 
This collection1 contains high quality ion trap spectra of human and veterinary 
pharmaceuticals, endogenous metabolites, drugs of abuse, and doping agents. The library 
contains spectral trees acquired by electrospray ionization (ESI) in both the positive and 
negative ion modes. Each spectral tree contains a name, structure, and CAS number. The 
HighChem Spectral Tree Library contains more than 13 000 individual spectra of 1251 
positive and 524 negative ESI spectral trees. In addition, 702 positive and 263 negative ESI 
spectral trees are associated with fragmentation mechanisms2.

1 Compiled by Dr. Ernst Pittenauer, Vienna University of Technology, Getreidemarkt 9/164, A-1060 Vienna, 
Austria and Dr. Petr Simek, Academy of Sciences of the Czech Republic, Branisovska 3, CZ-37005 Ceske 
Budejovice, Czech Republic

2 Dr. Ernst Pittenauer, Vienna University of Technology, Getreidemarkt 9/164, A-1060 Vienna, Austria

IMPORTANT  HighChem owns all the intellectual property rights to spectral, structural, 
and fragmentation data in the HighChem Spectral Tree Library. You may not copy, 
translate, distribute, publish, or use this data in connection with other applications 
without the written approval of HighChem, Ltd., Slovak Republic. 
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Managing Library Records in the Database Manager
Use the Mass Frontier Database Manager to add new records (spectra, trees, chromatograms, 
structures, compound identification information, and fragmentation mechanisms) to a user 
library. A user library is any library you created in the Server Manager module. For 
instructions, see To create a new user library.

You can change and save any record information (spectra, trees, chromatograms, structures, 
compound identification information, and fragmentation mechanisms) in a library. To 
indicate a change in a record, the application displays a small circle in the ID number column 
of the Database Manager Spreadsheet view. Changes in records are not automatically updated 
in a database; you must manually save them. For additional information, see Chapter 2, 
“Database Manager Module.” 

Follow these procedures:

• To open the Database Manager window

• To add records to a user library

• To save changes in a library

• To delete library records

To open the Database Manager window

1. Do one of the following from the Mass Frontier application window:

Choose Tools > Database Manager from the Mass Frontier main menu.

–or–

Click the Database Manager icon, , in the Mass Frontier toolbar.

The Database Manager window opens.
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Figure 64. Database Manager window

You can add a new record in the Database Manager in the  Work tab only. You can update 
an existing record in any library that is not read-only. 
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To add records to a user library

1. In the Spreadsheet of any library in the Database Manager, select the records you want to 
add to the user library.

2. Choose Library > Add To Library from the Mass Frontier main menu.

The Add To Library window opens. 

3. In the Choose Library area, select the destination library.

4. (Optional) Turn off redundancy checking by selecting the Do Not Check option.

By default, the application checks whether the structure associated with the spectrum you 
are adding to the user library is already present in the library. The application compares 
each structure to be added to the user library with structures already in the library. If the 
structure already exists in the library, the following message appears:

5. Click Add.

Note  A single structure accompanying a spectrum in a user library cannot contain more 
than 199 non-hydrogen atoms.
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To save changes in a library 

1. In the Database Manager, select the a library you want to save.

2. Choose Library > Save Changes In Library from the Mass Frontier main menu.

When you save a newly created record, the application redirects you to the Add To Library 
dialog box. For additional information, see To add records to a user library.

To delete library records

1. Use any search method to retrieve the record or records you want to delete.

2. Select the records you want to delete in the Database Manager Spreadsheet.

3. Choose Library > Delete from Library from the Mass Frontier main menu. 

The Delete From Library window opens.

4. Carefully review the spectra and structures. 

Note  If you close a Database Manager window or the Mass Frontier application with 
unsaved changes, the application prompts you to save them.

IMPORTANT  When you delete a library record, the information is irreversibly lost. 
You cannot undo the delete library record function. You cannot delete library records 
from read-only libraries. 
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5. Do one of the following:

a. To delete all displayed records at once, select the Delete Without Confirmation 
option. 

b. To delete record-by-record, select the Confirm Each Spectra/Structure Pair Before 
Deletion option. 

The application prompts you to confirm the deletion of each selected record in the 
library, even if you selected only one. For example:

6. Click Delete.

When you delete a record from a library, the application automatically decrements the ID 
numbers of records with a higher ID than the deleted record so that there are no ID 
number gaps in the library.
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Searching Chromatographic Libraries
The Mass Frontier application can create searchable libraries of data-reduced 
chromatographic data. You can export retention times, TIC profiles, selected scans, or 
detected component spectra or trees to user libraries and search them using various criteria. 
Use this feature to search a particular spectrum in a series of GC/LC/MSn library records 
(target analysis) or to perform cross matching of all scans or components in a chromatogram 
against spectral data of other chromatographic records (dereplication). Chromatograms are 
organized in a similar manner to spectral libraries, the difference being that a single library 
entry represents a data-reduced chromatogram rather than a simple spectrum or tree.

For additional information, see “Exporting Scans, Components, and Reduced 
Chromatograms” on page 325 or “Searching Components” on page 334.
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6

Fragments and Mechanisms Module

The Mass Frontier application can automatically generate possible fragments, including 
complete fragmentation and rearrangement mechanisms starting from your chemical 
structure. The Fragments & Mechanisms module provides information about basic 
fragmentation and rearrangement processes that might occur in a mass spectrometer.

Generated fragments and corresponding mechanisms are particularly useful for the following:

• Checking consistency between a chemical structure and its mass spectrum

• Confirming library search identifications

• Recognizing the structural differences between spectra of closely related compounds

• Interpreting the spectra of isotopically-labeled compounds

• Illustrating the structure-spectra relationship for educational purposes

Contents

• Features

• Generating Fragments and Mechanisms

• Using the Fragments & Mechanisms Window

• Previewing Unimolecular Reactions

• Generating Fragments for Multiple Structures

• Specifying Reaction Restrictions

• Working with Generated Fragments
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The Fragments & Mechanisms module uses a mathematical approach to simulating 
unimolecular ion-decomposition reactions. For additional information, see “Previewing 
Unimolecular Reactions” on page 193.

The system, which generates possible fragmentation and rearrangement pathways, is based on 
these assumptions:

• General fragmentation and rearrangement rules 

The system optionally predicts reaction pathways that are based on general fragmentation 
and rearrangement rules. This feature does not include compound-specific mechanisms 
that cannot be applied generally. At first, this might seem to be a disadvantage; however, 
you can use this feature in combination with a substructure search for identifying specific 
compound classes. For additional information, see “Unexplained Peaks” on page 219.

• Fragmentation Library mechanisms 

The system optionally accesses an intelligent fragmentation mechanism knowledge base 
for predicting unimolecular decomposition reactions. HighChem Fragmentation Library 
currently contains approximately 19000 individual mechanisms. You can also include 
your own mechanisms in fragmentation prediction. For additional information, see “Base 
Page” on page 201, Chapter 7, “Fragmentation Library,” , or “Using Library Reactions in 
Fragmentation Prediction” on page 237.

• Charge localization concept

Every ion-decomposition reaction that is generated is based on the charge localization 
concept. The application determines exactly where the charge site in all precursor and 
product ions is located. The system internally generates resonance reactions, which are 
not displayed by default. For additional information, see “Resonance Page” on page 209. 

These reactions can move charge sites to distant locations and, in some complicated 
structures, the charge localization concept might appear to have been violated. If a 
reaction step is not clear, you can set up the system to display mechanisms along with 
resonance reactions. You can, however, use an unspecified charge location that is 
internally transformed to all combinatorial structures with a localized charge.

• Unimolecular linear reaction mechanisms

The Mass Frontier application generates only unimolecular reactions. The reaction 
pathways are displayed as linear reaction mechanisms, which incorporate one 
intermediate site on the left and one intermediate site on the right for each reaction step. 
The application includes only ionic products in reaction pathways; it does not display 
neutral fragments.
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• Even-Electron rule

The application generates reaction mechanisms in accordance with the Even-Electron 
rule. The Even-Electron rule says that the homolytic bond cleavages of an even electron 
ion are energetically unfavorable. This means that the application never generates radical 
cations from an even-electron ion.

• Bond cleavages only

Using the General fragmentation and rearrangement rules option, the application can 
only generate fragments from bond cleavages. It does not support bond creation, except 
creation of an H-X bond (X = any element) in hydrogen rearrangements. For this option, 
the system does not include ring contractions, cyclizations, or skeletal and non-hydrogen 
rearrangements. The Fragmentation Library option supports bond creation with all 
rearrangements and ring transformations. For additional information, see 
“H-Rearrangements Page” on page 207 or Chapter 7, “Fragmentation Library.” 

• Ionization methods

The application supports electron impact, protonation, deprotonation, cluster ion 
formation, alkali metal adducts, and chemical ionization methods.

• Formally possible solutions

The mechanisms generated by the Mass Frontier application contain formally possible 
reaction steps. The system does not determine the stability of product ions from 
thermodynamic data or rates of reaction. When evaluating generated mechanisms, keep 
this rule in mind: Short and uncomplicated reaction pathways are more favorable than 
complex mechanisms involving complicated, multistep hydrogen rearrangements.
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Generating Fragments and Mechanisms
You can generate fragmentation and rearrangement pathways from any structure you supply, 
including ions and isotopically-labeled compounds. The structure can originate from the 
Structure Editor, the Database Manager, or a Fragments & Mechanisms window. Before the 
Mass Frontier application generates the program, it checks the input structure for errors. If it 
finds any errors, a message box displays the errors and cancels the generation.

• When you start a generation from the Structure Editor, the application assumes that the 
complete structure is intended as input for the generation.

• When you start a generation from the Database Manager window, the application 
automatically links the generated fragments in the Fragments & Mechanisms window 
with the corresponding spectrum in the Database Manager window. The application 
highlights peaks that have the same m/z value as the generated fragments. Selecting a 
highlighted peak reveals all the pathways leading to it. By default, peaks are highlighted in 
red. 

To start a generation of possible fragmentation and rearrangement pathways

1. Do one of the following:

Click the Fragments and Mechanism button, , in the Mass Frontier toolbar.

–or–

Choose Tools > Fragments and Mechanisms from the Mass Frontier main menu.

The Reaction Restrictions dialog box opens. For detailed information about the Reaction 
Restrictions dialog box, see “Specifying Reaction Restrictions” on page 198.

Figure 65. Reaction Restrictions dialog box
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2. Specify your parameters in the Reaction Restrictions dialog box and click OK.

The Generation of Fragments & Mechanisms dialog box displays the progress as the 
application checks for structure errors. See “Generation of Fragments & Mechanisms 
dialog box” on page 187.

When the checks are complete, the Fragments & Mechanisms window opens. See “Using 
the Fragments & Mechanisms Window” on page 189.

Figure 66. Generation of Fragments & Mechanisms dialog box

Table 22. Generation of Fragments & Mechanisms parameters  (Sheet 1 of 2)

Parameter Description

Status Reports the current check. 

Progress Status bar reports the relative completion state of the current 
check.

Already Generated m/z List of m/z values of the ions that have already been generated 
and the total number of ions that have already been generated.
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Reactions Limit Indicates approximately how many temporary internal 
reactions have been generated from a particular structure. 
Large and structurally complicated molecules can produce an 
enormous number of reactions but consume a large amount of 
memory. This memory consumption limits the number of 
temporarily generated reactions. If the reactions limit is 
reached, the generation stops and the application displays an 
error message, but the fragments and mechanisms generated 
up to that point are displayed. The most important fragments 
are generated first, so even if a generation stops, the most 
important fragments have likely been generated. However, if 
you are missing an important fragment because you assume 
the generation was interrupted, you can increase the reactions 
limit. For additional information, see “Sizes Page” on 
page 213.

Info With this multithreading strategy, you can simultaneously 
perform multiple tasks. For example, while the application is 
generating reactions, you can search libraries or analyze your 
spectra. You can also run two or more generations of 
fragments and mechanisms at the same time.

Pause Temporarily interrupts generation to redirect processing power 
to other processes that might be simultaneously running in the 
application or to other Windows applications.

Finish Stops the current generation. The application displays 
fragments and any production mechanisms that are generated 
up to that point.

Cancel Cancels the current generation. The application does not 
display any generated fragments. It can take several seconds 
before the window closes.

Table 22. Generation of Fragments & Mechanisms parameters  (Sheet 2 of 2)

Parameter Description
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Using the Fragments & Mechanisms Window
When the application finishes a reaction-generating process, a Fragments & Mechanisms 
window opens. You cannot directly open this window from any menu or toolbar. A Fragments 
& Mechanisms window displays either the complete mechanisms of ion-decomposition 
reactions or only the resulting fragments.

Follow these procedures:

• To customize the m/z tab display

• To display a mechanism or fragment for an m/z value

• To copy fragments or mechanisms

• To display the isobaric fragments for a particular m/z value

Set m/z (Bar Code Spectrum,
Fragments Comparator, Clipboard)

Exclude m/z (Bar Code Spectrum, 
Fragments Comparator, Clipboard)

Show Bar Code Spectrum

Compare Fragments

Show m/z Values for Explained Peaks Only

Ionization Method 

Reaction Mechanisms 
Overview
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To customize the m/z tab display

1. Choose Options > Settings from the Mass Frontier main menu.

The Options dialog box opens.

2. Click Reaction in the Layouts section.

The m/z page of the Options: Reaction Layout dialog box opens.

3. Specify the display style for your m/z tabs.

The Sample area shows how each display style will look.

4. Click OK.

The next time you generate fragments and mechanisms, the application uses the specified 
display changes. Current Fragments & Mechanisms windows are not affected. 
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To display a mechanism or fragment for an m/z value

Do one of the following:

Click the appropriate m/z tab.

–or –

Choose the m/z value from the m/z list.

The display style depends on the settings you specified in the Options dialog box. 

To copy fragments or mechanisms

1. Click the Copy button on the Mass Frontier main menu and choose one of the following:

• Mechanism

This command copies mechanisms in both graphic format (Enhanced Windows 
Metafile) and data format. 

• Fragment

This command is available only when you have a selected fragment in the Fragments 
& Mechanisms window.

• List of Fragments

This command copies all fragments listed in the Fragments & Mechanisms window.

2. Paste the copied element into a Structure Editor window, a Database Manager window, or 
any Windows application. 
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To display the isobaric fragments for a particular m/z value

You can generate several possible isobaric fragments for a particular m/z value. When 
more than one fragment is generated for an m/z value, the application displays each 
numbered fragment separately.

To display the isobaric fragments with their corresponding mechanisms, click the 
numbered button next to the hand pointer.

The fragments are sorted according to the simplicity of their production mechanism, so 
fragment No.1 is produced by the simplest (shortest) mechanism. The isobaric fragments 
are usually isomers of the same fragments with a different charge, radical, or p-bond 
location. 
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Previewing Unimolecular Reactions
The Mass Frontier application uses general unimolecular reactions for prediction of 
fragmentation, rearrangement, and resonance mechanisms.

To preview unimolecular reactions

Click the Reaction Mechanisms Overview button, , in a Fragments & Mechanisms 
window. 

The Reaction Mechanisms Overview window opens.
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Reaction Formalism

The reaction formalism used in the application follows these conventions:
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Generating Fragments for Multiple Structures
The Mass Frontier application supports batch processing for fragment prediction. You can 
generate fragments without mechanisms for multiple input structures in a single batch. 

To generate fragments for multiple input structures 

1. Choose Tools > Batch Fragment Generation from the Mass Frontier main menu.

The Batch Fragment Generation: Input Structures dialog box opens.

2. To add structures, do any of the following: 

Click the Open button, , and import structures from .sdf or .mol files.

–or–

Paste structures from the Clipboard.

–or–

Create structures in the Structure Editor window, and then copy and paste them.

3. Click OK.

The Batch Processing Options: Reaction Restriction dialog box opens. The parameters in 
this dialog box are almost identical to the Reaction Restrictions dialog box. See 
“Specifying Reaction Restrictions” on page 198.
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4. Specify your parameters in the Batch Processing Options: Reaction Restriction dialog box 
and click Next.

The Batch Processing Options: Output Parameters dialog box opens.

5. Select one of the following output options:

• Save to a library.

• Save in .sdf file format. 

This file format, defined by Molecular Design Ltd. (MDL), is an ASCII file format 
that can contain multiple compounds in .sdf file format.

• Add to a new Database Manager window.

6. To annotate the spectra, select the Annotate Spectra check box.

7. Click Generate.

The Generation of Fragments & Mechanisms dialog box reports the progress.
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8. When the batch is completed, click Close.

For each input structure, the application generates a separate set of fragments and saves 
them in the specified output format. 

Fragment generation is executed in its own thread, which means you can use other Mass 
Frontier functions during the generation.
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Specifying Reaction Restrictions
Use the features in the Reaction Restrictions dialog box to change the default settings of the 
ionization method and the basic fragmentation and rearrangement mechanisms. 

The Reaction Restrictions dialog box automatically opens when you begin generating 
fragments. You can also open the Options dialog box from the Mass Frontier main menu or 
toolbar and access identical Reaction Restrictions parameters.

This section includes the following topics:

• Managing Reaction Restrictions Files

• Using the Reaction Restrictions Dialog Box

• Specifying Precision and Isobaric Differentiation

To open the Reaction Restrictions pages of the Options dialog box

1. Choose Options > Settings from the Mass Frontier main menu. 

2. Click Reaction Restrictions in the Parameters section.

The Reaction Restrictions pages of the Options dialog box open. The parameters are 
exactly the same as the parameters in the Reaction Restrictions dialog box that 
automatically opens when you generate fragments and mechanisms. See “Reaction 
Restrictions dialog box” on page 186.

Managing Reaction Restrictions Files

Use the Reaction Restrictions dialog box to specify many parameters for a fragment. You can 
save parameter values to a file and then import that file to apply the same parameter values to 
other fragments.

To save reaction restrictions to a file

1. Specify the restrictions for all pages of the Reaction Restrictions dialog box.

2. Click the Save button, .

The Save Reaction Restrictions dialog box opens.

3. Type a file name for the file.

The file type defaults to .rrs.

4. Click Save.

You can import these restriction settings when you generate fragments for similar compounds.

Note  There is no Save option when you use the Reaction Restrictions pages of the 
Options dialog box.
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To import reaction restrictions from a file

1. Click the Open button, .

The Open Reaction Restrictions dialog box opens.

2. Select an .rrs file to import. 

3. Click Open.

The application overwrites all parameters in the Reaction Restrictions dialog box with the 
saved parameters in the file. 

4. Click OK to make these restrictions active.

All changes in the Reaction Restrictions dialog box take effect after the regeneration of 
fragments and mechanisms and affect all subsequent generations. The current Fragments 
& Mechanisms windows are not affected. 

Note  There is no Open option when you use the Reaction Restrictions pages of the 
Options dialog box.
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Using the Reaction Restrictions Dialog Box

The Reaction Restrictions dialog box automatically opens when you begin generating 
fragments. You can manually open identical pages of parameters from the Options menu.

This section includes the following topics:

• Base Page

• Ionization and Cleavage Page

• H-Rearrangements Page

• Resonance Page

• Additional Page

• Sizes Page

To restore default settings

Click Restore Defaults.

The application restores all default values in the Reaction Restrictions dialog box. These 
values take effect after the regeneration of fragments and mechanisms and affect all 
subsequent generations. The current Fragments & Mechanisms windows are not affected.

To hide the Reaction Restrictions dialog box each time you start fragment generation

Clear the Display This Window Every Time Generation of Fragments & Mechanisms 
Is Started check box.

The application will not display the Reaction Restrictions dialog box when you start 
fragment generation. 

If you want to return to displaying the Reaction Restrictions dialog box each time you 
start fragment generation, follow the next procedure.

To restore the Reaction Restrictions dialog box each time you start fragment 
generation

1. Choose Options > Settings from the Mass Frontier main menu. 

2. Click Reaction Restrictions in the Parameters section.

3. Select the Display This Window Every Time Generation of Fragments & Mechanisms 
Is Started check box, and click OK.

The Reaction Restrictions dialog box opens each time you start fragment generation. 
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Base Page

Use the Base page to specify the type of knowledge base the system uses for predicting 
fragmentation pathways. See “Base page of the Reaction Restrictions dialog box” on page 202.

Follow these procedures:

• To minimize the generation of useless fragments

• To disable automatic simulation

• To speed up fragment generation

• To exclude mechanisms with unspecified charge sites

To minimize the generation of useless fragments

Some mechanisms of small fragments can fit virtually every structure and can generate an 
immense number of useless fragments. 

1. In the Spreadsheet view for the library, clear the Active check box for these structures in 
the Fragmentation Library. 

For additional information about active records, see “Spreadsheet View” on page 67.

2. In the Reaction Restrictions dialog box, select the Active Records Only check box.

The fragment generation ignores the inactive records in the Fragmentation Library. 

To disable automatic simulation

Select the Library Ionization Only check box and add an ionization mechanism to the 
library.

To speed up fragment generation

1. Select the General Fragmentation Rules option in the Knowledge Base area. 

The fragmentation library mechanisms must follow general fragmentation rules.

2. Clear the Ignore General Frag. Rules in Library Reactions check box in the 
Fragmentation Library Options area. 

Note  When a neutral molecule is provided, the application automatically simulates 
the ionization process according to the selected ionization mode on the Ionization & 
Cleavage page. You must first disable this automatic simulation feature to use a 
different ionization site. For additional information, see “Ionization and Cleavage 
Page” on page 204.
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To exclude mechanisms with unspecified charge sites

Select the Charge Localization Concept Only check box in the Fragmentation Library 
Options area.  

This option excludes mechanisms in the fragmentation library that contain unspecified 
charge sites from the generation process.

Figure 67. Base page of the Reaction Restrictions dialog box

Note  Structures with an unspecified charge site in the fragmentation library or in the 
starting structure slow the generation process. When you use an unspecified charge site, 
the system must consider a large number of combinations for each step. When possible, 
avoid using unspecified charge sites in the fragmentation library.

Table 23. Base parameters  (Sheet 1 of 2)

Feature Description

Knowledge Base

General Fragmentation 
Rules

Specifies general rules for generating fragments and 
mechanisms.

Fragmentation Library Activates the Selected Fragmentation Library and the 
Fragmentation Library Options areas where you can 
choose the libraries and options to use for generating 
fragments and mechanisms.

The HighChem Fragmentation Library contains 
approximately 19000 mechanisms, so calculation times 
are significantly longer when you choose this library.
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Both Uses both the general rules and the selected libraries to 
generate fragments and mechanisms.

Selected Fragmentation Library Specifies the fragmentation libraries to use for generating 
fragments and mechanisms.

Fragmentation Library 
Options

Active Records Only Ignores records in the Fragmentation Library that are not 
marked as Active. When this option is not selected, the 
fragmentation generation function considers all 
mechanisms from the selected libraries.

Library Ionization Only Disables the automatic simulation of the ionization 
process.

Ignore General Frag. Rules 
in Library Reactions

Skips the checking of general fragmentation rules to 
speed up the generation.

Charge Localization 
Concept Only

Excludes mechanisms in the fragmentation library that 
contain unspecified charge sites from the generation 
process.

Display This Window Every 
Time Generation of Fragments 
& Mechanisms Is Started

Opens the Reaction Restrictions dialog box each time you 
start fragment generation. Clear this check box if you 
want to use the same parameter settings for subsequent 
fragment generations and do not want to see this dialog 
box each time. 

If you clear this option and want to return to displaying 
the Reaction Restrictions dialog box each time you start 
fragment generation, follow the instructions “To restore 
the Reaction Restrictions dialog box each time you start 
fragment generation” on page 200.

Restore Defaults Restores all default values in the Reaction Restrictions 
dialog box. These values take effect after the regeneration 
of fragments and mechanisms and affect all subsequent 
generations. The current Fragments & Mechanisms 
windows are not affected. 

Open Imports the restriction parameter values from an .rrs file.

Save Saves the current restriction parameter values to an .rrs 
file.

Table 23. Base parameters  (Sheet 2 of 2)

Feature Description
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Ionization and Cleavage Page

Use the Ionization & Cleavage page to specify the ionization method. 

When comparing generated fragments and mechanisms with a mass spectrum, carefully 
choose the correct ionization method. The application warns you if the reaction restrictions 
are set for protonation techniques or chemical ionization and you are attempting to compare 
generated fragments with a spectrum from the NIST library, which contains only EI spectra. 
However, if the spectrum is from a file, the application does not check mass spectrum type 
and ionization techniques for consistency. For additional information, see “Importing the 
NIST/EPA/NIH Mass Spectral Database” on page 171.

Figure 68. Ionization & Cleavage page of the Reaction Restrictions dialog box

Table 24. Ionization & Cleavage parameters  (Sheet 1 of 3)

Feature Description

Ionization Method

Electron Impact Electron Impact (EI) mode that produces M+• ions.

Protonation Positive ionization [M+H]+. The protonation mode 
represents “soft ionization” techniques such as 
Electrospray Ionization (ESI), Atmospheric Pressure 
Chemical Ionization (APCI), Fast Atom Bombardment 
(FAB), and other techniques.
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Deprotonation Negative ionization [M–H]–. The deprotonation mode 
represents “soft ionization” techniques such as 
Electrospray Ionization (ESI), Atmospheric Pressure 
Chemical Ionization (APCI), Fast Atom Bombardment 
(FAB), and other techniques.

The deprotonation option does not support General 
Fragmentation Rules in the knowledge base. For 
additional information, see “Base Page” on page 201. 

You can only use deprotonation in connection with the 
Fragmentation Library. For additional information, see 
Chapter 7, “Fragmentation Library.” 

Cluster Ion Formation [M+NH4]+ or [M+H3O]+

Alkali Metal Adducts [M+Li]+, [M+Na]+, [M+K]+

Chemical Ionization The chemical ionization option offers three basic 
ionization reactions: protonation, hydride abstraction (see 
“Reaction Formalism” on page 194), and adduct 
formation.

In addition, you can select one of six most common 
reaction gases: methane (CH4), hydrogen (H2), isobutane 
(i–C4H10), ammonia (NH3), water (H2O), and nitrogen 
monoxide (NO).

Ionization On

Non-Bond El. Performs ionization on non bonded electrons.

Pi Bond [π] Performs ionization on Pi bonds. Available only when 
Electron Impact or Protonation ionization methods are 
selected.

Sigma Bond [σ] Performs ionization on Sigma bonds. Available only when 
Electron Impact ionization method is selected.

Cleavage

Alpha [α] Use alpha cleavage when generating fragments and 
mechanisms. Available only when Electron Impact 
ionization method is selected.

Inductive [i] Use inductive cleavage when generating fragments and 
mechanisms. 

Table 24. Ionization & Cleavage parameters  (Sheet 2 of 3)

Feature Description
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Display This Window Every 
Time Generation of Fragments 
& Mechanisms Is Started

Opens the Reaction Restrictions dialog box each time you 
start fragment generation. Clear this check box if you 
want to use the same parameter settings for subsequent 
fragment generations and do not want to see this dialog 
box each time. 

If you clear this option and want to return to displaying 
the Reaction Restrictions dialog box each time you start 
fragment generation, follow the instructions “To restore 
the Reaction Restrictions dialog box each time you start 
fragment generation” on page 200.

Restore Defaults Restores all default values in the Reaction Restrictions 
dialog box. These values take effect after the regeneration 
of fragments and mechanisms and affect all subsequent 
generations. The current Fragments & Mechanisms 
windows are not affected. 

Open Imports the restriction parameter values from an .rrs file.

Save Saves the current restriction parameter values to an .rrs 
file.

Table 24. Ionization & Cleavage parameters  (Sheet 3 of 3)

Feature Description
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H-Rearrangements Page

Use the H-Rearrangement page in the Reaction Restriction dialog box to specify the controls 
for setting four basic hydrogen rearrangements:

The hydrogen rearrangements that involve radical (odd-electron ions) rHA are set by default 
for hydrogen transfer from a steric optimal atom, usually from a γ-atom (McLafferty 
rearrangement). A hydrogen shift to an adjacent position (rH1,2) is activated by default and 
cannot be deactivated. For additional information, see “Reaction Formalism” on page 194.

There are two reasons for changing the default setup of rearrangements: 

• You are missing an important peak and you suspect an unusual rearrangement. You can 
compel hydrogen transfer from an α, β, γ, or δ atom.

• You might want to simplify a mechanism by deactivating rearrangements that cause 
redundant reaction steps.

Figure 69. H-Rearrangement page of the Reaction Restrictions dialog box
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Table 25. H-Rearrangement parameters

Feature Description

In Odd-Electron Ion [rHA]/
Hydrogen Transfer from Atom

Specifies one of the following hydrogen transfer methods:
• α
• β
• γ
• δ
• Steric Optimal

In Even-Electron Ion/
Hydrogen Transfer from Atom

Specifies one of the following hydrogen transfer methods:
• α, β, [rHB]
• γ [rHC]
• Charge-Remote Rearrangement [rHR]

Display This Window Every 
Time Generation of Fragments 
& Mechanisms Is Started

Opens the Reaction Restrictions dialog box each time you 
start fragment generation. Clear this check box if you 
want to use the same parameter settings for subsequent 
fragment generations and do not want to see this dialog 
box each time. 

If you clear this option and want to return to displaying 
the Reaction Restrictions dialog box each time you start 
fragment generation, follow the instructions “To restore 
the Reaction Restrictions dialog box each time you start 
fragment generation” on page 200.

Restore Defaults Restores all default values in the Reaction Restrictions 
dialog box. These values take effect after the regeneration 
of fragments and mechanisms and affect all subsequent 
generations. The current Fragments & Mechanisms 
windows are not affected. 

Open Imports the restriction parameter values from an .rrs file.

Save Saves the current restriction parameter values to an .rrs 
file.
208 Mass Frontier User Guide Thermo Scientific



 6 Fragments and Mechanisms Module
Specifying Reaction Restrictions
Resonance Page

The application generates fragmentation and rearrangement mechanisms along with electron 
shift reactions (resonance reactions). Because these reactions can cause a large number of 
by-products even for relatively small structures, by default, the resonance reactions are not 
depicted. 

To keep the reaction network simple, the application reduces reaction complexity by not 
displaying resonance reactions. As a result, elementary reaction steps that include resonance 
reactions are merged into a single step. If you have difficulty understanding such reduced 
mechanisms, you can display all resonance reactions.

Figure 70. Resonance page of the Reaction Restrictions dialog box

Table 26. Resonance parameters  (Sheet 1 of 2)

Feature Description

Resonance Reactions Specifies any of the following reactions:
• Electron Sharing [es]
• Charge Stabilization [er]
• Radical Isomerisation [rr]

Display Resonance Reactions

Yes Displays all resonance reactions.

No (Recommended) Does not display resonance reactions.
Thermo Scientific Mass Frontier User Guide 209



6 Fragments and Mechanisms Module
Specifying Reaction Restrictions
Display This Window Every 
Time Generation of Fragments 
& Mechanisms Is Started

Opens the Reaction Restrictions dialog box each time you 
start fragment generation. Clear this check box if you 
want to use the same parameter settings for subsequent 
fragment generations and do not want to see this dialog 
box each time. 

If you clear this option and want to return to displaying 
the Reaction Restrictions dialog box each time you start 
fragment generation, follow the instructions “To restore 
the Reaction Restrictions dialog box each time you start 
fragment generation” on page 200.

Restore Defaults Restores all default values in the Reaction Restrictions 
dialog box. These values take effect after the regeneration 
of fragments and mechanisms and affect all subsequent 
generations. The current Fragments & Mechanisms 
windows are not affected. 

Open Imports the restriction parameter values from an .rrs file.

Save Saves the current restriction parameter values to an .rrs 
file.

Table 26. Resonance parameters  (Sheet 2 of 2)

Feature Description
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Additional Page

By default, the application does not activate cleavage on an aromatic ring. However, you 
might activate bond cleavage on aromatic rings when working with small aromatic 
compounds. For example, when you generate fragments and mechanisms of phenol, you can 
generate the important fragment corresponding to the peak m/z  66 only after activating 
cleavage on aromatic systems. 

By default, cleavage on aromatic systems is deactivated because of the quantity of fragments 
that can be generated from large aromatic compounds and because the aromatic bond is a very 
strong bond.

Figure 71. Additional page of the Reaction Restrictions dialog box
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Table 27. Additional parameters 

Feature Description

Allowed on Aromatic System Specifies any of the following bonds on aromatic rings:
• Ionization
• Stabilization
• Cleavage

Hydrogen Radical Lost

Yes

No (Recommended)

Allowed 
Carbo - Cation/Anion

Specifies any of the following:
• Primary
• Secondary
• Tertiary

Display This Window Every 
Time Generation of Fragments 
& Mechanisms Is Started

Opens the Reaction Restrictions dialog box each time you 
start fragment generation. Clear this check box if you 
want to use the same parameter settings for subsequent 
fragment generations and do not want to see this dialog 
box each time. 

If you clear this option and want to return to displaying 
the Reaction Restrictions dialog box each time you start 
fragment generation, follow the instructions “To restore 
the Reaction Restrictions dialog box each time you start 
fragment generation” on page 200.

Restore Defaults Restores all default values in the Reaction Restrictions 
dialog box. These values take effect after the regeneration 
of fragments and mechanisms and affect all subsequent 
generations. The current Fragments & Mechanisms 
windows are not affected. 

Open Imports the restriction parameter values from an .rrs file.

Save Saves the current restriction parameter values to an .rrs 
file.
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Sizes Page

On the Sizes page in the Reaction Restrictions dialog box, you can limit the size and 
complexity of a reaction pathway generation. 

Increasing the maximum number of reaction steps can exponentially increase the number of 
fragments produced for a specified reaction path. Generally, keep this number small, and if 
you must generate additional fragments, you can select individual fragments to use as starting 
points for additional reactions. 

Large and structurally complicated molecules can produce an enormous number of reactions 
but consume a large amount of memory. This memory consumption limits the number of 
temporarily generated reactions. If the reactions limit is reached, the generation stops and the 
application displays an error message, but the fragments and mechanisms generated up to that 
point are displayed. The most important fragments are generated first, so even if a generation 
stops, the most important fragments have likely been generated. However, if you are missing 
an important fragment because you assume the generation was interrupted, you can increase 
the reactions limit. 

Figure 72. Sizes page of the Reaction Restrictions dialog box
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Table 28. Sizes parameters 

Feature Description

Reaction Steps

Max Number Specifies the maximum number of cascaded fragment 
reactions. 

Reactions Limit

Value Specifies the number of temporary internal reactions.

Mass Range

From Specifies the lower end of the m/z range.

To Specifies the upper end of the m/z range.

Display This Window Every 
Time Generation of Fragments 
& Mechanisms Is Started

Opens the Reaction Restrictions dialog box each time you 
start fragment generation. Clear this check box if you 
want to use the same parameter settings for subsequent 
fragment generations and do not want to see this dialog 
box each time. 

If you clear this option and want to return to displaying 
the Reaction Restrictions dialog box each time you start 
fragment generation, follow the instructions “To restore 
the Reaction Restrictions dialog box each time you start 
fragment generation” on page 200.

Restore Defaults Restores all default values in the Reaction Restrictions 
dialog box. These values take effect after the regeneration 
of fragments and mechanisms and affect all subsequent 
generations. The current Fragments & Mechanisms 
windows are not affected. 

Open Imports the restriction parameter values from an .rrs file.

Save Saves the current restriction parameter values to an .rrs 
file.
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Working with Generated Fragments
The Fragments & Mechanisms module automatically generates fragments and detailed 
fragmentation and rearrangement mechanisms from your chemical structure. 

This section includes the following topics:

• Linking Generated Fragments with a Spectrum

• Eliminating Generated Fragments Not Present in a Spectrum

• Simulating Fragmentation Processes in MS/MS Experiments

• Unexplained Peaks

• Bar Code Spectra

• Marking Fragments

• Specifying Precision and Isobaric Differentiation
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Linking Generated Fragments with a Spectrum

Use the Mass Frontier application to link generated fragments with a mass spectrum, which 
helps explain peaks in a spectrum. When you start a generation of fragments and mechanisms 
from the Database Manager window, the generated fragments are automatically linked with 
peaks in a spectrum according to their m/z values. After a generation, highlighted (explained) 
peaks are displayed in a different color—by default, red—in the original mass spectrum. 
Selecting a highlighted peak reveals all the mechanisms leading to it. In addition, you can 
automatically assign generated fragments.

To automatically assign generated fragments

In the Database Manager window, right-click the spectrum pane and choose 
Auto Annotation > Generated Fragments from the shortcut menu.

The corresponding Fragments & Mechanisms window must be open.

For additional information, see “Assigning Fragments to Spectral Peaks” on page 61.

When an unexplained peak is likely to be an isotopic peak of an explained peak, it is depicted 
in a third color—by default, green. Selecting such a peak reveals all the mechanisms leading to 
the fragment, which can produce this isotopic profile.

You cannot predict energies and barriers in ionized molecules, which prevents the prediction 
of all the peaks in a mass spectrum. In addition, the fragment predictability range is usually 
between 50 and 90 percent. However, a prominent unexplained peak can be of special value 
for interpreting or identifying an unknown. An unexplained peak can indicate a 
compound-specific mechanism that occurs in molecules with similar structural features or 
with a common substructure. Several mechanisms that have been observed only in a specific 
group of compounds cannot be applied generally when proposing fragmentation and 
rearrangement pathways. 

If you suspect a compound-specific mechanism of fragment formation, verify your 
assumption by conducting a substructure search. Then you can compare the explained and 
unexplained peaks in the spectra retrieved by the substructure search. 
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Eliminating Generated Fragments Not Present in a Spectrum

The Fragments & Mechanisms module shows all m/z values that have been generated with the 
specified Reaction Restrictions settings. When the generated fragments are linked with a 
spectrum—that is, the fragments were generated from a Database Manager window that 
contains the specified spectrum—you can eliminate the m/z values that do not have 
corresponding peaks in the spectrum. In some cases, the application generates a large number 
of theoretically possible fragments with a variety of m/z values; therefore, showing only those 
fragments that can be linked with a spectrum (explained peaks) is useful.

For additional information, see “Specifying Reaction Restrictions” on page 198 or “Linking 
Generated Fragments with a Spectrum” on page 216.

To eliminate m/z values that cannot be linked with peaks in a spectrum

Click the Show m/z Values For Explained Peaks Only button, , in the Fragments 
& Mechanisms window.

When you eliminate m/z values that do not correspond to a spectrum, these values are not 
permanently deleted. To restore the original display, click the Show m/z Values For 
Explained Peaks Only button again.

This Show m/z Values For Explained Peaks Only button switches the display between 
all generated m/z values and m/z values for explained peaks only.
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Simulating Fragmentation Processes in MS/MS Experiments

To simulate fragmentation processes in MSn experiments, you can generate the fragments and 
mechanisms from neutral compounds or from ions or you can select a product fragment 
(parent ion) in a Fragments & Mechanism window and start the generation from there. You 
can simulate an unlimited number of consecutive secondary ion decomposition reactions.
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Unexplained Peaks

In some cases, the fact that the application cannot explain a peak (because the corresponding 
fragment was probably formed by a compound-specific mechanism) can help in identifying 
characteristic structural groupings that give rise to the peak. For example, the phthalates 
produce a characteristic ion with m/z 149, which is formed by a highly specific mechanism. 
You can easily recognize the peak at m/z 149 as a contaminant from elasticized polymers. The 
application is not able to explain this peak because its corresponding fragment is formed by an 
unusual hydrogen rearrangement and cyclization, which are not supported. To distinguish 
between a randomly unexplained peak and a compound-specific peak, you must find 
examples in the library. Using a substructure search, you can retrieve compounds that contain 
a phthalate group as a common substructure. For additional information, see “(Sub)Structure 
Search” on page 84. 

After the generation of fragments and mechanisms of the retrieved examples, the prominent 
peak corresponding to the phthalate group remains unexplained in the majority of cases. For 
example, a phthalate with a functional group at position 3, 4, 5, or 6 will have its prominent 
peak shifted to higher masses by the mass of this functional group. Such an unexplained, 
prominent peak, present in the spectra of structurally similar compounds, can be a strong 
indicator of a compound-specific fragmentation process. This information can serve as 
evidence toward identifying a substructure under investigation.
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Bar Code Spectra

The Mass Frontier application can automatically predict possible fragments from a chemical 
structure using general rules and fragmentation libraries, along with initial determination of 
the structural plausibility of generated ions. Predicting mass spectra is hindered by the 
difficulty of predicting thermochemical data, thermodynamic stability of product ions, and 
reaction rates. However, you can use generated fragments and their m/z values for creating bar 
code spectra. A bar code spectrum contains peaks at predicted m/z values with identical 
(maximal) intensity.

For additional information, see “Previewing Unimolecular Reactions” on page 193 or “Using 
Library Reactions in Fragmentation Prediction” on page 237.

Follow these procedures:

• To create a bar code spectrum

• To compare multiple bar codes

To create a bar code spectrum

1. Click the Bar Code Spectrum button, , in the Fragments & Mechanisms window.

The Select Target dialog box opens.

2. Select one of the open Database Manager windows, or click New Database Manager to 
open a new window.

The created bar code spectrum is displayed in the selected Database Manager window. 

Bar code spectra are automatically linked with their original Fragments & Mechanisms 
windows. When you select any bar code peak in the Database Manager window, the 
Fragments & Mechanisms window displays the corresponding fragments and their formation 
mechanisms. This link remains in place as long as the corresponding Fragments & 
Mechanisms window is open. For additional information, see “Linking Generated Fragments 
with a Spectrum” on page 216. 
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You can use bar code spectra in several strategies for investigating spectra-structure 
relationships. The primary purpose of generating bar code spectra is that they make 
identifying spectral differences possible in structurally similar compound classes for which 
mass spectra are not available. To study fragmentation dissimilarities between 
structurally-related compounds, comparing multiple bar codes in the Database Manager 
window is easier than manually comparing fragments and their m/z ratios between multiple 
Fragments & Mechanisms windows. For additional information, see “Using the Compare 
Spectra Page” on page 43. 

To compare multiple bar codes

In the following example, you are interpreting an unknown spectrum and you have 
established two structural proposals. To find out which structure belongs to the unknown 
spectrum, do the following:

1. Draw both structures in separate Structure Editor windows.

2. Generate fragments for both structures. 

3. Create bar code spectra and save them to the same Database Manager window. 

4. Compare the bar code spectra on the Compare Spectra page in the Database Manager 
window. 

In the Difference Spectrum pane, you should see the specific peaks that this pair of 
spectra do not have in common. 

5. Compare these specific peaks with the unknown spectrum and take a closer look at the 
fragmentation mechanisms of these peaks. 

When a specific peak is present in the unknown spectrum and the mechanism of formation 
seems to be simple and plausible, you can select the most likely structure. This approach, 
using bar codes, is far superior to simply comparing explained peaks, because you can 
simultaneously apply it to a large number of structural proposals.

In the following example, the abundance is proportional to the number of generated 
m/z values that fit into a single integer m/z value. 
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Figure 73. Comparing multiple bar codes

Experimental and Bar Code spectra of 
Pyrrolidine[2,1-c]-2H,5H-1,4-benzodiazepin-2,5-dione, 1,3-dihydro- (Electron impact mode) 

Generated using 1ppm mass 
precision (monoisotopic mass 
settings)

Generated using unit mass 
precision
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Marking Fragments

You can use the generated fragments for fragment comparison of different structures or for 
export to an Excel spreadsheet. The automated generator can predict a large number of 
theoretically possible fragments. To extract only selected fragments for use during further 
processing, mark fragments (m/z values) that should be either considered or ignored.

The fragment marks apply to bar code spectra, the Fragments Comparator window, and 
copying to an Excel spreadsheet.

For additional information, see “Bar Code Spectra” on page 220 or “Comparing Fragments” 
on page 241.

To mark an m/z value using the toolbar buttons

Select the tab for the m/z value and click one of the following buttons:

To mark an m/z value using the check boxes in the m/z list

1. Click the check box for an m/z value in the m/z list until it displays the correct state. 

The check box can have one of three states:

• Set 

• Exclude 

• Default 

2. To mark all the m/z values as Default, click the Default button, , 
at the bottom of the list.

Mark Description

Set The Set mark has the highest priority. When any m/z values are 
marked Set, only these values are considered.

Exclude When you mark fragments Exclude, the marked fragments are 
not considered.

Default When no fragments are marked (by default), then all the 
fragments are considered.

Note  Changes you make to marks are instantly reflected in the Bar Code spectrum. After 
you send or copy a list of fragments with specific marks to the Fragments Comparator, the 
application ignores all subsequent changes. The same applies for a fragment list copied to 
an Excel spreadsheet. For additional information, see “Comparing Fragments” on 
page 241.
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Specifying Precision and Isobaric Differentiation

Use the features of the Mass/Abundance pages to specify m/z precision and isobaric 
differentiation of calculated fragments.

To set the m/z precision of calculated fragments

1. Choose Options > Settings from the Mass Frontier main menu. 

2. Click Mass/Abundance in the Parameters section.

3. Click the Mass Precision tab.

The Mass Precision page opens.

For detailed information about setting the parameters on the Mass Precision page, see 
“Precision” on page 384. 

To set the isobaric differentiation of calculated fragments

1. Choose Options > Settings from the Mass Frontier main menu. 

2. Click Mass/Abundance in the Parameters section.

3. Click the Mass Accuracy tab.

The Mass Accuracy page opens.

For detailed information about setting the parameters on the Mass Accuracy page, see 
“Accuracy” on page 381. 
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Fragmentation Library

Use the Fragmentation view in the Database Manager window to display fragmentation 
reactions in all your libraries and to create and manage fragmentation mechanism databases in 
your editable libraries.

The Fragmentation view contains a graphical editor for entering fragmentation reactions, 
which you can store in the library database with complementary information for the reaction. 
You can search all fields of the database, such as authors, ionization method, mass analyzer, or 
structures.

The fragmentation library uses an expert system to automatically extract a decomposition 
mechanism for each fragmentation reaction in the database and determine the compound 
class range to which you can apply the mechanism. This system applies database mechanisms 
to your structures and automatically predicts the fragmentation reactions for a specified 
compound.

Contents

• Drawing Fragmentation Reactions

• Editing a Fragmentation Scheme

• Working with Records

• Extracting Mechanisms

• Using Library Reactions in Fragmentation Prediction

• Searching for Fragmentation Criteria

• Comparing Fragments
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HighChem collated and entered fragmentation mechanisms published in all the available 
printed media dedicated to mass spectrometry. Each reaction, along with related chemical 
structures, was manually drawn in Reaction Editor and saved in the HighChem 
Fragmentation Library, which currently contains approximately 130000 individual reactions. 
See “Fragmentation mechanisms from the library” on page 227. Fragmentation pathways are 
accompanied with complementary information such as the title, the authors, and the 
information source. This library collection serves as a knowledge base for predicting 
fragmentation pathways from your structures.

To ensure the data is of the highest quality, the software rigorously evaluates fragmentation 
mechanisms in two stages: manual and automatic. The manual evaluation includes accuracy 
and plausibility assessments of reaction mechanisms and consistency checking between 
fragment masses and peak m/z values if the spectrum is available. The automatic evaluation 
includes simple element, charge, and radical consistency checks on both sides of the reaction 
and newly developed algorithms for complex electron mapping that has revealed formally 
erroneous mechanisms. Both stages have uncovered numerous problems and errors regarding 
mechanisms, and HighChem has either made the appropriate corrections or excluded these 
mechanisms from the library.
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Figure 74. Fragmentation mechanisms from the library

Note  The HighChem Fragmentation Library is a read-only library. You cannot copy, 
paste, or edit anything in the library.
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Drawing Fragmentation Reactions 
Use the Fragmentation view to enter and edit fragmentation reactions. 

Follow these procedures:

• To open the Fragmentation view for the current compound

• To create a new structure

• To edit an existing structure

• To add a reaction arrow

• To edit the arrow label

To open the Fragmentation view for the current compound 

Click the Fragmentation tab on the right side of the Database Manager window.

The Fragmentation view for the selected compound opens.
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To create a new structure

1. Do one of the following to open the Structure Editor dialog box:

Double-click the Reaction page drawing area.

–or–

Click the Add/Edit Structure button in the toolbar. 

–or–

Right-click a blank drawing area and choose New Structure from the shortcut menu. 

The Structure Editor dialog box opens. For detailed instructions about using the 
Structure Editor, see Chapter 4, “Structure Editor Module.” 

2. Create your structure in the Structure Editor.

Figure 75. Structure Editor dialog box

You cannot open another window until you close the Structure Editor dialog box. 

3. Click OK. 

The application adds your fragment to the Reaction page drawing area.

The new, unconnected structure is indicated with yellow handles, . If a scheme is 
formally incorrect, the software places a red border around it. 
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4. Click the Check button, , to identify critical errors in the scheme.

You cannot save schemes with one or more critical errors (such as an unconnected 
fragment or the presence of more than one scheme) to the database.

5. Drag the structure to any location on the drawing area.

To edit an existing structure

1. Do one of the following to open the structure in the Structure Editor dialog box:

Double-click the fragment. 

–or–

Select the structure and click the Add/Edit Structure button, , in the Reaction page 
toolbar. 

2. Use the tools in the Structure Editor dialog box to edit the structure.

For detailed instructions, see Chapter 4, “Structure Editor Module.” 

3. To confirm your changes, click OK.

The application updates the modified structure in the Reaction page drawing area.

To add a reaction arrow

1. Do one of the following:

a. Click the Draw Straight Arrow button, , in the Reaction page toolbar.

b. Position the cursor where you want the arrow on the drawing area, and click again. 

–or–

a. Right-click a structure and choose New Arrow.

b. Click the arrow and drag it to the correct location on the drawing area.

2. To be certain that the arrow connects the correct structures, look for the red selection 
squares.

As you move a connection arrow, red selection squares appear around the structure or 
arrow when the objects are close enough to connect.
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For the application to correctly extract mechanisms, you must properly connect the 
structures in a reaction scheme with arrows (see “Extracting Mechanisms” on page 235). 
The application considers stand-alone structures and disconnected arrows as errors and 
ignores them. 

When a structure is connected with at least one arrow, the Reaction page displays the 
selection squares in green . When a structure is not connected, the Reaction page 
displays the selection squares in yellow . The same color-coding applies to arrows. 
When an arrow is connected with a structure, this arrow end appears in green. When the 
arrow end is not connected, it appears in yellow.

To edit the arrow label 

1. Double-click the arrow.

The Arrow Caption dialog box opens.

2. Type or paste the text into the dialog box.

3. Use the formatting tool in the Arrow Caption dialog box to format your text.

4. Click OK.
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Editing a Fragmentation Scheme
In addition to a fragmentation reaction, you can also maintain text data in a database record. 

To open the Fragmentation Scheme data for the current compound 

1. Click the Fragmentation tab on the right side of the Database Manager window.

The Fragmentation view for the selected compound opens.

2. Click the Info tab on the top of the Fragmentation view.

The Info page for the selected compound opens. By default, all records on the Info page 
are expanded.

3. To display the Fragmentation Scheme data, do one of the following:

Click the plus sign next to Compound (to collapse the compound records).

–or–

Scroll down to the Fragmentation Scheme section.

Figure 76. Fragmentation Scheme data on the Info page

Note  To hide all empty records, right-click and choose Hide Empty Values from the 
shortcut menu.
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Working with Records 
The Mass Frontier application applies the mechanisms of fragmentation reactions to your 
structure and automatically predicts fragmentation reactions for the specified compound. 
However, the application might apply some mechanisms that are erroneous or too general. 
Some mechanisms of small fragments can fit to virtually every structure and can generate a 
large number of useless fragments. 

Excluding specific records can prevent the generation of a large number of fragments, which 
dramatically slows the generation process and makes reviewing the predicted fragments 
difficult. You can change record activity in the Active column of the Spreadsheet view. 

Follow these procedures:

• To exclude a record from the generation of fragments

• To include or exclude multiple records from the generation of fragments

• To sort records in the Spreadsheet view

• To save changes to the reaction and fragmentation scheme

To exclude a record from the generation of fragments

1. Select the record in the Spreadsheet view for the library.

2. Clear the Active check box.

Figure 77. Active check box in Spreadsheet view

To include or exclude multiple records from the generation of fragments

1. Select the records you want to activate.

2. Right-click the records and choose Activate All Selected Records or Deactivate All 
Selected Records from the shortcut menu.

Note  Changes to an Active check box are immediately updated in the database and 
do not need to be saved.

Active record
Inactive record
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To sort records in the Spreadsheet view

Click the column header.

You can sort any of the following criteria in ascending or descending order:

• Active and inactive records

• ID numbers (sorted 1–n)

• Molecular mass (sorted from smallest to largest)

• Formula (sorted from fewest to most Carbons, followed by fewest to most 
Hydrogens, and so forth)

• Title (sorted alphabetically)

To save changes to the reaction and fragmentation scheme 

Choose Library > Save Changes in Library from the Mass Frontier main menu.

The Mass Frontier application performs three sequential actions:

• Checks the fragmentation scheme on the Reaction page for formal correctness. If the 
software detects an error, you are prompted to either save the scheme as it is or return 
to the record to correct the problem. 

• Extracts a fragmentation mechanism for every single unimolecular reaction in the 
fragmentation scheme, using advanced algorithms. This process can take several 
seconds for complex reactions.  For additional information about extracting 
fragmentation mechanisms, see “Extracting Mechanisms” on page 235.

• Stores the reaction scheme, additional text, numerical data, and extracted 
mechanisms in the database. 

When you save a scheme with just a single error, the application does not extract the 
reaction mechanisms and ignores the entire record when predicting fragments and 
mechanisms. At any time, you can return to an erroneous record to fix the problem so 
that the software can perform fragmentation prediction for the record. 

Reaction symbols and reaction abbreviations appear only when you save a scheme. For 
additional information, see “Reaction Symbols” on page 236 or “Reaction Formalism” on 
page 194. 
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Extracting Mechanisms
The automated prediction of fragmentation and rearrangement pathways extracts 
unimolecular decomposition mechanisms from reactions you provide. The application 
decodes the underlying principle of fragmentation mechanisms from reaction drawings and 
builds a knowledge base of fragmentation events, replacing the need for the manual input of 
atom-atom correspondence in precursor and product ion pairs. For additional information, 
see “Drawing Fragmentation Reactions” on page 228 or “Base Page” on page 201.

The application processes specific fragmentation details (similar to labeled or generic 
structures) for use in experimental mechanistic studies to direct the dissociation route. Using 
deuteria or substituents participation, the decoding algorithm unambiguously extracts the 
underlying mechanism.

Figure 78. Extracted mechanisms

Because many reactions stored in a fragmentation library follow general fragmentation rules 
that can be predicted using preprogrammed unimolecular reactions, the library distinguishes 
between class-specific mechanisms and general fragmentation reactions. After you save a 
reaction to the database, the application attempts to identify a general fragmentation rule and 
assigns the relevant reaction symbol above the arrow. You can edit the reaction symbol of every 
reaction on the Reaction page by double-clicking the arrow and entering the new formatted 
text into the annotation dialog box.

With respect to fragmentation prediction, determining the preferred ionization site is as 
important as detailed knowledge of the fragmentation mechanism. The application supports 
the virtual generation of charged molecules based on library ionization reactions using the 

Two mechanistic possibilities can be extracted from 
the depicted fragmentation reaction.

Isotope labeling directs the decoding algorithm to 
the required rearrangement.

Note  Reaction symbols do not appear immediately after the reaction is drawn, but only 
after you save the record in a library. For a description of reaction symbols, see “Reaction 
Symbols” on page 236.
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exact location of the positive, negative, or unspecified charge location symbol that you can 
assign to a structure drawing. For additional information about modifying the charge location 
symbols, see “Modifying Atoms and Bonds” on page 139.

Reaction Symbols

The Mass Frontier application automatically extracts fragmentation mechanisms from a 
reaction drawing after you save a scheme. When a reaction follows one of the preprogrammed 
general fragmentation rules, the arrow is labeled with the particular rule abbreviation. For 
descriptions of these abbreviations, see “Reaction Formalism” on page 194.

Even when a reaction is formally correct, deriving a reaction mechanism from your drawing 
might not be possible because you entered an unfeasible fragmentation mechanism or the 
unimolecular reaction is incomprehensible to the application. When a mechanism cannot be 
extracted, the application puts a cross through the reaction arrow ( ). In this case, the 
mechanism is reduced to the exact precursor and product structures and only the identical 
neutral or ionic precursor is matched with your structure in the fragmentation prediction 
process. 

The application can sometimes decode a mechanism from a drawn reaction, but the 
atom-matching procedure will not be able to find the corresponding atom counterparts on 
both sides of the reaction leading to partially recognized mechanisms. When this occurs, the 
reaction arrow appears with a small line through it at right angles. This kind of reaction can be 
used only for fragment prediction for some input structures according to the decision of the 
fragmentation algorithm. Even when your input fragment looks similar to the precursor in the 
library reaction, a partially recognized reaction mechanism might not be selected for 
fragments prediction.

To overcome such a problem with unrecognized or partially recognized mechanisms, try to 
decompose complex one-step mechanisms into several simple reaction steps and then save 
these in a fragmentation library.

Figure 79. Graphical indicators of unrecognized mechanisms

Partially recognized mechanism

Unrecognized mechanism
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Using Library Reactions in Fragmentation Prediction
Library reactions create a database of fragmentation and rearrangement mechanisms that you 
can apply to your structures to predict the fragmentation pathways occurring in a mass 
spectrometer. The library mechanisms are extensions to the general fragmentation rules, 
which might not cover all the complex processes for a broad spectrum of ionization and ion 
activation techniques. For additional information, see “Previewing Unimolecular Reactions” 
on page 193. 

Library mechanisms provide flexibility in altering predicted fragmentation pathways and 
entering highly specific mechanisms that apply to a limited class of compounds. Because the 
Mass Frontier application contains approximately 130000 reactions, the fragmentation 
predictability is much higher than if only general rules were applied. This is particularly true 
for low energetic experiments such as ESI or APCI that often yield complicated skeletal and 
hydrogen rearrangements, unusual ring closures, or complex fragmentations. 

Any recognized and active mechanism that has been saved into a library serves as a knowledge 
base for predicting fragmentation pathways. After drawing and saving a reaction into any 
fragmentation library, you can use the mechanism template for predicting fragmentation 
pathways for any structure to which the derived mechanism can be applied. The applicability 
range depends on many factors, but structurally similar compounds with a common ring 
scaffold usually exhibit identical fragmentation mechanisms.

Fragment stability and general ion energetics depend on many thermodynamical parameters, 
and even a slight structural dissimilarity between two molecules can result in large differences 
in the course of fragmentation pathways. For example, two identical structures with a simple 
hydroxy group difference can occasionally exhibit completely different spectra and the derived 
fragmentation analogy based on library reactions might not always reflect the real 
fragmentation events for structural analogs.

When a fragmentation reaction is predicted using a library reaction, you can double-click the 
Lib arrow label to see the corresponding mechanism. Both template and generated 
fragmentation mechanisms are displayed in red in the Fragmentation view and in the 
Fragments & Mechanisms window. See “Generated fragmentation mechanisms” on page 238.
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Figure 80. Generated fragmentation mechanisms
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Searching for Fragmentation Criteria
Fragmentation libraries are fully searchable using various combinations of search criteria. 

Because fragmentation libraries largely contain ionic structures that can undergo resonance 
reactions, the Mass Frontier application can perform a resonance substructure search. This 
search feature ensures the correct retrieval of all resonance structures, even when the query 
structure is in a different resonance form than the library structure. This feature is fully 
automatic, so you need not worry about the particular resonance state of the ionic structures. 
However, be aware of this functionality when reviewing search results, as the query and library 
structures in positive search results might appear different if the resonance reactions are 
possible. In this case, do not consider this difference as an error, but rather be aware that there 
might be complex resonance variations.  For additional information about resonance 
reactions, see “Resonance Page” on page 209.

You can ignore charges and radicals in (sub)structure searches if their location is ambiguous. 
When searching structures with an unspecified charge location or substituents, review the 
applicable search rules. For descriptions of these search rules, see “(Sub)Structure Search 
Rules” on page 89.

Follow these procedures:

• To search Fragmentation data

• To search (Sub)Structure data

To search Fragmentation data

1. Choose Search > Fragmentation Data from the Mass Frontier main menu.

The Fragmentation Data Search dialog box opens.

2. Select the libraries you want to search.

3. Type the search criteria on the Data page or select criteria on the Advanced page.

For a detailed description of the Fragmentation Data Search dialog box, see 
“Fragmentation Data Search” on page 98.

4. Click OK.

Depending on the merge option you select, the search results appear in the Work library 
pane of the Database Manager window or in a new Database Manager window. 

To search (Sub)Structure data

1. Choose Search > (Sub)Structure from the Mass Frontier main menu.

The (Sub)Structure Search dialog box opens.

2. Select the libraries you want to search.
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3. Select search criteria on the Data page or the Advanced page.

For a detailed description of the (Sub)Structure Search dialog box, see “(Sub)Structure 
Search” on page 84.

4. Click OK.

The search finds all the reactions in the selected libraries with reaction precursor or 
product structures that match your queried (sub)structure. 

Depending on the merge option you select, the search results appear in the Work library 
pane of the Database Manager window or in a new Database Manager window. The 
search results display the query substructure in red in the library structure. 
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Comparing Fragments
Use the Fragments Comparator module to process and compare fragments generated in the 
Fragments & Mechanisms window. The fragments can originate from different structures. 
This module supports fragments generated using any ionization method. Using fragment 
marks in the Fragments & Mechanisms window, you can export a selected set of fragments 
into the Fragments Comparator module. The fragments are organized in columns. Each 
column represents a set of fragments provided by an associated Fragments & Mechanisms 
window. The Fragments Comparator module can hold a large number of fragment sets, 
limited only by system resources. For detailed instructions for marking fragments, see 
“Marking Fragments” on page 223.

The Fragments Comparator was designed as an integral part of the Fragments & Mechanisms 
module. When you double-click any fragment in the Fragments Comparator module, the 
associated mechanisms appear in the Fragments & Mechanisms window. The Fragments 
Comparator can recall only mechanisms that are present in an open Fragments & 
Mechanisms window. When you close the associated Fragments & Mechanisms window, the 
link is lost.

The comparison feature is especially useful when analyzing the fragmentation products of 
structurally related compounds. Common fragments point toward a common substructure in 
terms of fragmentation. Fragment differences can indicate fragments along with 
corresponding peaks in a spectrum that are characterized by distinct structural details. 
Predicted m/z values of fragments that are different for structurally related compounds are 
displayed on the Compare Spectra page in the Database Manager window. For a detailed 
description of the Compare Spectra page, see “Using the Compare Spectra Page” on page 43.

Fragments Comparator Window

The Fragments Comparator window consists of Table and Structures pages. The Table page 
lists the numerical m/z values of fragments, and the Structures page displays structural 
drawings of possible fragments. Because the Fragments & Mechanisms module can generate 
several isobaric isomers for a single m/z value, the Structures page imports only the first 
fragment for each generated m/z value. The Mass Frontier application simultaneously imports 
fragments into these two pages but manages the information independently. Moving or 
deleting a column on one page does not affect the other page.

The Fragments Comparator window can display structures of fragments only as long as the 
associated Fragments & Mechanisms window is open. When you close the associated 
Fragments & Mechanisms window, the corresponding column of fragments on the Structures 
page is removed.

On the Table page, you can select a column or a part of a column and copy the data. You can 
then paste the m/z values into an Excel spreadsheet or a similar application.

You can resize the cell on the Structure page with the Cell Size track bar, move columns in 
both pages, and delete the columns for imported fragments (the leftmost columns).
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Figure 81. Table page in the Fragments Comparator window

Figure 82. Structures page in the Fragments Comparator window
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Comparison Results

Both the Table and Structures pages in the Fragments Comparator window are divided into 
two parts. The left side displays columns of imported fragments for each Fragments & 
Mechanisms window. The right side displays three columns that show three types of 
comparison results. The first result column shows all available fragments (logical OR), the 
second column shows all common fragments (logical AND), and the third column shows 
different fragments (logical NAND). 

Note  The Mass Frontier application compares all fragments by their m/z values using 
Resolution Settings (see “Accuracy” on page 381). The fragments are usually predicted in 
several isomeric forms, making a structural comparison unreasonable. Because the 
application compares the fragments by m/z values, the calculated precision as defined in 
the Resolution Settings significantly influences the comparison results.
Thermo Scientific Mass Frontier User Guide 243





8

Chromatogram Processor Module

Use the Chromatogram Processor module for the extraction and processing of mass spectral 
scans from GC/MS or LC/MS files or from MSn data. Use this module to perform 
component detection, spectra deconvolution, spectral averaging, and background subtraction. 

You can display three types of chromatograms: Total Ion Chromatograms (TIC), MS and 
MS/MS chromatograms, and Extracted Ion Chromatograms (XIC). With the XIC feature, 
you can display individual mass chromatograms of ions that are characteristic for a specific 
compound.

Mass spectral scans, deconvoluted components, and various types of MSn data can be 
classified using these methods: PCA, SOM, or Fuzzy Clustering. You can search spectra in a 
library for positive compound identification or copy the spectra to a Database Manager 
window for further processing and archiving. You can also simultaneously open multiple 
chromatograms. Fully customizable chromatogram and mass spectrum layouts are available. 

In the Chromatogram Processor window, you can copy chromatograms with extracted spectra 
for importing into reports, spreadsheets, or other Windows programs. MSn data is displayed 
in tree structures so that you can view the dependencies. This module does not include target 
analysis or automatic quantitation of ions.

Contents

• Supported GC/MS and LC/MS Data File Formats

• Working in a Chromatogram Processor Window

• Using the Chromatogram Pane

• Averaging Scans

• Processing the Data

• Using the Extracted Ion Chromatogram Features

• Using Components Detection and Spectra Deconvolution

• Processing Extracted Spectra

• Working with Detected Components

• Processing MSn Data

• Exporting Scans, Components, and Reduced Chromatograms

• Annotating Chromatographic Peaks
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Supported GC/MS and LC/MS Data File Formats
The Mass Frontier application supports various data file formats for importing GC/MS and 
LC/MS files:

• Thermo Xcalibur raw data files (MS and MSn)

• Thermo Scientific LCQ™, GCQ™, ITS40, and Magnum

• Varian Saturn™ (Agilent)

• Agilent™ ChemStation™ 

• JACAMP (DOS, Windows, and UNIX™)

You can import these files to the Chromatogram Processor, and you can save single scans in 
JACAMP, MSP format, or as a HighChem Chromatogram file. The HCC format saves all 
actions applied to chromatogram.

This application supports “centroid” type data and displays centroid mass spectra in a bar 
graph. This application does not support “profile” type data for mass spectra. 

Because of various netCDF standards for implementation, the application might not be able 
to read some .cdf files.

Note  The Mass Frontier application supports features connected with chromatographic 
spectral trees for Xcalibur raw data (.raw) files only. For additional information, see 
“Processing MSn Data” on page 323.
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Working in a Chromatogram Processor Window
In the Chromatogram Processor window, you can copy chromatograms with extracted spectra 
for importing into reports, spreadsheets, or other Windows programs. MSn data is displayed 
in tree structures so that you can view the dependencies. Using text boxes, you can annotate 
chromatographic scans or components. This module does not include target analysis, 
structures, or automatic quantitation of ions.

Follow these procedures:

• To make the chromatogram files editable

• To open a Chromatogram Processor window

• To export scans or components to a Database Manager window

• To copy data to a Database Manager window

• To copy components to a Spectra Classifier window

To make the chromatogram files editable

1. In Windows Explorer, select all the files whose attributes you want to change.

The Mass Frontier software comes with GC/MS and Xcalibur MSn demonstration files, 
located in the C:\Documents and Settings\All Users\Documents\HighChem\Mass 
Frontier 7.0\Chromatograms directory.

2. Right-click the files and choose Properties from the shortcut menu.

3. Clear the Read-only check box in the Properties dialog box and click OK.

To open a Chromatogram Processor window

1. Do one of the following:

Click the Chromatogram Processor button, , in the Mass Frontier toolbar.

–or– 

Choose File > Open > GC/LC/MS from the Mass Frontier main menu.

–or– 

Double-click a HighChem chromatogram (.hcc) in Windows Explorer. 

The Open Chromatogram dialog box opens.

2. Select the raw data file and click Open.

The Chromatogram Processor window opens. See “Chromatogram Processor window” 
on page 250. 

Note  You cannot open GC/LC/MS files from a CD-ROM. If you have files on a 
CD-ROM, copy these files to the hard drive and disable the read-only file attribute to 
make them accessible for importing. 
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To export scans or components to a Database Manager window

1. Select the scans or components.

2. Click the Add Selected Scans/Components to Database Manager button, .

Because copying components can take several minutes, use this method to monitor the 
processing and, if needed, interrupt the operation. 

The Export Chromatographic and Spectral Data dialog box opens.

3. Select the option for the type of data you want to export.

4. Click Continue.

The Select Target dialog box opens.
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5. Do one of the following:

Select the Database Manager window for the exported data, and then click Select.

–or–

Click New Database Manager.

The export process begins.

6. To stop the export process, click Cancel.

To copy data to a Database Manager window

1. Select the components.

2. Right-click and choose Copy > Copy option from the shortcut menu.

You can copy a selection, chromatogram, MS spectrum, or an MS tree.

3. In a Database Manager window, right-click and choose Paste > option from the shortcut 
menu. 

For more information about exporting and importing chromatograms, see  “Exporting Scans, 
Components, and Reduced Chromatograms” on page 325. 

To copy components to a Spectra Classifier window

1. Select the scans or components.

2. Click the Add Selected Scans or Components to Spectra Classifier button, .

The Spectra Classifier window opens, and the selected components are displayed in the 
Available Groups of Spectra list.
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Figure 83. Chromatogram Processor window
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Using the Chromatogram Pane
The Chromatogram pane includes the following pages:

• TIC Page

• 3D View Page

• Info Page

TIC Page

The Chromatogram Processor window displays Total Ion Current (TIC) chromatograms on 
the TIC page. 

Figure 84. TIC page in the Chromatogram pane

Follow these procedures:

• To zoom in on the retention time or the intensity axis

• To use the toolbar zoom and pan features

• To select a scan from the TIC display

• To use the chromatogram pane visualization options

• To use the spectrum pane visualization options
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To zoom in on the retention time or the intensity axis 

1. Drag the cursor in the horizontal (retention time) or vertical (intensity) scale to form a 
rectangle around the region you want to enlarge. 

Figure 85. Enlarging the retention time scale

Figure 86. Enlarging the intensity scale

2. To return to the original scale, right-click and choose Zoom > Zoom Reset from the 
shortcut menu. 

Stretching the 
retention time scale

Results in peak separation

Stretching the intensity scale

Results in exaggerated 
peak height
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To use the toolbar zoom and pan features

• Click the Hand button, , in the Mass Frontier toolbar and drag the hand to pan 
horizontally or vertically.
Similarly, hold down the H keyboard key or the Spacebar to change the cursor to the 
hand.

• Click the Zoom Out button, , in the Mass Frontier toolbar.

• Click the Zoom In button, , in the Mass Frontier toolbar.

• Click the Zoom to Box button, , in the Mass Frontier toolbar and describe a 
rectangle. 
Similarly, hold down the Z keyboard key and describe a rectangle.

• Click the Zoom Reset button, , in the Mass Frontier toolbar to return to full scale.

• Click the Zoom Undo button, , in the Mass Frontier toolbar to undo the last zoom 
operation.

• Click the Zoom Redo button, , in the Mass Frontier toolbar to restore the last zoom 
operation.

• Use the scroll wheel on the mouse to zoom the entire display. 

To select a scan from the TIC display

1. Click the chromatogram pane to select a retention time.

The scan corresponding to the selected retention time is displayed on the Spectrum page. 
A vertical line in the chromatogram pane indicates the selected scan. 

2. To move the scan point to the next or previous scan, click the keyboard arrow keys.

Retention times (tR), scan numbers, and scan filters of active scans are displayed in the 
status bar.
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To use the chromatogram pane visualization options

1. In the Chromatogram pane, click the Visualization Options button, .

The Visualization Options pane opens.

2. Select the options for the chromatogram display.

The effect is immediate; the options pane remains open while you experiment with 
combinations of display options.

3. When you are satisfied with the display options, click the Visualizations Options button 
again to close the pane. 

To use the spectrum pane visualization options

1. In the Spectrum pane, click the Visualization Options button, .

The Visualization Options pane opens.

2. Select the options for the spectrum display.

The effect is immediate; the options pane remains open while you experiment with 
combinations of display options.

3. When you are satisfied with the display options, click the Visualizations Options button 
again to close the pane. 
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3D View Page

The 3D View page in the Chromatogram Processor window shows GC/MS or LC/MS data 
in a two-dimensional plot (retention time versus m/z value) where intensity as a third 
dimension is color-coded.

Figure 87. 3D View page in the Chromatogram Processor window
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Info Page

The Info page in the Chromatogram Processor window shows additional information saved in 
the data file. Each GC/MS or LC/MS file format contains a different list of items that 
describe sample, instrument, experimental condition, and other information. The application 
extracts information from the file and displays it on the Info page.

Figure 88. Info page in the Chromatogram pane
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Averaging Scans
The application can extract the average mass spectrum from several scans. 

To extract the average mass spectrum from several scans

1. Click the Show Scan Points button, , in the Chromatogram Processor toolbar.

2. Click the Chromatogram Processing Utilities button, , and choose Scans 
Average. 

3. Drag the cursor in the Chromatogram pane to indicate the region of the scans to be 
averaged.

The marked region is displayed in the same color as the active scan line (by default 
purple). The average spectrum is displayed on the Spectrum page. 

Figure 89. Averaged scans

4. To cancel the spectra average mode and restore the single scan mode, click anywhere in 
the chromatogram pane. 
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The interfacing of gas and liquid chromatography with mass spectrometry often produces a 
signal that is not associated with the information you want. The Mass Frontier application 
provides tools for GC/MS and LC/MS data processing to improve the useful signal. 

This section includes the following topics:

• Fragment Ion Search (FISh)

• Force Mass Tolerance

• Matrix Conversion

• Thresholding

• Baseline Correction and Noise Elimination

• Smoothing

• Base Peak Chromatogram

• Background Subtraction

Chromatographic data processing prepares valid data for automated detection and 
deconvolution of chromatographic components. There are two principally different ways of 
combining data processing and component detection:

• Preprocess data in advance by using a variety of methods for every processing type, 
separate with several customizable options, and then begin component detection. 

• Perform data processing at the same time as component detection, using predefined 
methods and options (optimized for common chromatograms) in the same window that 
is used for component detection. See “Using Components Detection and Spectra 
Deconvolution” on page 299.

Fragment Ion Search (FISh)

Fragment Ion Search (FISh) is a data processing method used for intelligent extraction of 
useful information from chromatograms. The FISh feature removes spectral peaks that are not 
present in the predefined template. A list of fragments or m/z values serves as the input 
template (Fragment Source). When you apply the FISh algorithm, all spectral peaks except for 
the template peaks are removed from the chromatogram. You can use this feature to extract 
structurally related spectral peaks, for example, peaks related to the parent drug in 
metabolite ID, or to eliminate the noise or impurity peaks. 

Follow these procedures:

• To apply fragment ion search to your data

• To drag actions from one Chromatogram Processor window to another

• To view an explanation of FISh results
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To apply fragment ion search to your data

1. Click the Apply Fragmentation Ion Search button, , in the Chromatogram 
Processor toolbar. 

The FISh Filter dialog box opens. See “Model page in the FISh Filter dialog box” on 
page 265.

2. Specify your fragment ion search parameters.

3. Click Calculate.

The application displays the status of the FISh processing.

4. When the fragment ion search is complete, click Close. 

The Chromatogram Processor window displays the detected components.

To drag actions from one Chromatogram Processor window to another

1. Open multiple Chromatogram Processor windows.

2. Select, define, and calculate the filters and detection methods in the source 
Chromatogram Processor window. 

The application adds these calculated filters and methods to the Actions pane 
Chromatogram Processor window.

3. Select an action in the Actions pane of the source Chromatogram Processor window.

Note  Do not click Cancel in this status box unless you intend to stop the FISh 
process.
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4. Drag the action to the Actions pane of the target Chromatogram Processor window.

5. Drag as many actions as you want from the any open source window to the target 
window.

The application copies each action and its associated parameters from the source 
Chromatogram Processor window to the target Chromatogram Processor window.

The Actions pane reports that the actions are not synchronized.

The detection method must always be the final action, but you can change the order of 
other filters in the Action pane.

6. Select the action you want to move and click the up or down arrow in the Actions pane 
toolbar.

The application moves the selected action.

7. To apply these actions to the current raw data file, do the following:

a. Select the check box for each of the actions you want to process.

b. Click the Apply Actions to Chromatogram button, , in the Action pane 
toolbar.

The Mass Frontier application processes each of the selected actions for the current raw 
data file.
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To view an explanation of FISh results

1. After FISh processing, right-click a spectrum in the Spectrum pane and choose FISh 
Explanation from the shortcut menu.

The application adds a FISh page and displays the results.

Table 29. FISh parameters

Parameter Description

Parent Opens the Structure Editor where you can define the parent.

Show Parent Highlights in red all fragments common to the parent.

Show Lets you select the maximum number of fragments to display 
in this page.

Show All Displays all fragments.

Show Unique Displays only unique fragments.

Show First Displays only the first fragments in each m/z group.

Cell Size Lets you resize the cells to fit more or fewer fragments in the 
display.
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Saving FISh Parameters to a File

Follow these procedures:

• To save all FISh processing parameters to a file

• To edit FISh parameters before saving them to a file

• To save FISh model parameters to a file

• To save FISh options parameters to a file

To save all FISh processing parameters to a file

1. When all processing is complete, click the Save Actions to a File button, , in the 
Actions pane of the Chromatogram Processor window.

The Save Chromatogram Actions dialog box opens.

2. Type a name for the Mass Frontier Chromatogram Actions (.hcca) file and click Save.

The applications saves the model and options parameters to the specified file.

To edit FISh parameters before saving them to a file

1. Click the Change Actions Parameters button, , in the lower left pane of the 
Chromatogram Processor window.

The Fish Filter dialog box opens. This dialog box does not have a Calculate button. You 
can edit the FISh parameters on this dialog box, but you cannot begin FISh processing.

The Fish Filter dialog box includes the following pages:

• “Model page in the FISh Filter dialog box” on page 265

• “Options page in the FISh Filter dialog box” on page 267

2. When you have finished changing the parameters, click OK.

A message in the Actions pane reports that, because of your edits, the FISh parameters are 
no longer synchronized with the previous filters. This is acceptable only for saving the 
edited parameters to a file.
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To save FISh model parameters to a file

1. On the Model page of the FISh Filter dialog box, select the Save FISh Model check box.

The Save FISh Flat File dialog box opens.

2. Type the name for the FISh Flat (.fish) file and click Save.

When you calculate the FISh filter, the application writes the model parameters to a .fish 
file. 

To save FISh options parameters to a file

1. On the Options page of the FISh Filter dialog box, click Save.

The Save FISh Parameters File dialog box opens.

2. Type the name for the FISh Parameters (.fish.par) file and click Save.

When you calculate the FISh filter, the application writes the options parameters to 
a .fish.par file. 

Loading FISh Parameters from a File

Follow these procedures:

• To load all FISh processing parameters from a file

• To load FISh model parameters from a file

• To load FISh options parameters from a file

To load all FISh processing parameters from a file

1. Click the Load Actions from a File button, , in the Actions pane of the 
Chromatogram Processor window.

The Load Chromatogram Actions dialog box opens.

2. Select a Mass Frontier Chromatogram Actions (.hcca) file and click Open.

When you calculate the FISh filter, the application uses the model and options parameters 
from the specified .hcca file. 
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To load FISh model parameters from a file

1. On the Model page of the FISh Filter dialog box, select the FISh Model check box.

2. Click the Open button, .

The Open FISh Flat File dialog box opens.

3. Select a FISh Flat (.fish) file and click Open.

When you calculate the FISh filter, the application uses the model parameters in the 
specified .fish file. 

To load FISh options parameters from a file

1. On the Options page of the FISh Filter dialog box, click Load.

The Open FISh Parameters File dialog box opens. Select a FISh Parameters (.fish.par) file 
and click Open.

When you calculate the FISh filter, the application uses the options parameters in the 
specified .fish.par file. 
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Figure 90. Model page in the FISh Filter dialog box

Table 30. Model parameters (Sheet 1 of 2)

Parameter Description

Fragments Defines the template list of fragments or m/z values that are not 
removed from a chromatogram.

Generated from 
Structure

Uses a list of fragments that you create in the Structure Editor 
module.

Fragments Uses a list of fragments that you can load from an SDF file.

Library Uses all fragments from the selected library.

Reference Spectrum Defines the m/z values to use as a reference spectrum.

Edit Opens the Input m/z List dialog box where you can create a list of 
m/z values. These values do not have implicit tolerance values, so 
enter these m/z values with the proper number of decimal digits. 
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Only Peaks that 
Match Subset of 
Formula

Enter a reference formula to limit the number of fragments.

Modifications Specifies a modifications list.

Edit Opens the Modifications dialog box where you can create new 
modifications or select predefined modifications.

FISh Model Use parameters from a saved FISh model (.fish.par) file. When 
you choose to use a saved file, all other parameter options are 
unavailable.

Save FISh Model Saves the active fragment source to the specified (.fish.par) file.

Buttons

Calculate Begins the fragment ion search process.

Reset Resets the chromatogram to its original (before fragment ion 
search) state. Uses the determined Mass Merge Power value in 
Baseline Correction and Noise Elimination, Smoothing, and the 
JCD Component Detection Algorithm as the starting value.

Close Closes the fragment ion search dialog box.

Default Returns the Mass Merge Power parameter to its default value.

Table 30. Model parameters (Sheet 2 of 2)

Parameter Description
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Figure 91. Options page in the FISh Filter dialog box

Table 31. Options parameters (Sheet 1 of 3)

Parameter Description

Filtering Target

Mark Peaks Marks the threshold peaks in red when they are large enough to be 
above threshold value (the point where Mass Frontier preserves 
peaks). Specifies that the predefined peaks are marked in pink and 
corresponding TIC are drawn in green. No peaks are removed.

Remove Peaks Specifies that peaks that are not predefined in the template are 
removed. 

Detect 
Components

Specifies JCD or TECD detection options.
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Filter Scans Specifies that only peaks are removed from scans, in contrast to 
the Filter Precursors option where entire scans are removed. The 
Mass Frontier application displays these options when you have a 
data-dependent chromatogram. 

• Apply to Top Stage Only: When selected, the filter is applied 
only to top stage scan (usually MS1 scans). Data-dependent 
scans are not affected in this case.

• Remove Data Dependent Scans: This option is active only if 
Apply to Top Stage Only is selected. When selected, the 
algorithm removes whole data-dependent scans for which the 
precursor peak was removed. When cleared, the filter is 
applied to a data-dependent scan in the same manner as a top 
stage scan (individually to each peak).

Filter Precursors Specifies that all spectra with a precursor ion not found in the 
predefined list are removed from the chromatogram and precursor 
ions are removed from parent spectra. This option is enabled for 
data-dependent chromatograms only.

• Filter Top Stage Scans: Modifies the top stage scans (usually 
MS1 scans). 

Isotopes

Use Monoisotopic 
Peaks Only

All other isotopes are ignored. This option uses the shortest 
computation time.

Mark Isotopic 
Pattern when 
Available

If a monoisotopic peak is recognized, the application includes 
other existing isotopes in the result. Missed isotopes do not 
influence the recognition of the peaks. This option produces the 
highest signal and can produce false positive results.

Use Full Isotopic 
Pattern Only

The peaks are included in the results only if a significant part of 
the isotopic profile is found in the analyzed spectrum. This option 
produces the most accurate result but can omit some peaks of low 
intensity and consumes the most time. The Mass Frontier 
application changes the option to Mark Isotopic Pattern when 
Available for data-dependent scans.

Constraints

Maximum 
Eliminated 
Abundance

Peaks with intensity higher than this value are not removed.

Use only m/z 
Range

Min/Max

Table 31. Options parameters (Sheet 2 of 3)

Parameter Description
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Buttons

Save Opens the Save FISh Parameters File dialog box where you can 
save your current parameters to a FISh parameters file (.fish.par).

Load Opens the Open FISh Parameters File dialog box where you can 
choose a FISh parameters file (.fish.par) to load.

Table 31. Options parameters (Sheet 3 of 3)

Parameter Description
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Force Mass Tolerance

Use the Force Mass Tolerance feature to change mass tolerance values for scans that you select. 
When processing spectra with different mass tolerance settings of different origins, you might 
want to force tolerance values to create comparable data. The Mass Frontier application uses 
tolerance values when comparing two m/z values.

To run the Force Mass Tolerance process

1. Select the type of scans you want to process from the filter list. 

If you select Force Tolerance Only to Current Filter in the Force Tolerance dialog box, the 
software processes only visible scans.

2. Click the Chromatogram Processing Utilities button, , and choose Force Mass 
Tolerance. 

The Force Tolerance dialog box opens. See “Force Tolerance dialog box” on page 271.

3. Specify your tolerance parameters.

If you select Force Tolerance Only to Current Filter, the software processes only visible 
scans.

4. Click Calculate.

5. When the process is complete, click Close. 

Note  Use the Force Mass Tolerance feature to check the correctness of search and 
calculation procedures by creating unit resolution from high accuracy/resolution data. You 
cannot improve accuracy using this feature. 
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Figure 92. Force Tolerance dialog box

Table 32. Force Tolerance parameters  (Sheet 1 of 2)

Parameter Description

General

Force Tolerance Only 
to Current Filter

Entered mass tolerance is forced only to scans visible in 
Chromatogram Processor.

Merge Similar Peaks The peaks that overlap are merged after forcing the tolerance. 

Mass Tolerance

The application supports these tolerance types:
• Unit
• Resolving power M/ΔM
• ppm 1 000 000 x ΔM/M
• Mass Accuracy (ΔM in AMU or ΔM in MMU)

where:

M = m/z (mass-to-charge ratio)

ΔM = M2 – M1 (M1, M2 are two adjacent peaks)

Peaks (m/z values) that fall into the ΔM band are merged into a 
single peak (m/z value).

Value Value of mass tolerance. 
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Buttons

Calculate Begins the forced mass tolerance process.

Reset Resets the chromatogram to its original (before forced mass 
tolerance) state.

Close Closes the mass tolerance dialog box.

Default Returns all mass tolerance parameters to their default values.

Save Opens the Save Force Tolerance Parameters File dialog box where 
you can save your current parameters to a Force Tolerance 
parameters file (.tolerance.par).

Load Opens the Open Force Tolerance Parameters File dialog box where 
you can choose a Force Tolerance parameters file (.tolerance.par) 
to load.

Table 32. Force Tolerance parameters  (Sheet 2 of 2)

Parameter Description
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Matrix Conversion

Some processing utilities, such as Baseline Correction and Noise Elimination, Smoothing, and 
the JCD Component Detection Algorithm, use internal matrix calculations. For high 
resolution/accuracy data, how the matrix is created can have a significant influence on the 
outcome of the processing utilities.

For additional information, see “Baseline Correction and Noise Elimination” on page 285, 
“Smoothing” on page 290, or “JCD Algorithm” on page 301.

The Mass Frontier application automatically converts a chromatogram to a matrix, where the 
first dimension is the scan number and the second dimension is an m/z value. Values of matrix 
cells are abundances. However, the oscillating m/z values of an identical ion might overlap 
with a different oscillating isobaric ion. In this case, it is very difficult to decide which m/z 
value should be taken as an independent dimension. Using the Matrix Conversion feature, 
you can control the alignment of oscillating m/z values to a specific value and you can visually 
control this process.

In the following example, the peaks are oscillating around m/z 402.15 and m/z 402.5 before 
matrix conversion. 

Figure 93. Oscillating peaks on the 3D View page

Note  Use this feature mainly for visual determination of Mass Merge Power. 
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In the following example, the peaks are aligned to discrete m/z 402.15 and m/z 402.5 after 
matrix conversion. 

Figure 94. Aligned peaks on the 3D View page

Matrix conversion uses the Mass Merge Power parameter to determine the strength of the 
alignment process. The software uses this parameter also in Baseline Correction and Noise 
Elimination, Smoothing, and the JCD Component Detection Algorithm; however, when you 
calculate matrix alignment, you can watch the immediate effect on the chromatogram.

To apply matrix conversion to your data

1. Click the Chromatogram Processing Utilities button, , and choose Matrix. 

The Matrix Conversion dialog box opens. See “Matrix Conversion dialog box” on 
page 275.

2. Specify the mass merge power percentage.

3. Click Calculate.

4. To undo a conversion, click Reset.

The application returns to the Mass Merge Power value specified in Baseline Correction 
and Noise Elimination, Smoothing, and the JCD Component Detection Algorithm as a 
starting value.

5. When the conversion process is complete, click Close.
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Figure 95. Matrix Conversion dialog box

Table 33.  Matrix Conversion parameters

Parameter Description

Mass Merge Power Specifies the percentage of mass resolution calculated from all 
scans in a chromatogram. It specifies the mass difference interval 
within the algorithm and merges spectral peaks into one m/z 
value. A low value can result in more individual m/z dimensions 
and a high value can result in merging more ions into one.

Buttons

Calculate Begins the matrix conversion process.

Reset Resets the chromatogram to its original (before matrix conversion) 
state. Uses the determined Mass Merge Power value in Baseline 
Correction and Noise Elimination, Smoothing, and the JCD 
Component Detection Algorithm as the starting value.

Close Closes the matrix conversion dialog box.

Default Returns the Mass Merge Power parameter to its default value.

Save Opens the Save To Matrix Conversion Parameters File dialog box 
where you can save your current parameters to a Matrix 
Conversion parameters file (.matrix.par).

Load Opens the Open Matrix Conversion Parameters File dialog box 
where you can choose a Matrix Conversion parameters file 
(.matrix.par) to load.
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Thresholding

Thresholding is a data processing method that analyzes every scan to reduce ion intensities or 
delete spectral peaks if algorithmic criteria have been met. The main purpose of thresholding 
is to eliminate noise or peaks originating from minor components that are not of interest. 
Thresholding requires fulfilling the condition that the intensity of noise peaks is smaller than 
the intensity of a signal and that the noise peaks count is significantly higher than the signal 
peaks count.

This section includes the following topics:

• Specifying Methods

• Using the Threshold Filter Wizard

To apply thresholding to your data

1. Click the Chromatogram Processing Utilities button, , and choose 
Thresholding. 

The Threshold Filter dialog box opens. See “Threshold Filter dialog box” on page 277.

2. Specify your thresholding parameters.

3. Click Calculate.

4. When the thresholding process is complete, click Close.

Note  In contrast to Baseline Correction and Noise Elimination (see “Baseline Correction 
and Noise Elimination” on page 285), which operates in a chromatographic time domain, 
the thresholding feature processes each scan as a stand-alone, independent object that 
ignores the previous or following scans. Setting thresholds can significantly shorten JCD 
computation time for large chromatograms.
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Figure 96. Threshold Filter dialog box

Table 34. Threshold Filter parameters  (Sheet 1 of 2)

Parameter Description

General

Remove Peaks Removes the threshold peaks. 

Mark Peaks Marks the threshold peaks in red when they are large enough to be 
above threshold value (the point where the Mass Frontier 
application preserves peaks). No peaks are removed. The same 
logic is applied for FISh filtering. 

Apply Threshold 
to Top Stage Only

Specifies that only MS1 (full scan) scans are processed.

Minimal 
Remaining Peak 
Count
Minimal Peaks per 
Scan

Specifies that the number of the most intense peaks specified in the 
Minimal box is not affected by thresholding.
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Algorithmic Enables algorithmic thresholding parameters.

Method Specifies that one of the following algorithms is used: Linear Fit, 
Histogram, or Median. See “Specifying Methods” on page 279.

Strength In the Linear Fit or Histogram method, the calculated threshold 
value is multiplied by this value. 
In the Median method, this value is used for calculation of filter 
length.

Apply Threshold 
to Spectra with 
Peak Count 
Higher Than

Specifies that algorithmic thresholding is applied to spectra with 
several peaks higher than the specified value.

Maximal Allowed 
Threshold

Specifies that the algorithmic threshold is applied to spectral peaks 
with an intensity lower than the specified value.

Manual Enables manual thresholding parameters.

Threshold Specifies that all peaks that exhibit an intensity lower than the 
specified value are deleted.

Buttons

Wizard Displays a simplified version of the Threshold filter parameters. 
See “Using the Threshold Filter Wizard” on page 283.

Calculate Begins the thresholding process.

Reset Resets the chromatogram to its original (before thresholding) state.

Close Closes the Threshold Filter dialog box.

Default Returns all thresholding parameters to their default values.

Save Opens the Save Threshold Parameters File dialog box where you 
save your current parameters to a threshold parameters file 
(.threshold.par).

Load Opens the Open Threshold Parameters File dialog box where you 
can choose a threshold parameters file (.threshold.par) to load.

Table 34. Threshold Filter parameters  (Sheet 2 of 2)

Parameter Description
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Specifying Methods

The threshold filter uses one of three options for methods: 

• Linear Fit

• Histogram

• Median

Linear Fit

The process of determining a linear fit occurs as follows:

• The Mass Frontier application applies Intensity = a + b × (m/z) to a scan, and then applies 
the test for outlier data (using Student's t-distribution) to each scan peak. 

• The Mass Frontier application considers outlier peaks as signals and excludes them from 
noise. 

• In iterative form, the Mass Frontier application applies linear regression and exclusion of 
outlier peaks (signal) to each considered peak while finding no new outlier points. 

• The Mass Frontier application determines a threshold value as the intensity of the most 
intensive noise peak (the highest peak that is not excluded from noise).
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Figure 97. Linear Fit method
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Histogram

A histogram is created from abundances of all peaks in analyzed scans (black circles on the 
figure), and then each histogram is smoothed (red triangles) and the end of the peak or the 
minimum between two peaks is considered as the threshold value (green line).

Figure 98. Histogram method
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Median

The median filter is applied to an analyzed scan (red line). The maximal filtered abundance is 
used as the threshold value.

Figure 99. Median method
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Using the Threshold Filter Wizard

The Threshold Filter wizard is a simplified version of the Threshold Filter parameters.

To open the Threshold Filter wizard

1. In the Threshold Filter dialog box, click the Wizard button, .

The Threshold Filter dialog box minimizes to a simplified version.

2. To return to the complete version of the Threshold Filter dialog box, click Details.

Figure 100. Threshold Filter Wizard dialog box

Table 35. Threshold Filter Wizard parameters (Sheet 1 of 2)

Parameter Description

Wizard

Remove Peaks Directly removes the threshold peaks. 

Mark Peaks Mark the threshold peaks in red only with 
corresponding TIC showing in red as well. No 
peaks are removed.

Apply Threshold to Top Stage Only Specifies that only MS1 (full scan) scans are 
processed.

Power Specifies the percentage of mass resolution 
calculated from all scans in a chromatogram on a 
linear scale. This value specifies the mass 
difference interval within the algorithm and 
merges spectral peaks into one m/z value. A Soft 
value can result in more individual m/z 
dimensions and a Strong value can result in 
merging more ions into one. 
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Buttons

Details Displays the full version of the Thresholding 
Filter parameters. See “Threshold Filter dialog 
box” on page 277.

Calculate Begins the thresholding process.

Reset Resets the chromatogram to its original (before 
thresholding) state.

Close Closes the Threshold Filter dialog box.

Default Returns all thresholding parameters to their 
default values.

Save Opens the Save Threshold Parameters File dialog 
box where you save your current parameters to a 
threshold parameters file (.threshold.par).

Load Opens the Open Threshold Parameters File 
dialog box where you can choose a threshold 
parameters file (.threshold.par) to load.

Table 35. Threshold Filter Wizard parameters (Sheet 2 of 2)

Parameter Description
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Baseline Correction and Noise Elimination

Baseline correction and noise elimination algorithms analyze ion profiles (ion 
chromatograms) of all ions appearing in spectra over the entire region of a chromatogram. In 
contrast to thresholding, where the individual scans and their spectral peaks are independently 
analyzed and modified, baseline correction and noise elimination analyze and modify spectral 
peaks in a specified retention time range.

To apply baseline correction and noise elimination to your data 

1. Click the Chromatogram Processing Utilities button, , and choose Baseline. 

The Baseline & Noise dialog box opens. See “Baseline & Noise dialog box” on page 286.

2. Specify your baseline correction and noise elimination parameters.

3. Click Calculate.

4. When the baseline and noise process is complete, click Close. 

Note  In contrast to thresholding, which processes each scan independently while ignoring 
the previous or following scans, the Baseline Correction and Noise Elimination feature 
processes data in a chromatographic time domain, following trends over a specified 
retention time range.
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Figure 101. Baseline & Noise dialog box

Table 36. Baseline & Noise parameters (Sheet 1 of 3)

Parameter Description

Mass Merge Power Specifies the mass difference within which the algorithm 
merges spectral peaks into one m/z value. A low value might 
result in more components (oscillating ions) and a high value 
can result in fewer components (merging ions).

General

Clear Only Top Stage Processes only spectra in MS1 stage (full scan).
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Segmentation Divides the chromatogram into discrete parts to which the 
algorithms are applied separately. This option can provide 
better results if a chromatogram exhibits diverse shape, peak 
density, and baseline characteristics over the retention time 
scale. Avoid segmentation if you use a LOESS derivative filter 
or if results obtained without segmentation are acceptable.

Use Baseline Correction Applies one of the following methods to your chromatogram: 
Top-Hat filter, Savitzky-Golay derivative filter, or LOESS 
derivative filter.

Top-Hat Filter A morphological two-step filter. First, the algorithm searches 
the average value (opening) of signal on an area around the 
analyzed peak and then it subtracts this value from the 
original analyzed peak.

Savitzky-Golay 
Derivative Filter

Baseline is defined by the point where the first derivation of a 
smoothed ion profile (values from Savitzky-Golay filter) is 
smaller than the value represented by the parameter Power. 
This baseline is then subtracted from the original ion profile. 
Time domain is determined by the Length parameter.

LOESS Derivative 
Filter

Principally identical with the Savitzky-Golay derivative filter 
but it does not require equidistant sampling.

Use Noise Elimination Applies the following methods individually or simultaneously: 
Counter filter reduces chemical noise and Quantile filter 
reduces electronic noise.

Counter Filter Counts the occurrence of non-zero peaks in ion profile. If the 
percentage of signal occurrence is higher than the Length 
parameter, the ion is considered as chemical noise and the 
whole ion profile is removed.

Quantile Filter Counts the occurrence of non-zero peaks in neighboring 
space on both sides (2×Length + 1 peaks). If the percentage of 
signal occurrence is smaller than the Fraction parameter, the 
analyzed peak is removed. This filter removes narrow peaks.

Buttons

Wizard Displays a simplified version of the Baseline & Noise filter 
parameters. See “Baseline & Noise wizard dialog box” on 
page 288.

Calculate Begins the baseline correction and noise elimination process.

Reset Resets the chromatogram to its original (before baseline 
correction and noise elimination) state.

Table 36. Baseline & Noise parameters (Sheet 2 of 3)

Parameter Description
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Figure 102. Baseline & Noise wizard dialog box

Close Closes the Baseline & Noise dialog box.

Default Returns all baseline correction and noise elimination 
parameters to their default values.

Save Opens the Save Baseline & Noise Parameters File dialog box 
where you save your current parameters to a threshold 
parameters file (.baseline.par).

Load Opens the Open Baseline & Noise Parameters File dialog box 
where you can choose a threshold parameters file 
(.baseline.par) to load.

Table 37. Baseline & Noise parameters (Sheet 1 of 2)

Parameter Description

Mass Merge Power Specifies the mass difference within which the algorithm 
merges spectral peaks into one m/z value. A low (Soft) value 
might result in more components (oscillating ions) and a high 
(Strong) value can result in fewer components (merging ions).

Clear Only Top Stage Processes only spectra in MS1 stage (full scan).

Use Baseline Correction Applies the correction method specified in the detailed 
Baseline & Noise dialog box.

Table 36. Baseline & Noise parameters (Sheet 3 of 3)

Parameter Description
288 Mass Frontier User Guide Thermo Scientific



 8 Chromatogram Processor Module
Processing the Data
Preserve Small Peaks Preserves small peaks when baseline correction is used.

Use Noise Elimination Applies the methods specified in the detailed Baseline & 
Noise dialog box: Counter filter reduces chemical noise and 
Quantile filter reduces electronic noise.

Buttons

Details Displays a detailed version of the Baseline & Noise filter 
parameters. See “Baseline & Noise dialog box” on page 286.

Calculate Begins the baseline correction and noise elimination process.

Reset Resets the chromatogram to its original (before baseline 
correction and noise elimination) state.

Close Closes the Baseline & Noise Filter dialog box.

Default Returns all baseline correction and noise elimination 
parameters to their default values.

Save Opens the Save Baseline & Noise Parameters File dialog box 
where you save your current parameters to a threshold 
parameters file (.baseline.par).

Load Opens the Open Baseline & Noise Parameters File dialog box 
where you can choose a threshold parameters file 
(.baseline.par) to load.

Table 37. Baseline & Noise parameters (Sheet 2 of 2)

Parameter Description
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Smoothing

The Mass Frontier application performs smoothing to average ion profiles (not the total ion 
chromatogram) for every ion (m/z value) found in the data file with their neighbors in a time 
series. Smoothing can increase correct component detection and eliminate spikes, which cause 
false positive results. For additional information, see “Using Components Detection and 
Spectra Deconvolution” on page 299.

To apply smoothing to your data

1. Click the Chromatogram Processing Utilities button, , and choose Smoothing. 

The Smoothing dialog box opens. 

2. Specify your smoothing parameters.

3. Click Calculate.

4. When the smoothing process is complete, click Close. 

Figure 103. Smoothing dialog box
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Table 38. Smoothing parameters (Sheet 1 of 2)

Parameter Description

Mass Merge Power Specifies the mass difference within which the algorithm 
merges spectral peaks into one m/z value. A low value might 
result in more components (oscillating ions) and a high value 
can result in fewer components (merging ions).

General

Smooth Top Stage 
Only

Applies smoothing only to MS1 stage (full scan).

Segmentation Divides the chromatogram into discrete parts so that the 
software can apply separate algorithms to each part. This 
option can provide better results if the chromatogram exhibits 
diverse shape, peak density, and baseline characteristics in the 
retention time scale. Avoid segmentation if using a LOESS or 
Median filter or if results obtained without segmentation are 
acceptable.

Method This list includes the following smoothing methods: 
Savitzky-Golay, Median, and LOESS. In contrast to Median 
and LOESS methods, the Savitzky-Golay method requires 
time-equidistant scans.

Method

Median Smoothing Smooths each ion profile in the chromatogram using the 
Median filter. The Length parameter determines the filter 
length.

Savitzky-Golay 
Smoothing

Smooths each ion profile in the chromatogram using the 
Savitzky-Golay filter. The Length parameter determines the 
filter length.

This smoothing requires equidistant time steps between scans. 
If smoothed results are not acceptable, use another method or 
check segmentation.

LOESS Smoothing Smooths each ion profile in the chromatogram using the 
LOESS filter. The Length parameter determines the filter 
length. This filter works in a similar way as the Savitzky-Golay 
filter but is slower and does not require equidistant time steps 
between scans. When Robust Smoothing is on, then the 
smoothing is slower but more robust to outlier data in ion 
profiles.
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Buttons

Wizard Displays a simplified version of the Smoothing filter 
parameters. See “Smoothing wizard dialog box” on page 293.

Calculate Begins the smoothing process.

Reset Resets the chromatogram to its original (before smoothing) 
state.

Close Closes the Smoothing dialog box.

Default Returns all smoothing parameters to their default values.

Save Opens the Save Smoothing Parameters File dialog box where 
you save your current parameters to a smoothing parameters 
file (.smooth.par).

Load Opens the Open Smoothing Parameters File dialog box where 
you can choose a smoothing parameters file (.smooth.par) to 
load.

Table 38. Smoothing parameters (Sheet 2 of 2)

Parameter Description
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Figure 104. Smoothing wizard dialog box

Table 39. Smoothing wizard parameters (Sheet 1 of 2)

Parameter Description

Mass Merge Power Specifies the mass difference within which the algorithm 
merges spectral peaks into one m/z value. A low value might 
result in more components (oscillating ions) and a high value 
can result in fewer components (merging ions).

General

Smooth Top Stage 
Only

Applies smoothing only to MS1 stage (full scan).

Segmentation Divides the chromatogram into discrete parts so that the 
software can apply separate algorithms to each part. This 
option can provide better results if the chromatogram exhibits 
diverse shape, peak density, and baseline characteristics in the 
retention time scale. Avoid segmentation if using a LOESS or 
Median filter or if results obtained without segmentation are 
acceptable.

Method This list includes the following smoothing methods: 
Savitzky-Golay, Median, and LOESS. In contrast to Median 
and LOESS methods, the Savitzky-Golay method requires 
time-equidistant scans.

Method

Median Smoothing Smooths each ion profile in the chromatogram using the 
Median filter. The Length parameter determines the filter 
length.
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Savitzky-Golay 
Smoothing

Smooths each ion profile in the chromatogram using the 
Savitzky-Golay filter. The Length parameter determines the 
filter length. This smoothing requires equidistant time steps 
between scans. If smoothed results are not acceptable, use 
another method or check segmentation.

LOESS Smoothing Smooths each ion profile in the chromatogram using the 
LOESS filter. The Length parameter determines the filter 
length. This filter works in a similar way as the Savitzky-Golay 
filter but is slower and does not require equidistant time steps 
between scans. When Robust Smoothing is on, then the 
smoothing is slower but more robust to outlier data in ion 
profiles.

Buttons

Details Displays a detailed version of the Smoothing filter parameters. 
See “Smoothing dialog box” on page 290.

Calculate Begins the smoothing process.

Reset Resets the chromatogram to its original (before smoothing) 
state.

Close Closes the Smoothing dialog box.

Default Returns all smoothing parameters to their default values.

Save Opens the Save Smoothing Parameters File dialog box where 
you save your current parameters to a smoothing parameters 
file (.smooth.par).

Load Opens the Open Smoothing Parameters File dialog box where 
you can choose a smoothing parameters file (.smooth.par) to 
load.

Table 39. Smoothing wizard parameters (Sheet 2 of 2)

Parameter Description
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Base Peak Chromatogram

The Base Peak Chromatogram process calculates a TIC profile based on the most intense 
spectral peak in each scan. This option is a display feature only; no data is modified. 

To apply the Base Peak Chromatogram to your data

Click the Chromatogram Processing Utilities button, , and choose Base Peak 
Chromatogram. 

The application marks the most intense peak for each scan in the Chromatogram pane.
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Background Subtraction

To eliminate the background signal from an active scan or from the average of spectral scans, 
you can perform a manual background subtraction. 

To set the location of two representative background scans

1. Click the Chromatogram Processing Utilities button, , and choose 
Background Subtraction. 

The cursor changes appearance, , to indicate this functionality.

2. Click a scan point in the chromatogram pane. 

A green vertical line indicates the background scans. The Scan pane displays the resulting 
spectrum. 

3. To cancel a background subtraction, click the Chromatogram Processing Utilities 
button, , and choose Delete Background Subtraction. 

The Extracted Ion Chromatogram feature can help you choose the two most 
representative background scans. You can use these background scans in the Manual 
background subtraction option in Automated Components Detection and Spectra 
Deconvolution procedures. 

For additional information, see “Using the Extracted Ion Chromatogram Features” on 
page 297 and “Using Components Detection and Spectra Deconvolution” on page 299.

To see the effects of the background subtraction on a scan

1. Copy the extracted and the original spectra to a Database Manager window.

See “Working in a Chromatogram Processor Window” on page 247.

2. Compare them using the spectra comparison routine on the Compare Spectra page.
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Using the Extracted Ion Chromatogram Features
Use the Mass Frontier application to display a chromatogram for an extracted ion in a 
different color. The extracted ion chromatogram (XIC) is sometimes called an individual, or 
single ion chromatogram, ion profile. The program can display up to 16 extracted ion 
chromatograms per window.

You can use background subtraction in conjunction with the Extracted Ion Chromatogram 
feature. In this case, the XIC profiles are extracted from background-subtracted scans.

To display an XIC for a particular mass-to-charge ratio

1. Do one of the following:

Click a spectral peak in the Scan pane.

–or–

Click the Data tab and double-click the m/z value in the mass-to-charge ratio table.

–or–

Click the Add/Edit Extracted Ion Chromatograms (XIC) button, .

The Extracted Ion Chromatograms dialog box opens. 

2. Change or add the mass-to-charge ratio.

3. Define XIC tolerance. 

Set a value of zero (the default value) to compare the XIC for m/z value with peaks using 
peak accuracy only. 

Set a non-zero value of tolerance (± m/z value) to compare the peak m/z value/accuracy 
with “XIC for m/z” ± its tolerance. 

4. Select a color for a particular m/z value.
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5. Click OK. 

The application extracts the XIC from the original file, a process that can be 
time-consuming for chromatograms with a large number of scans. However, because the 
application is multi-threading, you can still use other windows during the XIC extraction.

An extracted ion chromatogram is useful for verifying automated component detection and 
spectra deconvolution results. An XIC helps you to recognize mixture components in a peak 
region. Examine an XIC of model peaks for any component you might want to use in further 
analysis. Some structural (alkanes) or optical isomers produce almost identical mass spectra, 
and even if you can clearly see two or more maxima in a peak region, an XIC might not reveal 
a multi-component profile.

An XIC can help you determine whether the composition of the background changes over the 
course of a run. To view the background profile, extract the XIC of a base peak or a 
prominent peak from a scan that is clearly in a non-peak region. If the XIC of a background 
peak has a variable profile around the peak you are focusing on, choose two scans with 
different XIC profiles for background subtraction.

Figure 105. Extracted ion chromatogram ion profiles
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Using Components Detection and Spectra Deconvolution
The Mass Frontier application incorporates an automated system for detecting 
chromatographic components in complex GC/MS or LC/MS runs and extracting mass 
spectral signals from closely coeluting components (deconvolution). You can search individual 
mass spectra or spectral trees obtained after deconvolution in libraries or you can classify them 
using Principal Component Analysis or Neural Networks. For additional information about 
PCA or Neural Networks, see “Principal Component Analysis (PCA)” on page 341 or 
“Self-Organizing Maps” on page 343.

This Components Detection and Spectra Deconvolution system involves the combined use of 
the following procedures:

• Noise examination, signal filtering, and smoothing

See “Processing the Data” on page 258.

• Baseline definition and demarcation of chromatographic peaks

• Background scan determination and background subtraction

• Component candidate detection and model ion selection (m/z)

• Correlation of model ion profiles and component confirmation or rejection

• Spikes elimination

• Calculation of exact component retention time

• Spectra deconvolution using linear algebra

This system is designed for broad types of chromatographic runs, for both GC/MS, LC/MS, 
and GC/LC/MSn analyses, for clean and noisy signals, and for simple or complex 
chromatograms (see “Processing MSn Data” on page 323). However, you might need to 
change some parameters to optimize the system for specific applications. This automated 
procedure is designed for small- and medium-sized organic compounds. Do not use this 
procedure for the processing of proteins, peptides, oligonucleotides, or other biomolecules.
Thermo Scientific Mass Frontier User Guide 299



8 Chromatogram Processor Module
Using Components Detection and Spectra Deconvolution
Figure 106. Components detection and spectra deconvolution example

The Mass Frontier application incorporates an advanced automated system for detecting 
chromatographic components in complex GC/MS or LC/MS runs and extracting mass 
spectral signals from closely coeluting components (deconvolution).

The application identifies components using the following algorithms:

• JCD Algorithm

• RCD Algorithm

• TECD Algorithm

• Direct Infusion Algorithm
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JCD Algorithm

Joint Components Detection (JCD) is based on the statistical analysis of all ion profile 
maxima. Ion profiles (ion chromatograms) with comparable shapes and maxima belonging to 
a limited time range are considered as a single component. The algorithm extracts individual 
mass spectral peak abundance profiles to produce a “purified” spectrum or spectral trees and 
generates the peak shape of a representative component. For best results, use the JCD 
algorithm, but be aware that it requires significant computer processing resources.

To significantly reduce computation time for large files, apply a threshold filter to the 
chromatogram before performing JCD. See “Thresholding” on page 276 for more 
information about applying thresholds.

To run the Joint Components Detection algorithm

1. Click the Components Detection & Spectra Deconvolution button, , and 
choose JCD.

The Joint Detection Algorithm dialog box opens.

2. Specify your JCD parameters.

3. Click Calculate.

4. When the detection process is complete, click Close.

Note  These parameters are interdependent, so changing one parameter can affect 
algorithms linked with other parameters.
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Figure 107. Deconvolution page of the Joint Detection Algorithm dialog box

Table 40. Deconvolution parameters (Sheet 1 of 3)

Parameter Description

Mass Merge Power Specifies the mass difference within which the algorithm merges 
spectral peaks into one m/z value. A low value might result in 
more components (oscillating ions) and a high value can result in 
fewer components (merging ions).

Average Peak Width Specifies the chromatographic peak width in scans that the 
algorithm uses to identify a potential component. If a value is too 
high, the result might be the loss of narrow peaks. If a value is too 
low, it might split a real component into two different 
components. Average Peak Width is applied only for scans that are 
specified in Analyze MS Stages parameter. For example, if Analyze 
MS Stages is set to Top Stages, then Average Peak width is applied 
to MS1 scans only.
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Baseline Correction Applies an automated baseline correction for each ion profile 
using the Top-Hat algorithm. Use this option only for 
chromatograms with an elevated baseline.

Smoothing Performs the smoothing of each ion profile using the Average Peak 
Width value and the LOESS algorithm. If the Average Peak 
Width parameter is too large or peaks are shorter than four to five 
scans, then the smoothing can remove small peaks.

Noise Modification Determines how to adjust the intensity values of spectral peaks 
with comparable abundances to noise level. You can choose from 
None, Elimination, or Transition.

None Spectral peak intensities are not altered.

Elimination Spectral peaks with intensities lower than the specified value are 
eliminated. Use this method when low abundant peaks are not of 
interest. 

Min. Peak Height: The threshold value applied to each abundance 
in an ion profile. This value is determined as a percentage of the 
maximum of the analyzed ion profile. All abundances smaller than 
this threshold are removed. This option speeds up calculations.

Transition Default. Artificial noise is added to replace random spikes with 
constant noise for better detection of low abundant components. 
Abundances with zero value are replaced by artificial noise.

Analyzed MS Stages Determines which MS stages are considered in the analysis of ion 
profiles—that is, which MS stages are used for detecting 
components. The remaining stages are only used for spectral tree 
reconstruction. Select one of the following options:

• Top Stages level: Recommended in most cases.
• Lower Stages level: Useful if Data Dependent experiment is 

set so that ions are isolated according to a predefined list of 
m/z values and top-stage spectra are noisy. 

• All Stages level: Useful for the preliminary analysis of complex 
data.

Top Stages 
(default)

Analyzes only the top stage ions present in the data, where “top” 
means MS1, or MS/MS if MS1 is not present. The algorithm 
builds the component tree by joining the corresponding lower 
stage spectra that meet the following criteria: they occur within 
the component envelope and the software detected the precursor 
m/z in the top stage as a component ion (if the deconvoluted MS1 
spectrum contains peaks that have been further isolated, the 
corresponding MS/MS spectra are assigned to the spectral tree). 
Recommended option for most cases.

Table 40. Deconvolution parameters (Sheet 2 of 3)

Parameter Description
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Lower Stages Analyzes all ions except those from the top MS stages. The 
algorithm calculates the spectrum of the top stage from the total 
ion abundance of the top stage. The resulting spectral trees do not 
have as much depth as those from the Top Stages option. This 
option can be useful if the full-scan chromatogram is not well 
resolved and the lower stages contain enough scans with the same 
precursor value.

All Stages Analyzes all ions regardless of the MS stage. The resulting spectral 
trees do not have as much depth as those from the Top Stages 
option. This option is useful in some cases when the FISh 
algorithm is applied in metabolite ID (see “Base Peak 
Chromatogram” on page 295).

Beginning of Tree 
Branching

Determines MS stage where a spectral tree is divided into two or 
more independent components based on the precursor ion.

Retention Time Range Specifies only a part of a chromatogram to be analyzed (time 
range), which can speed up your work. In this case, the algorithm 
ignores regions outside of the specified range.

m/z Range Determines the m/z value range to be analyzed. Ignores other 
spectral regions. This feature is useful when processing large 
chromatograms.

Buttons

Wizard Displays a simplified version of the component detection 
parameters. See “Joint Detection Algorithm wizard dialog box” on 
page 307.

Calculate Begins the component detection process.

Reset Resets the chromatogram to its original (before component 
detection) state.

Close Closes the component detection dialog box.

Default Returns all component detection parameters to their default 
values.

Save Opens the Save JCD Parameters File dialog box where you can 
save your current parameters to a JCD parameters file (.jcd.par).

Load Opens the Open JCD Parameters File dialog box where you can 
choose a JCD parameters file (.jcd.par) to load.

Table 40. Deconvolution parameters (Sheet 3 of 3)

Parameter Description
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Figure 108. More page of the Joint Detection Algorithm dialog box

Table 41. More parameters (Sheet 1 of 2)

Parameter Description

Baseline Threshold Specifies the peak baseline as a percentage of base peak height.

Allowed Local Maxima Specifies the sensitivity to local minima of ion profiles. Peak ends 
are detected if the local minimum of analyzed ion profile is greater 
than this value. Value is determined as a multiple of estimated 
noise.

Min. XIC Peak Height Specifies the minimal ion profile peak height to be considered as a 
potential component. Value is determined as a multiple of the 
estimated noise.

Min. Component 
Height

Specifies the minimal intensity of component peaks. This value is 
determined as a percentage of intensity of the total ion 
chromatogram at the position of the component maxima.
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Merging Width Factor Specifies a limit for the time difference of the ion profiles maxima. 
Too high a value can cause the merging of randomly coeluting 
components. Too low a value can split a component into more 
false-positive components. The software merges ion profile peaks 
within this range into a single component.

For additional information, see “Wide Component Merge Mode” 
on page 314. 

Peak Shape Tolerance Specifies the degree (%) of similarity of ion profile shapes. If two 
ion shapes meet the specified percentage for the sharpness 
tolerance, as well as other parameters, the algorithm merges the 
ions into a single component.

Wide Component 
Merge Mode

Specifies whether to use a limit for the time difference of the ion 
profile maxima in a combination of the following parameters: 
Average Peak Width and Merging Factor. Select this check box 
(default) to avoid splitting a component into ion peaks that are 
detected as redundant components in chromatograms with wide 
peaks. Clear this check box if an incorrect component merge 
occurs. Recommended for most LC/MS experiments.

Table 41. More parameters (Sheet 2 of 2)

Parameter Description
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Figure 109. Joint Detection Algorithm wizard dialog box

Table 42. Joint Detection Algorithm wizard parameters (Sheet 1 of 2)

Parameter Description

Average Peak Width Specifies an automatically calculated average peak width, or lets 
you specify the average peak width.

Power of Baseline 
Correction

Specifies the power of the baseline correction within a low-to-high 
range.

Smoothing Power Specifies the smoothing power applied to each ion profile within a 
low-to-high range.

Components 
Overlapping Sensitivity

Specifies the overlap sensitivity within a low-to-high range.
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Intensity of Detected 
Components

Specifies the intensity of detected components within a 
low-to-high range.

Tree Branching Specifies one of the following:

 Parent ions are merged into one component.

 Each parent ion produces an individual tree.

Table 42. Joint Detection Algorithm wizard parameters (Sheet 2 of 2)

Parameter Description
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RCD Algorithm

Rapid Components Detection (RCD) is based on a model ion that represents a characteristic 
ion (m/z value in MS1 spectra) for every detected component. The algorithm starts with 
component candidate detection and model ion selection and continues with the correlation of 
model ion profiles to confirm or reject a candidate.

To run the Rapid Components Detection algorithm

1. Click the Components Detection & Spectra Deconvolution button, , and 
choose RCD.

The R-Component Detection Algorithm dialog box opens. This dialog box includes the 
following pages:

• “Deconvolution page of the R-Component Detection Algorithm dialog box” on 
page 310

• “More page of the R-Component Detection Algorithm dialog box” on page 312

2. Specify your RCD parameters.

3. Click Calculate.

4. When the detection process is complete, click Close.

Note  These parameters are interdependent, so changing one parameter can affect 
algorithms linked with other parameters.
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Figure 110. Deconvolution page of the R-Component Detection Algorithm dialog box

Table 43. Deconvolution parameters (Sheet 1 of 3)

Parameter Description

Threshold of Total 
Signal

The program uses a different threshold level from the one 
specified in the data file. In especially noisy chromatograms, 
setting the threshold higher can reduce the number of false 
positive results. However, if you feel the algorithm is too restrictive 
and is missing some chromatographic peaks, you can lower the 
default value. 

Minimum Model 
Ion Abundance

The algorithms search for spectral peaks (model ions) that have 
the most rapid rise and fall of a signal in a peak region. To 
eliminate spikes and random fluctuations, a model ion should 
exhibit a minimum abundance value.

Minimum Component 
Spacing

Eliminates the components within a specified retention time 
interval.
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Smoothing Use this option when you must analyze noisy data. The program 
automatically determines the smoothing factor according to the 
signal-to-noise ratio. You can change this value or switch off the 
smoothing. The system uses an exponential filter similar to the 
analog RC filter.

Spectra Difference 
Factor

To eliminate false positive component detection, the adjacent 
components must show some degree of spectral dissimilarity that 
is represented as the match factor used in library searching. The 
spectra Difference Factor value is the minimal match factor 
between spectra that detected components should exhibit.

Background 
Subtraction

When you select the Automatic option, the program attempts to 
find a region of relatively constant signal intensity before and after 
every peak and sets two background scans there. To use the 
Manual option, set the background scans by clicking the 
Chromatogram Processor Utilities button and choosing 
Background Subtraction before starting the detection and 
deconvolution process (see “Background Subtraction” on 
page 296). You can set two manual background scans anywhere in 
the chromatogram. When you select the None option, 
background subtraction is not performed.

Precursor Ion 
Subtraction

When a product ion chromatogram is being deconvoluted, you 
can subtract the selected precursor ion from all scans to improve 
component detection. However, if a component does not 
fragment and you can only observe a precursor ion, you should 
not apply the subtraction because you can overlook this 
component. Note that this application does not support scan 
events that are often used in connection with product ion 
scanning.

Scale Component 
Profile

Scale the component profile (envelope) to fit the intensity of a full 
scan.

Retention Time Range Where you specify only a part of a chromatogram to be analyzed 
(time range), which can speed up your work. In this case, the 
algorithm ignores regions outside of the specified range.

m/z Range Determines the m/z value range to be analyzed and ignores other 
spectral regions. This feature is useful when processing large 
chromatograms.

Table 43. Deconvolution parameters (Sheet 2 of 3)

Parameter Description
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Figure 111. More page of the R-Component Detection Algorithm dialog box

Spectra Deconvolution You can apply two extraction algorithms, the choice depending on 
the intended use for the component spectra. When components 
are intended for a library search (see “Spectrum Search” on 
page 79), use Sharp spectra deconvolution. When the purpose of 
component detection is target analysis, use Soft deconvolution. 
Generally, Sharp deconvolution subtracts peaks from coeluting 
components with a higher multiplication factor, and so it 
produces spectra with fewer peaks and lower intensities of isobaric 
peaks than Soft deconvolution.

Restore Defaults when 
Program Starts

Resets these parameters to the default values each time you start 
the Mass Frontier application.

Buttons

Calculate Begins the component detection process.

Reset Resets the chromatogram to its original (before component 
detection) state.

Close Closes the component detection dialog box.

Default Returns all parameters to their default values.

Save Opens the Save RCD Parameters File dialog box where you can 
save your current parameters to a RCD parameters file (.rcd.par).

Load Opens the Open RCD Parameters File dialog box where you can 
choose a RCD parameters file (.rcd.par) to load.

Table 43. Deconvolution parameters (Sheet 3 of 3)

Parameter Description
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TECD Algorithm

The TECD (Total Extraction Components Detection) algorithm creates spectral trees for 
every section of a chromatogram that starts with an MS1 scan. Each generated tree is then 
divided into subtrees based on the value of the Minimal Tree Depth parameter. Generated 
subtrees are merged into components based on the precursor ion m/z value identity and the 
spectral tree match factor similarity.

You can apply the TECD algorithm to data-dependent chromatograms only. This algorithm 
creates components according to precursor values and spectra similarity only. It is not as 
advanced as JCD but it is significantly faster.

To run the Total Extraction Components Detection algorithm

1. Click the Components Detection & Spectra Deconvolution button, , and 
choose TECD.

The Total Extraction Component Detection Algorithm dialog box opens.

2. Specify your TECD parameters.

3. Click Calculate.

4. When the detection process is complete, click Close.

Note  These parameters are interdependent, so changing one parameter can affect 
algorithms linked with other parameters.
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Figure 112. Total Extraction Component Detection Algorithm dialog box

Table 44. Total Extraction Component Detection Algorithm parameters (Sheet 1 of 2)

Parameter Description

Beginning of Tree 
Branching

Specifies the minimum number of tree sections the algorithm 
creates from the initial spectral tree. The value determines the MS 
stage where a division of a spectral tree takes place.

Tree Match Factor Specifies the minimum percentage that two spectral trees within 
adjacent tree sections must match before the algorithm considers 
the two spectral trees as the same component. Matching spectral 
trees is defined as having identical precursors up to the level 
specified by the Minimal Tree Depth value and a Tree Match 
Factor value that exceeds the specified value.

Wide Component 
Merge Mode

Enables a comparison of the spectral trees for potential matching 
and merging, not only in adjacent sections, but also in sections up 
to the distance specified by the Allowed Gap value. 

Allowed Gap When comparing the spectral trees for potential merging, specifies 
the maximum distance between nonadjacent tree sections.

Analyze only Current 
Filter

Processes only visible scans (scans chosen by scan filter) using the 
TECD algorithm.
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Direct Infusion Algorithm

The Direct Infusion algorithm is a spectral tree construction utility. Use this algorithm to 
create one or more spectral trees from a single raw file by reading various MSn scans acquired 
in one run and constructing a tree according to their MS stage and precursor ion m/z values.

To run the Direct Infusion algorithm

1. Click the Components Detection & Spectra Deconvolution button, , and 
choose Direct Infusion.

The Direct Infusion Spectral Tree Construction dialog box opens.

2. Specify your Direct Infusion parameters.

3. Click Calculate.

4. When the construction process is complete, click Close.

Retention Time Range Specifies only a part of a chromatogram to be analyzed (time 
range), which can speed up your work. In this case, the algorithm 
ignores regions outside of the specified range.

m/z Range Determines the m/z value range that is analyzed. Ignores other 
spectral regions. This feature is useful when processing large 
chromatograms.

Buttons

Calculate Begins the component detection process.

Reset Resets the chromatogram to its original (before component 
detection) state.

Close Closes the component detection dialog box.

Default Returns all component detection parameters to their default 
values.

Save Opens the Save TECD Parameters File dialog box where you can 
save your current parameters to a TECD parameters file 
(.tecd.par).

Load Opens the Open TECD Parameters File dialog box where you can 
choose a TECD parameters file (.tecd.par) to load.

Table 44. Total Extraction Component Detection Algorithm parameters (Sheet 2 of 2)

Parameter Description

Note  These parameters are interdependent, so changing one parameter can affect 
algorithms linked with other parameters.
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Figure 113. Direct Infusion Spectral Tree Construction dialog box

Table 45. Direct Infusion Spectral Tree Construction parameters (Sheet 1 of 2)

Parameter Description

Beginning of Tree 
Branching

Specifies the MS stage that should only have a single precursor. 
The value determines the MS stage for a tree branch division. 
When you use the default value of 1, the algorithm creates a single 
tree from all the scans in a run (file). When you use a value of 2, 
and the analyzed run contains MS/MS spectra with different 
precursor m/z values, the algorithm creates separate trees for each 
MS/MS scan with a unique precursor ion m/z value.

Threshold Ion 
Intensity

Removes spectral peaks of lower intensity than specified from each 
analyzed scan.

Include Upper Spectra Adds actual scans in the stage above the level set in Minimal Tree 
Depth to the resulting spectral trees. When you clear this option, 
the spectra above the stage set in Minimal Tree Depth contain 
spectra with a single peak equal to the precursor ion of the product 
spectra.

Average Scans Specifies that every tree node only contains average spectra.

Calculate Envelope When selected, the software calculates the ion profile (envelope) 
for each tree. You can then preview scans that belong to a 
particular tree.
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Retention Time Range Specifies only a part of a chromatogram to be analyzed (time 
range), which can speed up your work. In this case, the algorithm 
ignores regions outside of the specified range.

m/z Range Determines m/z value range for analysis. Ignores other spectral 
regions. This feature is useful when processing large 
chromatograms.

Buttons

Calculate Begins the spectral tree construction process.

Reset Resets the chromatogram to its original (before spectral tree 
construction) state.

Close Closes the spectral tree construction dialog box.

Default Returns all spectral tree construction parameters to their default 
values.

Save Opens the Save Direct Infusion Parameters File dialog box where 
you can save your current parameters to a Direct Infusion 
parameters file (.infusion.par).

Load Opens the Open Direct Infusion Parameters File dialog box where 
you can choose a Direct Infusion parameters file (.infusion.par) to 
load.

Table 45. Direct Infusion Spectral Tree Construction parameters (Sheet 2 of 2)

Parameter Description
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Processing Extracted Spectra
Use the Database Manager or Spectra Classifier windows to further process a spectrum 
obtained from the average of scans, from scans with a subtracted background, or from 
component deconvolution. You can also directly search for the spectrum in a Chromatogram 
Processor library. 

You can classify mass spectra obtained in the Chromatogram Processor using Principal 
Component Analysis, Neural Networks, or Fuzzy Clustering methods.

For additional information, see “Organizing Spectra” on page 345, “Principal Component 
Analysis (PCA)” on page 341, “Fuzzy Clustering” on page 344, or Chapter 12, “Neural 
Networks Module.” 

Follow these procedures:

• To choose scans or deconvoluted spectra for classification

• To search the extracted spectra

• To transfer the extracted spectrum or tree to a Database Manager window

• To transfer the extracted spectrum or tree to a Spectra Classifier window

• To copy a spectrum to a Windows application

To choose scans or deconvoluted spectra for classification

1. Select the scans or components that you want to classify.

You can select scans from the chromatogram pane or components from the filter list.

2. Click the Add Selected Scans or Components to Spectra Classifier button, .

The Spectra Classifier window opens.

Figure 114. Spectra Classifier window with spectra from a Chromatogram Processor
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To search the extracted spectra 

1. Click the Search button, .

The Component Search dialog box opens.

2. To perform a tree search, see “Spectral Tree Search” on page 74.

3. To perform a spectrum search, see “Spectrum Search” on page 79.

To transfer the extracted spectrum or tree to a Database Manager window

1. Select the components.

2. Right-click and choose Copy > Copy option from the shortcut menu.

You can copy an MS spectrum or an MS tree.

3. In a Database Manager window, right-click and choose Paste > option from the shortcut 
menu.

4. To process the components, see Chapter 2, “Database Manager Module.” 

To transfer the extracted spectrum or tree to a Spectra Classifier window

1. Select the components.

2. Click the Add Selected Scans or Components to Spectra Classifier button, .

The Spectra Classifier window opens.

3. To process the components, see Chapter 10, “Spectra Classifier Module.” 

To copy a spectrum to a Windows application

1. Select the spectrum.

2. Right-click and choose Copy > Copy MS Spectrum from the shortcut menu.

The application copies the chromatogram graphic and the spectrum from the Scan page 
to the Clipboard.

3. Open any Windows application and paste the contents of the Clipboard.

Note  Use the Paste Special command in the Windows applications to paste these 
graphics.
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Working with Detected Components
Detected components are marked with a triangle in the original chromatogram (see “Using 
Components Detection and Spectra Deconvolution” on page 299). Because the program 
calculates the precise retention time (tR) of each component, the component triangle can 
appear between scan points.

When you pause the cursor over a component triangle, a ToolTip displays the component 
number, precise retention time, and model ion m/z value that were used in the automated 
detection and deconvolution processes.

To edit or search chromatographic components in the Components Editor window, click the 
Components Editor button, . 

To process detected components in the Database Manager or in the Spectra Classifier 
modules, you must select them, copy them, and paste them into the Database Manager or 
Spectra Classifier windows. 

For details about processing detected components, see  “Processing Data-Reduced 
Chromatograms” on page 69 or Chapter 10, “Spectra Classifier Module.” .

Follow these procedures:

• To select a component

• To select a range of components

• To select all detected components in a run

• To copy the selected components to a Database Manager window

• To copy the selected components to a Spectra Classifier window

Note  To display a deconvoluted spectrum of a component rather than of a scan, click the 
triangle that marks the detected component in the chromatogram pane. To display an 
original scan at the position of a detected component, click above the triangle.
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To select a component

Click the triangle on the peak.

A deconvoluted spectrum appears in the scan pane. 

You can process this spectrum the same way you would any spectra, for example, search 
for it in a library or copy it to a Database Manager window. 

To select a range of components

1. Click the Select Components button, .

2. Draw a rectangle around the components.

The application makes a strict distinction between original scans and detected 
components and does not mix them. When selecting a chromatographic region, the 
application prefers components over scans. When you select a chromatographic region 
that contains both scans and components, the software selects only the components. 
When you select a region that does not contain any components, the software selects all 
scans in that region. 

To select all detected components in a run

Right-click the chromatogram pane and choose Select > Select All Components from 
the shortcut menu.
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To copy the selected components to a Database Manager window

1. Select the components.

2. Right-click and choose Copy > Copy option from the shortcut menu.

You can copy a selection, chromatogram, MS spectrum, or an MS tree.

3. In a Database Manager window, right-click and choose Paste > option from the shortcut 
menu.

4. To process data-reduced chromatograms, see Chapter 2, “Database Manager Module.” 

To copy the selected components to a Spectra Classifier window

1. Select the components.

2. Click the Add Selected Scans or Components to Spectra Classifier button, .

The Spectra Classifier window opens.

3. To process the components, see Chapter 10, “Spectra Classifier Module.” 
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Processing MSn Data
In the Chromatogram Processor window, you can view and process Xcalibur data-dependent 
experiments and product ion scanning raw data files and extract spectral trees (MSn spectra) 
from chromatograms. When you open Xcalibur data in a Chromatogram Processor window, 
the window displays a tree view control. Use this tree view control to select one or more 
product scans at any MSn stage. Deconvoluted components that are present are listed at the 
bottom of the tree control. 

For additional information, see “Using Components Detection and Spectra Deconvolution” 
on page 299, “Spectral Tree Arrangement” on page 106, or “Working with Detected 
Components” on page 320.

When you apply component detection and spectra deconvolution procedures to 
data-dependent chromatograms, the application generates components as spectral trees. You 
can process the tree components in the same way as regular spectra. You can edit them in the 
Components Editor window, search them in spectral libraries, or classify them using the 
Spectra Classifier module. You can only view spectral trees in the Chromatogram Processor; to 
edit them, paste them into a Database Manager window to access all editing utilities.

For additional information, see Chapter 9, “Components Editor Module,”  or Chapter 10, 
“Spectra Classifier Module.” 
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Figure 115. Xcalibur data in a Chromatogram Processor window
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Exporting Scans, Components, and Reduced Chromatograms
You can export scans, components, and chromatograms from the Chromatogram Processor 
window to a Database Manager or Spectra Classifier window for additional processing.

Follow these procedures:

• To export selected scans and components to a Database Manager window

• To export a data-reduced chromatogram to a Database Manager window

To export selected scans and components to a Database Manager window

1. Select the scans or components.

For details about selecting scans or components, see “Working with Detected 
Components” on page 320.

2. Click the Add Selected Scans/Components to Database Manager button, .

The Export Chromatographic and Spectral Data dialog box opens.

3. Select one of the export options.

4. Click Continue.

The Select Target dialog box opens.
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5. Do one of the following:

Select one of your open Database Manager windows and click Select.

–or–

Click New Database Manager.

The application imports the selected data to the Database Manager window.

To export a data-reduced chromatogram to a Database Manager window 

1. Select the scans or components.

For details about selecting scans or components, see “Working with Detected 
Components” on page 320.

2. Right-click and choose Copy > Copy Chromatogram from the shortcut menu.

3. In a Database Manager window, right-click and choose Paste > Chromatogram from the 
shortcut menu.

You can save data-reduced chromatograms in a Database Manager window to any library 
using the same procedure that you would use to save spectra or trees. 

Chromatographic scans or trees are fully searchable. For additional information, see 
“Searching Components” on page 334 or “Processing Data-Reduced Chromatograms” on 
page 69. 
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 8 Chromatogram Processor Module
Exporting Scans, Components, and Reduced Chromatograms
Figure 116. Copying a chromatogram from Chromatogram Processor to Database Manager
Thermo Scientific Mass Frontier User Guide 327



8 Chromatogram Processor Module
Annotating Chromatographic Peaks
Annotating Chromatographic Peaks
You can add chemical structures and formatted text to any chromatographic peak in the 
Chromatogram Processor window.

Follow these procedures:

• To add a chemical structure to a chromatographic peak

• To add formatted text to a chromatographic peak

To add a chemical structure to a chromatographic peak

1. Click the Assign Structure to Scan button, .

2. Click the scan where you want to place a structure. 

A new Structure Editor window opens where you can draw a fragment. For information 
about drawing fragments in the Structure Editor window, see Chapter 4, “Structure 
Editor Module.” 

3. After you finish drawing, click OK.

The application connects your structure with the selected scan.

4. To connect the added structure to a different scan, select the structure and drag the 
connecting circle to the required scan. 

5. To resize the structure fragment, select the structure and drag one of the corner rectangles.

Note  You cannot search structures assigned to chromatographic peaks.
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To add formatted text to a chromatographic peak

1. Click the Assign Text to Scan button, .

2. Click the scan where you want to place the text. 

The Annotation dialog box opens.

3. Type your text.

4. To draw a line connecting the peak to the annotation, select the Show Connection Line 
check box.

5. Click OK.

The application connects your text to the selected scan.

6. To connect the added text to a different scan, select the text and drag the connecting 
circle to the required scan.
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Components Editor Module

The Components Editor module consists of a complete set of management tools to delete 
unrelated components, add chemical structures, edit extensive data fields, process spectral 
trees, annotate spectral peaks, and sort search hit lists for every component in a processed 
chromatogram.

Using the Components Editor Window
Use the Components Editor window to edit, search, and organize chromatographic 
components stored in a library or generated by the Components Detection and Spectra 
Deconvolution feature. 

You cannot open the Components Editor module directly from the Mass Frontier application 
window. You must generate this module from your data in the Chromatogram Processor 
window. 

To open a Components Editor window

1. From a Chromatogram Processor window, click the Components Detection & Spectra 
Deconvolution button, , and choose one of the component detection algorithms. 

See “Using Components Detection and Spectra Deconvolution” on page 299.

2. Identify the detection parameters and click Calculate.

For detailed descriptions of the detection algorithm parameters, see the following:

• “JCD Algorithm” on page 301

• “RCD Algorithm” on page 309

• “TECD Algorithm” on page 313

• “Direct Infusion Algorithm” on page 315

3. When the detection and deconvolution process finishes, click Close.

The TIC page identifies the detected components with a triangle at each detected peak.

Contents

• Using the Components Editor Window

• Searching Components
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4. In the Chromatogram Processor window, click the Components Editor button, .

The Components Editor window opens. See “Components Editor window” on page 333.

The Components Editor window closely resembles the Database Manager window; 
however, the processing item is a chromatographic component rather than a database 
record. To distinguish between the modules, the Components Editor window has a light 
blue bar on the left side. Both modules behave almost identically. For a detailed 
explanation of the panes and their functionality, see Chapter 2, “Database Manager 
Module.” 

Each chromatographic component is represented by a single row. The columns contain 
supplementary component information. One of the columns lists Model Ion values that 
have been used for component detection. These values help you orient yourself and find 
components of interest. In most cases, the model ion is the base peak in the full-scan 
spectrum; however, if closely coeluting components have isobaric base peaks, the 
algorithms select different model ions to distinguish these components.

5. Make your changes to the chromatogram.

6. To save your changes and close this module, click OK. 

The application keeps changes with the chromatogram. To save the chromatogram to a 
chromatographic library, see “Processing Data-Reduced Chromatograms” on page 69. 

Note  You can also edit associated components of a library chromatogram (see “Searching 
Chromatographic Libraries” on page 182).
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Using the Components Editor Window
Figure 117. Components Editor window
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Searching Components
You can use the Components Editor window to search one selected subset or all the 
chromatographic components in the spectral or chromatographic libraries. For additional 
information, see “Searching Chromatographic Libraries” on page 182.

Follow these procedures:

• To search for a component from the processed chromatogram

• To search all the components from the processed chromatogram

• To remove a component from the hit list

• To process the hit list of a component

To search for a component from the processed chromatogram

1. Select the components in the Spreadsheet view.

2. Click the Search button, , and choose Search Selected Components.

The Spectral Tree Search dialog box opens. 

3. Enter your search criteria and click OK.

For details about the Spectral Tree Search parameters, see “Searching Spectral Trees” on 
page 120.

When the search is successful, the application stores the results in the Spreadsheet view in 
the Components Editor window. 

The highest match factor for each component search appears in the Match column of the 
Spreadsheet view. If the search did not find any plausible hits, the match factor is not 
displayed. 

The match factor is a number from 1 to 999 that specifies the measure of similarity 
between the query spectrum and the library reference spectrum. A match factor of 999 
means a perfect match. Matches greater than 930 display a lightning bolt, , in the 
Match column.

To search all the components from the processed chromatogram

1. Click the Search button, , and choose Search All Components. 

The Spectral Tree Search dialog box opens. 

Note  Searching a large number of components can take a long time, depending on 
the library size.
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2. Enter your search criteria and click OK.

For details about the Spectral Tree Search parameters, see “Searching Spectral Trees” on 
page 120.

When the search is successful, the application stores the results in the Spreadsheet view in 
the Components Editor window. The spreadsheet displays the title for all hits in red. 

The highest match factor for each component search appears in the Match column of the 
Spreadsheet view. If the search did not find any plausible hits, the match factor is not 
displayed. 

The match factor is a number from 1 to 999 that specifies the measure of similarity 
between the query spectrum and the library reference spectrum. A match factor of 999 
means a perfect match. Matches greater than 930 display a lightning bolt, , in the 
Match column.

To remove a component from the hit list

1. Select the component row.

2. Click the Reject Library Hit button, .

To process the hit list of a component

1. Select the component row.

2. Click the Hit Selector button, .

The Hit Selector window opens. 

To distinguish the Hit Selector window from the Components Editor and Database 
Manager windows, the Hit Selector window has a yellow bar on the left side.

The Hit Selector window lists the best matches found during the library search. The 
match factor describes the similarity of the match to your component.
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Figure 118. Hit Selector window

3. In the Hit Selector window, review the hit list and do one of the following:

• To accept a library record that corresponds to the component, select the component 
in the spreadsheet and click OK. 

When you accept a library record for a component, all relevant information 
(structure, name, molecular mass, ion types, and so on) are adopted and entered in 
the component fields.

• To reject all components in the hit list, click Cancel. 
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Spectra Classifier Module

Use the Spectra Classifier module to retrieve and organize spectra, which you can then submit 
to Principal Component Analysis (PCA), Neural Networks Self-Organizing Maps (SOM), or 
Fuzzy Clustering. 

Contents

• Classification Methods Background

• Advantages of Classification Methods in the Mass Frontier System

• Spectra Classification Methods

• Organizing Spectra

• Working in the Spectra Classifier Module

• Example Workflow
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Classification Methods Background
Classification greatly enhances library search and fragmentation prediction methods. The 
Mass Frontier application uses classification methods that close the triangle of 
computer-oriented methods for interpreting mass spectral data. The computer-oriented 
methods available in this application complement each other but are based on different 
principles. These methods provide the means to create alternative strategies and enable 
comprehensive data interpretation. 

Advantages of Classification Methods in the Mass Frontier System
In contrast to statistical software packages, the Mass Frontier system applies classification 
methods directly to mass spectral data. All preprocessing procedures, which are essential to 
using classification methods, are automatic. This built-in process ensures that you use 
classification methods correctly, even if you have minimal knowledge of the multivariate 
statistic.

The primary goal of spectral classification is to find a correlation between the properties of 
compounds and their mass spectra. Because physical and chemical properties and biological 
activities of chemical compounds are to a large extent a function of molecular structure, the 
results of classification analysis reflect structural features that are determined by fragmentation 
ions appearing in a mass spectrum. The important advantage of classification methods is that 
you do not need a detailed knowledge of the complex spectra-structure relationship to get 
satisfactory results. Classification strategy in this application is based on graphical 
presentation of the results, which you can easily view on the screen (see “Working in the 
Spectra Projector Window” on page 361).
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Spectra Classification Methods
Computer methods of analyzing mass spectral data center on three fundamental 
methodologies: library search techniques, expert system procedures, and classification 
methods.

For additional information, see “Using the Search Utilities” on page 72, “Previewing 
Unimolecular Reactions” on page 193, or “Example Workflow” on page 357.

This application contains three classification methods: 

• Principal Component Analysis (PCA) 

• Fuzzy Clustering

• Self-Organizing Maps

Self-Organizing Maps (SOM) is a special class of neural networks. Use these methods, based 
on different principles, to explore complex data from various perspectives. Principal 
Component Analysis (PCA) uses multivariate statistics, fuzzy clustering assigns data to 
clusters, and SOM is based on competitive learning.

In the multivariate statistic, you can consider each spectrum as a single point in an 
n-dimensional space, with the intensities being the coordinates of this point. A dimension 
(axis) of that space represents a mass-to-charge ratio, m/z, of the considered peak. This means 
that the dimensionality is determined by the m/z value of the last peak in the spectrum. For 
example, the EI spectrum of hydrogen exhibits two peaks at m/z =1 (intensity 2%) and m/z = 
2 (100%). You can view this spectrum as a point in a two-dimensional space with the 
coordinates [2, 100].

Figure 119. Multivariate statistic example

In reality, spectra have a far higher dimensionality than two. When the dimensionality is too 
high, or several coordinates are equal to zero (usually a mass spectrum does not have peaks at 
every m/z value), the classification methods might not provide the required results. As a result, 
a reduction of dimensionality is carried out either before a spectrum is placed in 
n-dimensional space, or during the classification process.

m/z  3 

m/z  1 

m/z  2 
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The basic hypothesis of multivariate statistical methods assumes that the distance between 
points (spectra) in an n-dimensional space is related to a relevant property of the compounds 
that represent these points. When the points are close enough to form a cluster or a separated 
region, you can assume that the compounds that correspond to these points exhibit common 
or similar properties. To ensure the results of the classification methods have statistical 
significance, place a large number of spectra (usually one or more groups, each with 10–1000 
spectra) in the same n-dimensional space. Then apply multivariate statistical methods, with 
various parameters, to evaluate these points (spectra). The objective of a classification process 
is to separate these points (spectra) into two or more classes according to the desired structural 
or other properties.
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Principal Component Analysis (PCA)

Principal Component Analysis reduces the dimensionality of a data set where a large number 
of interrelated—that is, correlated—variables exist, while retaining as much as possible the 
variation present in the data set. In mass spectrometry, the data set consists of the mass spectra 
of different compounds. The mass spectra are expressed as the intensities of individual m/z 
ratios, or variables.

PCA attempts to find a new coordinate system that can be expressed as the linear combination 
of the original variables (m/z) so that the major trends in the data are described. 
Mathematically, PCA relies on eigenvalue/eigenvector decomposition of the covariance or the 
correlation matrix of the original variables. PCA decomposes the data matrix X as the 
multiplication of two matrices P (the matrix of new coordinates of data points) and T´ 
(transposition of the coefficients matrix of the linear combination of the original variables):

X = P.T´

Generally, the data can be adequately described using far fewer coordinates, also called 
principal components, than original variables. PCA also serves as a data-reduction method 
and a visualization tool. When the data points are plotted in the new coordinate system, the 
relationships and clusters are often more apparent than when the data points are plotted with 
the original coordinates.

Figure 120. Geometrical interpretation of PCA

Old and new coordinates 
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Geometrical interpretation of PCA: The axes of the new coordinate system—principal 
components p1 and p2—are created as the linear combinations of the original axes. New 
coordinates (principal components (PC)) are orthogonal (perpendicular) to each other. There 
is greater variation in the direction of p1 than in either of the original variables, but very little 
variation in the direction of p2. For data sets with more than two variables, the first PC 
describes the direction of the greatest variation in the data set, the second PC describes the 
direction of the second greatest variation, and so on.
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Self-Organizing Maps

Self-Organizing Maps, sometimes called Kohonen networks, are a special class of neural 
networks. A self-organizing map consists of neurons placed at the nodes of a two-dimensional 
lattice. The neurons become selectively activated to various input mass spectra, or classes of 
spectra, in the course of a competitive learning process. The neurons compete among 
themselves to be activated or excluded. You can view SOM as a nonlinear generalization of 
PCA.

The principal goal of self-organizing maps is to transform a set of n-dimensional input spectra 
into a discrete two-dimensional map and to display this transformation. Each input spectrum 
presented to the network activates a neuron according to a complex set of interrelationships 
between spectra. In SOM, each mass spectrum must always activate a neuron and this 
spectrum is shown on the particular neuron. Spectra that activate the same neuron belong, in 
terms of classification, to the same pattern. To ensure that the self-organizing process has a 
chance to develop properly, the networks should be exposed to a certain number of different 
spectra. As a result, this application requires a minimum of 10 spectra in a self-organizing 
process.

Figure 121. SOM architecture as used in the Mass Frontier application

Note  The SOM classification method exhibits one atypical feature to be aware of: an 
identical data set produces different results if the input data is processed in a different 
order. This ordering is an inherent feature of neural networks and is not a result of faulty 
algorithms. 
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Fuzzy Clustering

Cluster analysis is a technique for grouping data into clusters to find common structural 
features in spectral data. Membership degrees between zero and one are used in fuzzy 
clustering, instead of crisp assignments of the data to clusters. Fuzzy clustering is based on the 
dot-product distance between the center of clusters and experimental spectral points. The 
dot-product is calculated from mass spectral n-dimensional space with the intensities being 
the coordinates and m/z values dimensions. The number of peaks whose intensities are above 
the predefined threshold determines the dimensionality of spectral space. The number of 
clusters is usually pre-defined. For additional information, see Chapter 11, “Spectra Projector 
Module.” 

Figure 122. Fuzzy clustering example
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Organizing Spectra
Spectra are organized into groups that can have their own names and graphic representations. 
When spectra are organized into groups, you can distinguish between the classes of spectra 
that should arise from the submitted groups of spectra after the classification process.

You can use the Mass Frontier application for the classification of spectra according to 
physical or chemical properties (point of origin, toxicity, aromaticity, and so on). For spectra 
that cannot be found in a library, classification can involve identification of substructure types 
or compound classes (structure elucidation) to establish and confirm structural proposals. 
Classification can also be useful in cases when you must retrieve only structurally related 
compounds from a complex chromatogram (metabolite research).

In classification analysis, distinguishing between two terms, groups and classes, is important. 
You can assign classes only after the classification method (Principal Component Analysis, 
Fuzzy Clustering, or Neural Networks (SOM)) clearly shows the occurrence of clusters or 
regions that consist of spectra with the desired properties. Before classification, you can only 
allocate spectra to groups according to preselected criteria. Often the objective of the 
classification process is to obtain classes that closely resemble groups of spectra submitted to 
classification.

You can save and open records with the .ref file extension, which are present in the Database 
Manager spreadsheet. This feature is especially useful for maintaining groups of spectra that 
are sent from the Database Manager to the Spectra Classifier window. 

When you have retrieved spectra for classification, you might want to save these records, 
rather than save the spectra as ASCII files, such as JCAMP-DX (.jdx) or NIST MSP (.msp) 
files. In contrast to .jdx or .msp files, a reference file stores the locations where all the relevant 
information about each spectrum is saved (spectrum, structure, experimental conditions, and 
so on). These files are easy to manipulate; you can add or remove one or more records to 
them. You cannot save deconvoluted spectra from the Chromatogram Processor window as 
records (see “Working with Detected Components” on page 320).
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Working in the Spectra Classifier Module
The Spectra Classifier window is the gateway to PCA, Neural Networks (SOM), and Fuzzy 
Clustering classification. When you send or paste any spectra to the Spectra Classifier 
window, the spectrum or spectra are automatically assigned to a group. The application 
automatically gives a name to a new group, which you can rename. You can add up to 255 
groups of spectra to Spectra Classifier, and each group can consist of an unlimited number of 
spectra. Conversely, it is also possible for a group to only contain a single spectrum. 

This section includes the following topics:

• Opening the Spectra Classifier Window

• Managing Groups of Spectra

• Viewing Spectra Data

• Classifying Spectra

• Spectra Classifier Window

Opening the Spectra Classifier Window

You can open an empty Spectra Classifier window or select spectra from the Database 
Manager or Chromatogram Processor window and populate those spectra to a Spectra 
Classifier window.

Follow these procedures:

• To open a Spectra Classifier window

• To select spectra for classification from the Database Manager

• To select spectra for classification from the Chromatogram Processor

To open a Spectra Classifier window

Do one of the following:

Click the Spectra Classifier button, , in the Mass Frontier toolbar.

–or –

Choose Tools > Spectra Classifier from the Mass Frontier main menu.

An empty Spectra Classifier window opens. See “Spectra Classifier Window” on 
page 355. You can open only one Spectra Classifier window at a time in the system. If a 
Spectra Classifier window is already open, it becomes active (and might already contain 
spectra).
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To select spectra for classification from the Database Manager

1. Select the records in the Database Manager window.

2. Click the Add Selected Records to Spectra Classifier button, , and choose 
Spectra Classifier.

The Spectra Classifier window opens.

Figure 123. Spectra Classifier window with spectra from a Database Manager

To select spectra for classification from the Chromatogram Processor

1. Select scans or components in the Chromatogram Processor window.

You can select scans from the chromatogram pane or components from the filter list.

2. Click the Add Selected Scans or Components to Spectra Classifier button, .

The Spectra Classifier window opens.

Figure 124. Spectra Classifier window with spectra from a Chromatogram Processor
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Managing Groups of Spectra

In the Spectra Classifier window, you can select the spectra you are ready to classify, remove 
spectra groups from the Spectra Classifier window, or assign names to the spectra groups.

Follow these procedures:

• To copy and paste spectra for classification

• To add an available spectra group to the ready-for-classification list

• To remove a spectra group from the ready-for-classification list

• To delete a group of spectra from the Spectra Classifier window

• To assign an appropriate name to each group

To copy and paste spectra for classification 

1. In a Database Manager window or a Chromatogram Processor window, select the spectra 
you want to classify.

2. In the Spectra Classifier window, click the Paste button, .

The application adds the selected spectra to the Available Groups of Spectra list.

To add an available spectra group to the ready-for-classification list

1. Select the group of scans in the Available Groups of Spectra list.

2. Click Add.

The application moves the selected group to the Groups of Spectra Ready for 
Classification list.

The application automatically assigns a graphic to each group in the Groups of Spectra 
Ready for Classification list. 

To change the group’s graphic, choose Options > Settings from the Mass Frontier main 
menu, and then choose Classification in the Layouts area. The colors and types of 
graphics are used only to distinguish the groups in the plots and have no influence on the 
results of the analysis. 
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To remove a spectra group from the ready-for-classification list

1. Select the group of scans in the Groups of Spectra Ready for Classification list.

2. Click Remove.

The application moves the selected group to the Available Groups of Spectra list.

To delete a group of spectra from the Spectra Classifier window

1. Select the group of scans in the Available Groups of Spectra list.

2. Do one of the following:

Click Delete One to remove only the selected scan.

–or–

Click Delete All to remove all scans in the Available Groups of Spectra list.

The application deletes the specified scans from the Spectra Classifier window.

To assign an appropriate name to each group 

1. In either list of spectra groups, select a group.

2. In the Selected Group of Spectra box, change the name of the group of spectra.

Note  You can delete scans only from the Available Groups of Spectra list. You cannot 
delete scans from the Groups of Spectra Ready for Classification list.

Note  You can use the copy (CTRL+C) and paste (CTRL+V) commands. 
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Viewing Spectra Data

In the Spectra Classifier window, you can view the spectra and structures for a spectra group 
or open the source (Database Manager or Chromatogram Processor) module for a spectra 
group.

To preview spectra records

In either list of spectra groups, select a group.

The table displays spectra, structures, and additional information. 

Figure 125. Spectra records

To open the source for a spectra group

Double-click a spectra group in either of the two lists.

The Database Manager window or Chromatogram Processor where the corresponding 
spectra originated opens with these records selected. 

IMPORTANT  The Spectra Classifier can hold only spectra that are still present in the 
original Database Manager or Chromatogram Processor window. After you create a 
group of spectra in the Spectra Classifier, do not move the spectra from the original 
Database Manager window or clear the component spectra from a chromatogram in 
the Chromatogram Processor. If you violate either of these conditions, the target 
group of spectra is removed from the Spectra Classifier. 
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Classifying Spectra

After you have selected all the groups you want to classify and chosen the classification 
method, you can classify the spectra groups. While the application is running the 
classification, you can continue to work in other Mass Frontier windows. Depending on the 
type of classification method you choose, the application displays the results in a Spectra 
Projector or a Neural Networks window.

Follow these procedures:

• To begin Principal Component Analysis classification

• To begin Neural Networks (SOM) classification

• To begin Fuzzy Clustering classification
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To begin Principal Component Analysis classification

1. In the Classification Method area, select the Principal Component Analysis option.

2. Specify the number of principal components to be calculated.

3. Click Classify Now.

The application classifies all groups of spectra in the Groups of Spectra Ready for 
Classification list according to the selected classification method.

The application displays the results of a Principal Component Analysis classification in a 
Spectra Projector window. For a complete description, see Chapter 11, “Spectra Projector 
Module.” 

Figure 126. Spectra Projector window resulting from PCA classification

Note  You can continue to work in other Mass Frontier windows while the application 
processes a classification.
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To begin Neural Networks (SOM) classification

1. In the Classification Method area, select the Neural Networks option.

2. Select the Optimal option (recommended), or select the User Defined option and 
specify an x and y value.

3. Click Classify Now.

The application classifies all groups of spectra in the Groups of Spectra Ready for 
Classification list according to the selected classification method.

The application displays the results of a Neural Networks classification in a Neural Networks 
window. For a complete description, see Chapter 12, “Neural Networks Module.” 

Figure 127. Neural Networks window resulting from spectra classification

Note  You can continue to work in other Mass Frontier windows while the application 
processes a classification.
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To begin Fuzzy Clustering classification

1. In the Classification Method area, select the Fuzzy Clustering option. 

2. Click Classify Now.

The application classifies all groups of spectra in the Groups of Spectra Ready for 
Classification list according to the selected classification method.

The application displays the results of a Fuzzy Clustering classification in a Spectra 
Projector window. For a complete description, see Chapter 11, “Spectra Projector 
Module.” 

Figure 128. Spectra Projector window resulting from Fuzzy Clustering classification

Note  You can continue to work in other Mass Frontier windows while the application 
processes a classification.
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Spectra Classifier Window 

Table 46. Spectra Classifier parameters  (Sheet 1 of 2)

Parameter Description

Available Groups of 
Spectra

Lists groups of spectra that have been sent (or copied) from a 
Database Manager or Chromatogram Processor window.

Groups of Spectra Ready 
for Classification

Lists the groups of spectra to classify when you click Classify 
Now.

Add → Moves the selected group to the Groups of Spectra Ready for 
Classification list.

← Remove Moves the selected group to the Available Groups of Spectra list.

Delete One Removes only the selected scan from the Spectra Classifier 
window.

Delete All Removes all scans in the Available Groups of Spectra list.

Paste Spectrum

Classification Layout

Show Source

Group Up

Group Down
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Classify Now Classifies all groups of spectra in the Groups of Spectra Ready for 
Classification list according to the selected classification method.

Selected Group of 
Spectra 

Editable name of the currently selected spectra group.

Classification Method

Principal 
Component 
Analysis / Principal 
Components

Specifies the PCA classification method and the number of 
coordinates used to describe the data. For a detailed description, 
see “Principal Component Analysis (PCA)” on page 341.

Neural Networks 
(SOM)

Specifies the SOM classification method, which is a 
self-organizing map that consists of neurons placed at the nodes 
of a two-dimensional lattice. For a detailed description, see 
“Self-Organizing Maps” on page 343.

Optimal (Recommended) Specifies an optimized two-dimensional lattice.

User Defined Specifies the x and y dimensions of the lattice.

Fuzzy Clustering Specifies the fuzzy clustering classification method that groups 
data into clusters to find common structural features in the 
spectral data. For a detailed description, see “Fuzzy Clustering” 
on page 344.

Table 46. Spectra Classifier parameters  (Sheet 2 of 2)

Parameter Description
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 10 Spectra Classifier Module
Example Workflow
Example Workflow

This example workflow demonstrates how to classify the derivatives of nicotine and caffeine.

You have an EI spectrum of an unknown compound that you suspect is a metabolite of either 
nicotine or caffeine, and you must find out which of these two compound classes it belongs 
to. 

1. Retrieve a sufficient number of spectra for each group (for example, nicotines and 
caffeines).

2. To form clusters of each group, submit to a principal component analysis. 

a. Perform a substructure search, where the search query is the structure of nicotine and 
caffeine. 

b. When a sufficient number of spectra for each group is found (more than 10 spectra), 
select these records and add them, separately for each group, to the Spectra Classifier. 

3. Assign an appropriate name to each group using the Selected Group of Spectra text box. 

You can use the copy (CTRL+C) and paste (CTRL+V) commands. 
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4. Select a line in the left pane of Spectra Classifier and click Add, and then repeat this for 
the next group.

5. When all the groups of spectra that you want to classify are in the Groups of Spectra 
Ready for Classification list, launch the classification process by clicking Classify Now. 

After the generation is finished, a new Spectra Projector window opens.

You have retrieved two groups of spectra: nicotine and caffeine derivatives. You now want 
to examine an unknown metabolite that likely originated from nicotine or caffeine. 

6. After preparing the two groups of spectra in the Spectra Classifier window, generate a 
Spectra Projector window by using the PCA option. 

The following figure shows that the two groups are separated into clusters. 

Figure 129. Nicotine and caffeine separated into clusters

7. Add the unknown metabolite to the projection plane by pasting or opening its spectrum 
in Spectra Projector. 

The projection of this external spectrum clearly shows that it belongs to the nicotine class 
(squares). 

8. Confirm or reject this result using the fragmentation pattern of nicotine.

Note  Spectral trees are supported by all the spectral modules except the Spectra 
Classifier, which uses total composite spectra generated from trees.



11
Spectra Projector Module

The Spectra Projector module displays the results of a Principal Component Analysis (PCA) 
or Fuzzy Clustering method. In a Spectra Projector window, mass spectra are projected as 
points on a two-dimensional (2-D) plane or a three-dimensional (3-D) twistable space, 
according to principal components or fuzzy cluster combinations. The objective of 
classification analysis is to find classes of spectra on the projection that exhibit common or 
similar properties. You can use the Spectra Projector window to place an external spectrum 
onto a projection to examine its class membership.

You can apply classification to spectra that cannot be previously distributed into groups by 
classifying only one group of spectra and attempting to find points on the projection that 
represent compounds with the expected properties. In the Spectra Projector window, you can 
select these points to examine their spectra and structures. 

For additional information, see “Principal Component Analysis (PCA)” on page 341 or 
“Fuzzy Clustering” on page 344.

Contents

• Generating a Spectra Projector Window

• Working in the Spectra Projector Window

• Using 3-D Projection Mode

• Opening and Saving Classification Results

• Accessing Spectra from a Spectra Projector Window

• Adding External Spectrum to a Projection
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Generating a Spectra Projector Window
Generating a Spectra Projector Window
You cannot directly open a Spectra Projector window from the Mass Frontier application. You 
must generate it from the Spectra Classifier module by specifying the Principal Component 
Analysis or the Fuzzy Clustering option for classification. You can open an unlimited number 
of Spectra Projector windows in the Mass Frontier application. For additional information, 
see Chapter 10, “Spectra Classifier Module.” 

You cannot alter classification results after they have been generated. To remove a spectrum 
(point) from a projection plane, remove this spectrum from the input data and then launch a 
new classification process. 

Figure 130. Spectra Projector generated with the PCA classification method

Figure 131. Spectra Projector generated with the Fuzzy Clustering classification method
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Working in the Spectra Projector Window
The Spectra Projector window displays spectra as points on a 2-D plane or in a 3-D space. 
You can select a combination of two principal components, which make up the 2-D 
projection plane. When you are viewing PCA results using the 3-D projection mode, you can 
select a combination of the three associated principal components.

For example, when you click a 2-D projection tab labeled “2-5,” the spectra are projected onto 
the plane of the 2nd and 5th principal components. The number of tabs is determined by the 
number of principal components that have been selected in the Spectra Classifier module. 
The Spectra Projector window displays a tab for every possible combination of the selected 
principal components. For example, when you generate the Spectra Projector module with 
three principal components, three tabs are available (1-2, 2-3, and 1-3). When you use the 
five default principal components, 10 tabs are available (1-2, 1-3, 1-4, 1-5, 2-3, 2-4, 2-5, 3-4, 
3-5, and 4-5). 

Figure 132. 2-D projection plane

In the 3-D mode, the number of combinations of principal components for more than five 
components is significantly higher in comparison to the 2-D projection plane. As a result, 
when you want to analyze your spectra in the 3-D mode, use no more than five principal 
components. Set the number of principal components in the Spectra Classifier window before 
you begin the PCA calculation. For additional information, see Chapter 10, “Spectra 
Classifier Module.” 
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Figure 133. 3-D space 

The status bar in a Spectra Projector window displays the number of selected principal 
components and the number of spectra that have been classified (the total number of spectra 
from all groups).

Follow these procedures:

• To scale the projection plane

• To show a legend of spectra

• To zoom and pan in the graphical display

To scale the projection plane

1. Select the tab for the projection you want to view.

You can view each projection at a different scale.

2. Right-click the Spectra Projector window and choose Zoom > zoom option from the 
shortcut menu.

• Use Zoom to Box to define a rectangle that enlarges to fill the window.

• Use Zoom In to display less of the projection plane at a larger scale.

• Use Zoom Out to display more of the projection plane at a smaller scale.

3. To return to the original scale, right-click the Spectra Projector window and choose 
Zoom > Zoom Reset from the shortcut menu. 
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To show a legend of spectra

Right-click the Spectra Projector window and choose Zoom > Show Legend from the 
shortcut menu.

The application displays a list of spectra with their symbols.

Figure 134. 3-D plot with a legend

To zoom and pan in the graphical display

• Click the Hand button, , in the Mass Frontier toolbar and drag the hand to pan 
horizontally or vertically.
Similarly, hold down the H keyboard key or the Spacebar to change the cursor to the 
hand.

• Click the Zoom Out button, , in the Mass Frontier toolbar.

• Click the Zoom In button, , in the Mass Frontier toolbar.

• Click the Zoom to Box button, , in the Mass Frontier toolbar and describe a 
rectangle. 
Similarly, hold down the Z keyboard key and describe a rectangle.

• Click the Zoom Reset button, , in the Mass Frontier toolbar to return to full scale.

• Click the Zoom Undo button, , in the Mass Frontier toolbar to undo the last zoom 
operation.

• Click the Zoom Redo button, , in the Mass Frontier toolbar to restore the last zoom 
operation.

• Use the scroll wheel on the mouse to zoom the entire display. 
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Using 3-D Projection Mode
The principle of PCA classification and Fuzzy Clustering is to reduce the dimensionality of a 
spectral space to a level comprehensible to the human eye. Because a paper or screen plot is 
inherently 2-D, the method of choice is usually 2-D PCA or Fuzzy Clustering. However, if a 
3-D projection on a 2-D computer screen is accompanied with motion, you can better 
perceive this simulation as a 3-D space. In the Spectra Projector window, you can rotate the 
plot to help you perceive this simulation in 3-D mode.

Spectra classification of complex data set in a 3-D space can be more effective and reliable 
than a simple 2-D plot. When analyzing PCA or Fuzzy Clustering results, do not rely entirely 
on 2-D plots. Two or more clusters that overlap in a 2-D plot might be separated in 3-D 
space, or two seemingly separate clusters discernible in a 2-D plot might appear in 3-D mode 
to be too close together to be considered as two different objects.

To view and rotate PCA or Fuzzy Clustering results in 3-D mode

1. Click the 3D Projection button, .

The application displays the classification plot in 3-D space.

2. Click the Show Axis button, .

The application overlays the x, y, and z axes on the display.

Figure 135. 3-D projection with axes

3. Click the Rotate button, .

The cursor changes to a rotation sphere, .

2-D projection

3-D projection with axes
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Using 3-D Projection Mode
4. Click the classification plot and drag the cursor to rotate the plot. 
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Opening and Saving Classification Results
Opening and Saving Classification Results
In the Spectra Projector window, you can save or open projection planes that have been 
generated with particular initial settings (number of principal components).

Follow these procedures:

• To open spectra projection planes

• To save spectra projection planes

To open spectra projection planes

1. Do one of the following:

Click the Open button, , in the Mass Frontier main toolbar and choose PCA 
Projections.

–or–

Choose File > Open > PCA Projections from the Mass Frontier main menu.

The Open Spectra Projections dialog box opens.

2. Select a Projection File (.pca2) file and click Open.

The selected file opens in a new Spectra Projector window. 

To save spectra projection planes

1. Do one of the following:

Click the Save button, , in the Mass Frontier main toolbar.

–or–

Choose File > Save from the Mass Frontier main menu.

The Save Spectra Projections dialog box opens.

2. Type a name for the saved file and click Save.

The application saves projection planes as graphics, without the possibility of recalling the 
original spectra, which are displayed as points. To access the spectra with structures from 
projection planes, save the records in the Database Manager, as described in the Spectra 
Classifier chapter. In this case, you must regenerate the classification from the original 
data set that was saved as records; you can, however, add an external spectrum. 

For additional information about saving records, see “Using Records in the Database 
Manager Window” on page 37 or “Organizing Spectra” on page 345. 
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Accessing Spectra from a Spectra Projector Window
An important part of classification analysis is knowing which spectrum is represented by a 
point on a projection plane. As the application links corresponding modules, it recalls spectra 
with structures or chromatographic components from any projection plane.

To access a single spectrum, scan, or deconvoluted component

Double-click a point on the projection. 

The linked module opens on top of all other windows, and the application selects the 
corresponding record or component and displays the spectrum. 

For additional information about saving spectra to records, see “Using Records in the 
Database Manager Window” on page 37 or “Working with Detected Components” on 
page 320. 

To access several spectra in a region

Do one of the following:

a. Right-click and choose Select from the shortcut menu.

b. Draw a region around the spectra.

–or–

a. Click the Select Spectra and Show Their Origin button, .

b. Draw a region around the spectra.

• When the selected spectra originate from a Database Manager window, you are 
prompted to copy the records with spectra and structures to either the last active 
Database Manager window or to a new one (see “Example Workflow” on 
page 357). 

• When your spectra originate from a chromatogram in a Chromatogram 
Processor window, the corresponding scans or components appear in the same 
color as they appear in the PCA or Fuzzy Clustering plot. 

Note  The Spectra Projector module is able to recall only records that are present in an 
open Database Manager window. When you close the Database Manager window that is 
the source of the input data for classification, the link between a point and its spectrum is 
interrupted. The application automatically warns you if you try to close a Database 
Manager window that is linked with one or more Spectra Projector windows. To keep the 
links between points and spectra intact, do not move records in or between Database 
Manager windows using cut-and-paste commands. 

When the data originates from Chromatogram Processor, keep the window open (see 
“Processing Extracted Spectra” on page 318).
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Adding External Spectrum to a Projection
The objective of principal component projections of mass spectra is to find classes of 
compounds with common or similar properties. You can then use sufficiently separated classes 
to investigate the class membership of an unknown spectrum (see “Example Workflow” on 
page 357). Use the Spectra Projector window to add an external spectrum, which was not 
used for classification, to the projection plane. When the added spectrum is clearly projected 
into a particular class region, you can assume that this compound has similar, usually 
structural, properties.

The following figure shows that two groups are separated into clusters. You can add the 
unknown spectrum to the projection plane by pasting or opening its spectrum in a Spectra 
Projector window. The projection of this external spectrum shows that it belongs to the 
nicotine class (squares, PCA; or triangles, Fuzzy Clustering). You can confirm or reject this 
result using the fragmentation pattern of nicotine.

Figure 136. Nicotine and caffeine separated into clusters
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Neural Networks Module

The Neural Networks module displays classification results from Self-Organizing Maps 
(SOM), which are a special class of neural networks. 

A self-organizing map is a network of neurons arranged in the form of a 
two-dimensional (2-D) lattice. You can define the size of a lattice or let the application 
automatically calculate it. During a classification, neurons become selectively activated to 
various input spectra as a result of a competitive learning process.

The objective of classification analysis using SOM is to find classes of spectra on the map that 
exhibit common or similar properties. When one or more spectra activate the same neuron, 
you can assume the spectra belong to a common class. In this case, the spectra should exhibit 
certain similarities. You can consider spectra that activate neighboring neurons and those 
neurons that have low Euclidian distance between each other (shown by borderline thickness), 
to be related. 

In neural networks, each mass spectrum must always activate a neuron and this spectrum is 
shown on the particular neuron. Neurons are displayed as rectangles. Spectra are represented 
as symbols or numbers, and are placed onto neurons. Because the spectra are located in 
discrete objects, the interpretation of SOM is relatively easy in contrast to PCA and Fuzzy 
Clustering where you do not have diffuse clusters. However, when a single spectra activates a 
larger numbers of neurons, this advantage is lost.

Spectra that activate the same neuron belong to the same classification pattern. All spectra 
drawn inside a neuron box are equal for classification purposes and their graphical positions 
within a neuron are irrelevant.

For additional information, see “Self-Organizing Maps” on page 343 or “Fuzzy Clustering” 
on page 344.

Contents

• Generating a Neural Networks Module

• Using the Neural Networks Window

• Accessing Spectra from a Neural Networks Window

Note  The SOM classification method exhibits one atypical feature to be aware of: 
Different results are produced for an identical data set if the input data is processed in a 
different order. This impact of order on results is an inherent feature of neural networks 
and not a result of faulty algorithms.
Thermo Scientific Mass Frontier User Guide 369



12 Neural Networks Module
Generating a Neural Networks Module
Generating a Neural Networks Module
Use the Spectra Classifier module to generate a Neural Networks module. You cannot directly 
open a Neural Networks window from the Mass Frontier main menu (similar to the Spectra 
Projector). After you generate the network, you cannot alter the classification results. To 
remove a spectrum (symbol) from a network, you must remove this spectrum from the input 
data and then launch a new classification process. You can open an unlimited number of 
Neural Networks windows at any time in the application.

To generate a Neural Networks module

1. Select spectra from the Database Manager or Chromatogram Processor window and 
populate those spectra to a Spectra Classifier window.

For detailed instructions, see “Opening the Spectra Classifier Window” on page 346.

2. In the Spectra Classifier window, select the data you want to classify.

For detailed instructions, see “Managing Groups of Spectra” on page 348.

3. To begin the Neural Networks classification process, select the Neural Networks option 
and click Classify Now.

For detailed instructions, see “Classifying Spectra” on page 351.

The application displays the results of a Neural Networks classification in a Neural 
Networks window. 

Figure 137. Neural Networks window resulting from spectra classification
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Using the Neural Networks Window
A Neural Networks window displays a topological map of neurons, represented as rectangles. 
Every neuron has a minimum of two and a maximum of six neighboring neurons. Spectra are 
displayed as symbols or numbers within neurons.

The status bar in a Neural Network window displays the lattice dimension and how many 
spectra have been classified (the total number of spectra from all groups).

Follow these procedures:

• To show distances between neurons

• To scale the lattice

• To use the zoom and pan features

• To open a neural networks file

• To save neural networks to a file

To show distances between neurons

Click the Show Distances Between Neurons button, .

To show the approximate distances between neighboring neurons, the application applies 
different thicknesses to their borders.

You can use information about neuron distances when classifying an unknown spectrum. 
The distances show how a neuron that has been activated by an unknown correlates with 
neighboring neurons. The distances can also suggest that spectra from a common neuron 
might have been activated by multiple, close neurons. 
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Although neurons are displayed in a regular 2-D lattice, the actual Euclidian distances 
between neurons vary. The line thickness is proportional to the distance between 
immediate neighbors. The thinner the line, the closer together are the neurons.

To scale the lattice 

1. Right-click the Neural Networks window and choose Zoom > zoom option from the 
shortcut menu.

• Click Zoom to Box to describe a rectangle that enlarges to fill the window.

• Click Zoom In to display less of the neural networks lattice at a larger scale.

• Click Zoom Out to display more of the neural networks lattice at a smaller scale.

2. To return to the original scale, right-click the Neural Networks window and choose 
Zoom > Zoom Reset from the shortcut menu. 

To use the zoom and pan features

• Click the Hand button, , in the Mass Frontier toolbar and drag the hand to pan 
horizontally or vertically.
Similarly, hold down the H keyboard key or the Spacebar to change the cursor to the 
hand.

• Click the Zoom Out button, , in the Mass Frontier toolbar.

• Click the Zoom In button, , in the Mass Frontier toolbar.

• Click the Zoom to Box button, , in the Mass Frontier toolbar and describe a 
rectangle. 
Similarly, hold down the Z keyboard key and describe a rectangle.

• Click the Zoom Reset button, , in the Mass Frontier toolbar to return to full scale.

• Click the Zoom Undo button, , in the Mass Frontier toolbar to undo the last zoom 
operation.

• Click the Zoom Redo button, , in the Mass Frontier toolbar to restore the last zoom 
operation.

• Use the scroll wheel on the mouse to zoom the entire display. 

Note  Spectra that activate the same neuron belong to the same classification pattern. 
This means that all spectra drawn inside a neuron box are equal for classification 
purposes and their graphical positions within a neuron are irrelevant.
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To open a neural networks file 

1. Do one of the following:

Click the Open button, , in the Mass Frontier main toolbar and choose Neural 
Networks.

–or–

Choose File > Open > Neural Networks from the Mass Frontier main menu.

The Open Neural Networks dialog box opens.

2. Select a Neural Networks (.nn2) file and click Open.

The lattice for the selected file opens in a new Neural Networks window. 

To save neural networks to a file

1. Do one of the following:

Click the Save button, , in the Mass Frontier main toolbar.

–or–

Choose File > Save from the Mass Frontier main menu.

The Save Neural Networks dialog box opens.

2. Type a name for the saved file and click Save.

The Mass Frontier application saves neural networks as graphics, without the possibility of 
recalling the original spectra, displayed as symbols. To access the spectra from a lattice, save 
the spectra to records in the Database Manager window as described in the Spectra Classifier 
chapter. In this case, regenerate the classification from the original data set that was saved.

For additional information about saving spectra to records, see “Using Records in the 
Database Manager Window” on page 37 or “Organizing Spectra” on page 345. 
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Accessing Spectra from a Neural Networks Window
An important part of classification analysis is knowing which spectrum is represented by a 
symbol on the lattice. As the Mass Frontier application links corresponding modules, it recalls 
spectra with structures or chromatographic components from any neural network.

To access a single spectrum, scan, or deconvoluted component

Double-click a symbol on the lattice. 

The linked module opens on top of all other windows, and the application selects the 
corresponding record or component and displays the spectrum. 

To access several spectra in a region

Do one of the following:

a. Right-click and chose Select from the shortcut menu.

b. Draw a region around the spectra.

–or–

a. Click the Select Spectra and Show Their Origin button, .

b. Draw a region around the spectra.

– When the selected spectra originate from a Database Manager window, the 
application copies the original data to the Database Manager window. For 
additional information, see “Example Workflow” on page 357. 

– When your spectra originate from a chromatogram in a Chromatogram 
Processor window, the corresponding scans or components are selected in the 
original Chromatogram Processor window and appear in the same color as they 
appear in the Neural Networks window. 

Note  The Neural Networks module is able to recall only records that are present in an 
open Database Manager window. When you close the Database Manager window that is 
the source of the input data for classification, the link between a symbol and its spectrum 
is interrupted. The application automatically warns you if you try to close a Database 
Manager window that is linked with one or more Neural Networks windows. To keep the 
links between symbols and spectra intact, do not move records in or between Database 
Manager windows.

When the data originates from a Chromatogram Processor window, keep the window 
open (see “Processing Extracted Spectra” on page 318).
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Formula Generator Module

Use the Formula Generator module to calculate a list of theoretical molecular formulas that 
best fit an m/z value. Because the number of possible molecular formulas for a specified m/z 
value is closely related to the mass tolerance, elements used, and the maximum allowed 
number of atoms for each isotope, always carefully evaluate these parameters before starting a 
generation. 

You can either manually enter the m/z value or have the software automatically retrieve the 
value from any spectral peak in the Database Manager window or the Chromatogram 
Processor window. In the Formula Generator module, you can also calculate the isotopic 
pattern for any generated formula.

Contents

• Generating Formulas from Peaks

• Specifying Mass/Abundance Options
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Generating Formulas from Peaks
Generating Formulas from Peaks
Use the Formula Generator module to calculate the possible elemental composition for any 
spectral peak by selecting the peak in a Database Manager or Chromatogram Processor 
window. 

Follow these procedures:

• To open a Formula Generator window

• To specify molecular formula options

• To automatically calculate the m/z tolerance value

• To generate possible formulas for a peak

To open a Formula Generator window

1. Do one of the following:

Click the Formula Generator button, , in the Mass Frontier main toolbar.

–or–

Choose Tools > Formula Generator from the Mass Frontier main menu.

The Formula Generator window opens.

Figure 138. Formula Generator window
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Generating Formulas from Peaks
To specify molecular formula options 

1. In the Formula Generator window, click Options.

The Molecular Formula Settings dialog box opens to the Peaks page.

2. Review the default settings on the Peaks page. 

See “Peaks page” on page 377.

3. Click the Limits tab to see the Limits page. Verify that the Charge setting matches the 
polarity of the MS mode you used for spectral acquisition. 

See “Limits page” on page 378.

4. Click the Elements tab to see the Elements in Use page. Verify the maximum number of 
elements used for calculation.

See “Elements in Use page” on page 379.

5. When you have verified the options, click OK.

Use the options in the Molecular Formula Settings dialog box to speed up calculations, 
restrict the number of possible formulas, or set the charge state and polarity.

Figure 139. Peaks page

Table 47. Peaks parameters  (Sheet 1 of 2)

Parameter Description

Clear Existing Labeling Removes all columns from the formula list except the 
Formula column. This option is meaningful only in the 
Auto Annotation > Generate Formulas feature in the 
Database Manager window.

Formula Count Limits the number of formulas displayed in the formula 
list. 
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Figure 140. Limits page

Show Theoretical m/z value Displays the Theoretical m/z column in the formula list. 

Show m/z Delta
Delta Units

Displays the Delta (units) column in the formula list. 

Show RDBE Displays the Ring Double Bond Equivalents (RDBE) 
column in the formula list.

Show Pattern Match Displays the Pattern Match (%) column in the formula 
list. 

Table 48. Limits parameters

Parameter Description

Charge Charge state. 

Nitrogen Rule Specifies whether to use the nitrogen rule in the elemental 
composition calculation. The choices include:

• Do not use
• Even-electron ion (for example, radical-cation)
• Odd-electron ion (for example, protonated)

Hydrogen Count Specifies whether to use an algorithm for the exclusion of 
implausible formulas with improbably high numbers of 
hydrogens.

Valence Test Specifies whether to exclude formulas if the atoms cannot 
be connected in any way using valences common in 
organic chemistry.

Ring plus Double Bond 
Equivalent (RDBE)

Displays only formulas for which RDBE is within the 
From–To range. RDBE limits the calculated formulas to 
those that make sense from a chemical perspective.

Table 47. Peaks parameters  (Sheet 2 of 2)

Parameter Description
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Figure 141. Elements in Use page

Table 49. Elements in Use parameters  (Sheet 1 of 2)

Parameter Description

Elements in Use Specifies whether Mass Frontier will consider isotopes of 
particular elements with a maximum number when 
calculating formulas. For information about isotope 
patterns, see “Displaying Isotope Patterns” on page 58.

Add Opens the Select Element dialog box where you can 
specify a new element. The application uses the new 
element when calculating formulas.
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To automatically calculate the m/z tolerance value

Select the Acquired from Source check box.

When you generate possible formulas for a peak, the application automatically calculates 
the m/z tolerance value from the source spectra. 

To generate possible formulas for a peak

1. In the Formula Generator window, click the Pick a Peak button, . 

The Formula Generator window minimizes to a bar.

2. Click a spectral peak in the Database Manager or Chromatogram Processor window.

The Formula Generator window lists all possible formulas. All the decimal places are 
accurately transferred to the Formula Generator. To choose which columns of 
information are displayed in this list, see “Peaks page” on page 377.

Delete Removes the selected element from the Elements in Use 
list.

Formula Opens the Enter Molecular Formula dialog box where 
you can specify a new formula. The software uses the new 
formula to derive upper limits for individual elements 
(see “Elements in Use page” on page 379). These limits 
are considered when the software calculates formulas. 

Table 49. Elements in Use parameters  (Sheet 2 of 2)

Parameter Description
380 Mass Frontier User Guide Thermo Scientific



 13 Formula Generator Module
Specifying Mass/Abundance Options
Specifying Mass/Abundance Options
This section includes the following topics:

• Monoisotopic Mass

• Accuracy

• Precision

Monoisotopic Mass

All the calculated masses displayed in the Formula Generator window are monoisotopic 
masses. The monoisotopic mass of an ion is the mass of the isotopic peak, which is composed 
of the most abundant isotopes of its elements. Because the system calculations support only 
single-charged ions (z=1), the calculated exact masses (not measured) in structure-based 
modules are equal to their m/z value.

Accuracy

The Mass Frontier application uses two parameters associated with m/z value: Accuracy and 
Resolution. Resolution is the smallest difference in m/z of two centroid peaks that a detector 
can distinguish Accuracy is the estimated difference between the observed and the real m/z 
value of a peak. 

The Mass Frontier application determines these values from the raw data file. If you select the 
Use User Defined option in the mass accuracy page, the software sets both values to the same 
user defined value.

Use accuracy settings for the differentiation of adjacent peaks (spectra) and m/z values 
(calculations). Because the application processes only centroid spectra, the differentiation is 
defined as the spacing between resolved peaks (spectra) or as the smallest distinguishable 
difference in m/z values (calculations). No additional parameters, such as peak width, are 
taken into account. 

To specify accuracy settings

1. Choose Option > Settings from the Mass Frontier main menu.

The Options dialog box opens.

2. Click Mass/Abundance in the Parameters section.

Note  Changing the accuracy in the Tolerance Settings dialog box does not affect spectra 
that you open in the Chromatogram Processor or fragments that the application has 
already calculated in the Fragments & Mechanisms and Fragments Comparator modules. 
When you require spectra or fragments with a new setting, you must reload the spectra or 
regenerate the fragments.
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The Mass Accuracy page in the Tolerance Settings dialog box displays options for 
specifying accuracy settings.

Figure 142. Mass Accuracy page

3. Define the appropriate type, value, and unit in the Accuracy for Calculated Data area.

The application supports these tolerance types:

• Unit

• Resolving power M/ΔM

• ppm 1 000 000 x ΔM/M

• Mass Accuracy (ΔM in AMU or ΔM in mmu)

where:

M = m/z (mass-to-charge ratio)

ΔM = M2 – M1 (M1, M2 are two adjacent peaks)

Peaks (m/z values) that fall into the ΔM band are considered to be identical (m/z value).

4. To set a tolerance for imported spectra or GC/LC/MS chromatograms from a processed 
file, do one of the following in the Accuracy for Experimental Data area:

Select the Determine from Source option to adopt the tolerance settings saved in a file.

–or–

Select the Use User Defined option to use the same tolerance settings specified for 
calculations in the Accuracy for Calculated Data area.
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You cannot improve the resolution of experimental data by choosing a user-defined type. 
Avoid setting tolerance values that are better than the resolution of the mass spectrometer 
that you use for data acquisition. The Use User Defined option can artificially reduce the 
resolution of experimental data when working with low- and high-resolution spectra in 
the same data set: spectra search, target analysis, or classification.

For additional information, see “Using the Search Utilities” on page 72 for spectra search, 
“Searching Chromatographic Libraries” on page 182 for target analysis, Chapter 10, 
“Spectra Classifier Module.”  for classification, or “Supported GC/MS and LC/MS Data 
File Formats” on page 246.
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Precision
Precision refers to m/z values and is defined as the position of the last digit relative to the 
decimal point that is displayed. Precision settings are used only for the display of m/z values 
and peak positions on the m/z scale. In contrast to tolerance, the Mass Frontier application 
ignores precision settings in all calculations, always using the highest possible precision. To 
assure the correct display of m/z values, you must set the precision to the same or a higher 
order than the tolerance.

To specify precision settings

1. Choose Option > Settings from the Mass Frontier main menu.

The Options dialog box opens.

2. Click Mass/Abundance in the Parameters section.

3. Click the Mass Precision tab.

The Mass Precision page in the Tolerance Settings dialog box displays options for 
specifying precision settings.

Figure 143. Mass Precision page

4. Do one of the following:

Select the From Accuracy option to use settings specified on the Mass Accuracy page.

–or–

Select the Number of Decimal Digits option and, in the adjacent box, specify the 
number of decimal places to use.

Note  When working with experimental spectra, some of the digits of the displayed 
m/z values might not be significant.
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Microsoft Office

The Mass Frontier application supports the Object Linking and Embedding (OLE) features 
of the Microsoft Excel spreadsheet and the Microsoft Word applications —that is, you can 
open these applications and their native data files inside the Mass Frontier main window. This 
feature is useful for data exchange between the Mass Frontier modules and Excel worksheets. 

Note  The Mass Frontier application does not support the direct import or export of 
native Excel files (.xls) to the Database Manager module.

Note  The Mass Frontier installation package does not include the Microsoft Office 
application. To use the Object Linking and Embedding features of Excel and Word, you 
must purchase the Microsoft Office application separately. Install Microsoft Office before 
you install the Mass Frontier software (see “Installing the Mass Frontier Application” on 
page 21).

Contents

• Exchanging Data

• Exporting Data to an Excel Spreadsheet

• Importing Spectra from an Excel Spreadsheet
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Exchanging Data
You can use copy-and-paste commands to exchange text tables, graphics, mass spectra, and 
trees in table format between the Microsoft Excel and the Mass Frontier applications. 

To use a Microsoft Word document

1. Choose Microsoft Office > Open Microsoft Word Document from the Mass Frontier 
main menu.

The Open Microsoft Word Document dialog box opens.

2. Select a document and click Open.

A Word document opens in the Mass Frontier window. The Word menu and toolbars are 
displayed below the Mass Frontier toolbars. The Word menu and toolbars do not include 
the Open or Save commands. 

3. To save a Word document, choose Microsoft Office > Save Microsoft Word Document 
from the Mass Frontier main menu.

4. Use copy-and-paste commands to exchange data between the Mass Frontier modules and 
the Word document.

To use an Excel document

1. Choose Microsoft Office > Open Microsoft Excel Document from the Mass Frontier 
main menu.

The Open Microsoft Excel Document dialog box opens.

2. Select a document and click Open.

A Microsoft Excel spreadsheet opens in the Mass Frontier window. See “Embedded Excel 
spreadsheet” on page 387.

The Excel menu and toolbars are displayed below the Mass Frontier toolbars. The Excel 
menu and toolbars do not include the Open or Save commands. 

3. To save an Excel document, choose Microsoft Office > Save Microsoft Excel Document 
from the Mass Frontier main menu.

4. Use copy-and-paste commands to exchange data between the Mass Frontier modules and 
the Excel spreadsheet.
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Figure 144. Embedded Excel spreadsheet
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Exporting Data to an Excel Spreadsheet
You can export text tables, graphics, mass spectra in numerical table format, and spectral trees 
from the Database Manager to an Excel spreadsheet. Because you can access all these types at 
the same time, you must specify the type of data you want to copy to the Excel spreadsheet. 
For instructions for copying spectral tree data from the Mass Frontier application, see 
“Copying and Pasting a Spectral Tree” on page 116. 

Follow these procedures:

• To export data records

• To export mass spectrum or mass differences graphics

• To export a mass spectrum in numerical table format

• To use an Excel spreadsheet as an editor

To export data records

1. Select one or more records on the Spreadsheet page in the Database Manager window.

2. Do one of the following:

Click the Copy button, , in the Mass Frontier toolbar and choose Selected Rows 
from the menu.

–or–

Choose Edit > Copy > Selected Rows from the Mass Frontier main menu.

3. Click the Excel spreadsheet to make it active.

4. Right-click the Excel spreadsheet, and choose Paste from the shortcut menu.

The application pastes the records into the spreadsheet.
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To export mass spectrum or mass differences graphics

1. Choose Microsoft Office > New Microsoft Excel Worksheet from the Mass Frontier 
main menu.

2. Do one of the following in the Database Manager window:

Click the Spectrum tab.

–or–

Click the Mass Differences tab.

The mass spectrum or mass differences spectrum must be visible before you can copy it. 
For detailed information about the content of the spectrum and mass differences pages, 
see Chapter 2, “Database Manager Module.” 

3. Do one of the following:

Click the Copy button, , in the Mass Frontier toolbar and choose Spectrum from 
the menu.

–or–

Choose Edit > Copy > Spectrum from the Mass Frontier main menu.

4. Click the Excel spreadsheet to make it active.

5. Right-click the Excel spreadsheet, and choose Paste Special from the shortcut menu.

The Paste Special dialog box opens.

6. Select Picture (Enhanced Metafile) and click OK.

The application pastes the spectra graphics into the spreadsheet.
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To export a mass spectrum in numerical table format

1. In a Database Manager window, click the Data tab to make the m/z and abundance table 
visible.

2. Do one of the following:

Click the Copy button, , in the Mass Frontier toolbar and choose Spectrum from 
the menu.

–or–

Choose Edit > Copy > Spectrum from the Mass Frontier main menu.

3. Click the Excel spreadsheet to make it active.

4. Right-click the Excel spreadsheet, and choose Paste from the shortcut menu. 

The application pastes the record data into the spreadsheet.

To use an Excel spreadsheet as an editor

Export a spectrum or tree to an Excel spreadsheet, edit it, and then import the edited 
spectrum or tree into the Database Manager window.

Using the Excel application’s editing features is useful when, for example, you have an 
experimental spectrum with several noise peaks at high m/z values that you want to delete 
or you want to extract part of a spectrum that is important to your report or presentation. 
For obvious reasons, do not add, delete, or alter prominent peaks.
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Importing Spectra from an Excel Spreadsheet
You can import mass spectra or spectral trees stored in an Excel spreadsheet to the Database 
Manager window (see “Copying and Pasting a Spectral Tree” on page 116). You can organize 
spectral tables horizontally or vertically. 

To import spectra from an Excel spreadsheet

1. Make sure your table contains mass spectra.

2. Select the table you want to export into the Mass Frontier application.

3. Right-click the Excel spreadsheet, and choose Copy from the shortcut menu.

4. Choose Edit > Paste > Spectrum in the Mass Frontier main menu.

To correctly interpret m/z values and abundance

Follow one of these conventions:

• When the spectral table is vertical, the first column must be the m/z value and the 
second must be abundance.

• When the spectra are vertically oriented, the first column is abundance, and the 
second column is the m/z value, then label the first row of the first column 
“Abundance” and the first row of the second column “m/z”.

• When the spectral table is horizontally oriented, then the first row must be the m/z 
value and the second row must be abundance.

• When the spectra are oriented horizontally, the first row is abundance, and the 
second row is the m/z value, then label the first column of the first row “Abundance” 
and the first column of the second row “m/z”.

• When you import more than one spectrum at a time, then the first column or row 
(depending on the orientation) must be the m/z values and all the other columns (or 
rows) must be abundance.

Note  The Mass Frontier application supports standard tables with separated numbers, so 
you can also import spectra from other applications.
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Report Creator Module

To create customizable reports, use the Report Creator module to extract text and graphics 
from other modules in the Mass Frontier application. You can also specify the order in which 
objects from the module appear in the report. You can print or export reports to PDF files and 
save the report layout.

You can extract text and graphics from the following modules:

• Database Manager 

• Structure Editor 

• Chromatogram Processor 

• Spectra Projector 

• Neural Networks 

• Fragments and Mechanisms 

You can create reports only from open windows. You cannot report data that is simply stored 
in the Mass Frontier application; it must appear on the screen before you can add it to a report 
in the Report Creator window. 

This section includes the following topics:

• Adding Graphic Elements to a Report

• Adding Data Elements to a Report

• Aligning Elements on a Report

• Saving, Printing, or Exporting a Report

• Example Reports
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To open the Report Creator window

1. Open the modules with the data you want to use in a report.

2. Do one of the following:

Click the Report Creator button, , in the Mass Frontier main toolbar.

–or–

Choose Tools > Report Creator from the Mass Frontier main menu. 

The Report Creator window opens.

Figure 145. Report Creator window 
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The Report Creator window is divided into three panes:

• The leftmost pane displays a thumbnail of each of the pages of your report.

• The center pane displays the contents of your report.

• The rightmost pane displays the commands you can use to add and modify elements in 
your report.
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Adding Graphic Elements to a Report
Use Report Creator features to add common graphical elements to the report.

Follow these procedures:

• To add a page to a report

• To add text

• To load a graphic

• To draw a line

• To add a data/time stamp

To add a page to a report

1. Click the Add Page button, .

The application adds a blank page to the end of the report.

2. Use the thumbnail views in the leftmost pane to move between pages.

To add text

1. Click Text and click on the report where you want the text.

2. Double-click the rectangle.

The Formatted Text Editor dialog box opens.
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3. Select the default text and type your text.

4. Use the text editing features to format your text.

5. Click OK.

6. To verify that your text looks as you expect, choose File > Preview from the Report 
menu.

The Preview page shows a print view of your report, without a background grid or 
positioning rectangles.

7. To close the Preview page, click the Close button, , or press ESC. 

To load a graphic

1. In the Report Creator window, click Picture and click on the report where you want the 
graphic.

2. Double-click the rectangle.

The Picture Editor dialog box opens.

3. Click Load.

4. The Load Picture dialog box opens.

5. Locate a graphic and click Open.

The application supports these graphic formats: .gif, .jpg, .jpeg, .bmp, .ico, .emf, 
and .wmf.

The application displays the graphic in the Picture Editor dialog box.

6. Click OK.
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If the aspect ratio of the graphic is not similar to the rectangle in the Report Creator 
window, the graphic might be misshaped.

7. Stretch the graphic rectangle to fit the aspect ratio of the graphic.

8. To resize the graphic rectangle, right-click and choose Position > Scale or Position > Size 
from the shortcut menu.

9. To verify that your graphic looks as you expect, choose File > Preview from the Report 
menu.

The Preview page shows a print view of your report, without a background grid or 
positioning rectangles.

10. To close the Preview page, click the Close button, , or press ESC.

To draw a line 

1. Click Line and click on the report where you want the line.

The application places the line at the bottom edge of the rectangle. You cannot draw a 
vertical line.

2. To change the color of the line, double-click the rectangle.

The Color dialog box opens.

3. Select a color for your line and click OK.

4. To resize the graphic rectangle, right-click and choose Position > Scale or Position > Size 
from the shortcut menu.

These commands do not change the thickness of the line.
398 Mass Frontier User Guide Thermo Scientific



 15 Report Creator Module
Adding Graphic Elements to a Report
To add a data/time stamp

1. Click Date & Time and click on the report where you want the time stamp.

The application inserts the current date and time in a rectangle. 

2. To change the date and time, double-click the rectangle.

The Date & Time dialog box opens.

You do not have to use the current date and time on the report.

3. To change the date, click a new date on the calendar.

4. To change the time, click the up or down arrows in the Time box.

5. Click OK.
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Adding Data Elements to a Report
Use Report Creator features to add data elements from a Database Manager or 
Chromatogram Processor window to a report.

Follow these procedures:

• To copy a graphic from the Database Manager or Chromatogram Processor window

• To add a structure

• To add a tree

• To add a spectrum

• To add a fragmentation scheme

• To add Compare Spectra graphics

• To add Compare Trees graphics

To copy a graphic from the Database Manager or Chromatogram Processor window

1. Copy a tree or structure in a Database Manager or Chromatogram Processor window. 

The application saves this graphic to the Clipboard.

2. In the Report Creator window, click Picture and click on the report where you want the 
graphic.

3. Double-click the rectangle.

The Picture Editor dialog box opens.

4. Click Paste From Clipboard.
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The application displays the graphic in the Picture Editor dialog box.

5. Click OK.

If the aspect ratio of the graphic is not similar to the rectangle in the Report Creator 
window, the graphic might be misshaped.

6. Stretch the graphic rectangle to fit the graphic.

7. To resize the graphic rectangle, right-click and choose Position > Scale or Position > Size 
from the shortcut menu.

8. To verify that your graphic looks as you expect, choose File > Preview from the Report 
menu.

The Preview page shows a print view of your report, without a background grid or 
positioning rectangles.

9. To close the Preview page, click the Close button, , or press ESC. 

Note  If the Paste From Clipboard button is not enabled, there is nothing on the 
Clipboard to paste. You cannot copy a graphic to the Clipboard while this dialog box 
is open. You must cancel this dialog box, copy a graphic to the Clipboard, and return 
to this dialog box.
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To add a structure

1. Click Main Structure and click on the report where you want the structure.

The application pastes the current structure in a rectangle. 

2. Double-click the rectangle until the structure you want is displayed.

As you double-click, the application cycles through all available structures. 

3. To view all the available structures, click the Main Structure down arrow.

4. To add the chemical formula and molecular mass, click Main Structure Description and 
click on the report where you want the description.

The application adds the chemical formula and molecular mass for the structure.

Note  When the original structure is smaller than the required structure, stretch the 
rectangle to an appropriate size.
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To add a tree

1. Click Tree and click on the report where you want the tree.

The application pastes the current tree in a rectangle. 

2. Double-click the rectangle until the tree you want is displayed.

As you double-click, the application cycles through all available trees. 

3. To view all the available trees (one from each open Database Manager or Chromatogram 
Processor window), click the Tree down arrow.

Note  When the original tree is smaller than the required tree, stretch the rectangle to 
an appropriate size.
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To add a spectrum

1. Click Spectrum and click on the report where you want the spectrum.

The application pastes the current spectrum in a rectangle. 

2. Double-click the rectangle until the spectrum you want is displayed.

As you double-click, the application cycles through all available spectrum. 

3. To view all the available spectra (one from each open Database Manager or 
Chromatogram Processor window), click the Spectrum down arrow.

Note  When the original spectrum is smaller than the required spectrum, stretch the 
rectangle to an appropriate size.
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To add a fragmentation scheme

1. Click Fragmentation Scheme and click on the report where you want the fragment.

The application pastes the current fragment in a rectangle. 

2. Double-click the rectangle until the fragment you want is displayed.

As you double-click, the application cycles through all available fragmentation schemes. 

3. To view all the available spectra (one from each open Database Manager window), click 
the Spectrum down arrow.

Note  When the original fragment is smaller than the required fragment, stretch the 
rectangle to an appropriate size.
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To add Compare Spectra graphics

1. Click Compare Spectra and click on the report where you want the compared spectra.

The application pastes the current compare spectra data in a rectangle. 

2. Double-click the rectangle until the correct compare spectra data is displayed.

As you double-click, the application cycles through all available compare spectra data. 

3. To view all the available compare spectra data (one from each open Database Manager 
window), click the Compare Spectra down arrow.
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To add Compare Trees graphics

1. Click Compare Trees and click on the report where you want the compared trees.

The application pastes the current compare trees data in a rectangle. 

2. Double-click the rectangle until the correct compare trees data is displayed.

As you double-click, the application cycles through all available compare trees data. 

3. To view all the available compare trees (one from each open Database Manager window), 
click the Compare Trees down arrow.
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Aligning Elements on a Report
The alignment toolbar includes commands to align all selected elements in your report.

To align elements

1. Hold down the SHIFT key and select all elements you want to align.

The alignment toolbar buttons are available only when elements are selected.

2. Click the appropriate alignment button in the toolbar.

3. If the effect is not what you want, click the Undo button, .

Left 
align

Center align 
(horizontal)

Right 
align

No space 
or overlap 
(horizontal)

Top 
align

Center align 
(vertical)

Bottom 
align

No space 
or overlap 
(vertical)

Shrink to 
smallest width

Expand to 
largest width

Shrink to 
smallest height

Expand to 
largest height

Center selection 
(horizontal)

Center selection 
(vertical)
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Saving, Printing, or Exporting a Report 
Use the Report Creator to save a report as a Mass Frontier format file (.mfrf ), or as a Mass 
Frontier Snapshot file (.mfrs), or as a template to use as a base for creating other reports.

You can also export a report as a PDF or TIFF file.

Follow these procedures:

• To save a report

• To save a report as a template

• To preview or print a report

• To export a report as a PDF file

• To export a report as a TIFF file

To save a report

1. Click the Save button, . 

The Save As dialog box opens.

2. Type a name for the Mass Frontier Report File (.mfrf ), and click Save.

The application saves the report in the …\HighChem\Mass Frontier 7.0 \Reports folder. 

To save a report as a template

1. Choose File > Save As from the Report Creator menu.

The Save As dialog box opens.

2. Open the Templates folder.

3. Type a name for the Mass Frontier Report File (.mfrf ), and click Save.

The application saves the report in the …\HighChem\Mass Frontier 7.0\ 
Reports\Templates folder.

You can use this report as a base for making another report by choosing File > Open and 
navigating to the Templates folder. 

Note  If you have previously saved this report, the application immediately saves your 
changes and does not open the Save As dialog box.
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To preview or print a report

1. Click the Print Preview button, . 

The Preview window opens.

2. Click the Print button, , to print the report.

You can save the report as a print preview (.ppv) file by clicking the Save As button, .

3. Click the Close button, , to close the Preview window. 

To export a report as a PDF file

1. Choose File > Export As PDF from the Report Creator menu.

The Save As dialog box opens.

2. Navigate to a location for the PDF file.

3. Type a name for the PDF file.

4. Click Save.

The report opens in an Adobe Acrobat window. 

To export a report as a TIFF file

1. Choose File > Export As TIFF from the Report Creator menu.

The Save As dialog box opens.

2. Navigate to a location for the TIFF file.

3. Type a name for the TIFF file.

4. Click Save.

The report opens in a Windows Picture and Fax Viewer window.
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Example Reports
The following example reports show added graphics, structures, spectra, spectral trees, data, 
and text.

Example Metabolite ID Database Report

Metabolite ID Database Report 1/18/2011 8:43:04 AM
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Example Metabolite ID FISh Chromatogram Report

Metabolite ID FISh Chromatogram Report 1/18/2011 9:12:33 AM
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Average Spectra parameter  77, 82

B
background subtraction  296
backup library  165
bar code spectra  220
Base Peak chromatogram  295
Baseline correction algorithm  285
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bond location, unspecified  145

C
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Chromatogram Processor module
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data processing  258
description  8
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Fragment Ion Search  258
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Joint Component Detection  301
linear fit method  279
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processing extracted spectra  318
processing MSn data  323
Rapid Component Detection  309
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visualization options, spectrum  254
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working with detected components  320
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Compare Spectra page  43
components detection algorithms  300
Components Editor
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searching components  334
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description  9

Composite Spectra parameter  77, 82
connect to server  157
convert library  168
Copy to Compare Spectrum parameter  44
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Database Manager module
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CAS number search  97
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export to Excel  49
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ID search  96
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Work spreadsheet  67
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F
FISh (Fragment Ion Search)  258
Force Mass Accuracy  270
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open window  375
options  377
precision  384
window  376

fragment assignment  61, 61
Fragment Ion Search (FISh)  258
fragmentation and rearrangement rules  184
Fragmentation Library

Active Record  233
add straight reaction arrow  230
comparison results  243
description  6
edit structure  230
editing fragmentation reactions  228
fragmentation scheme  232
Fragments Comparator  241
HighChem fragmentation library  226
mechanism extraction  235
reaction symbols  236
save changes in fragmentation scheme  234
search utilities  239
substituents  235
window  241

Fragmentation Library mechanisms  184
fragmentation reactions  228
fragmentation scheme  232
Fragments & Mechanisms module

bar code spectra  220
bond cleavage, aromatic systems  211
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Help, how to use  x
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ID search  96
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Ignore Top Level parameter  78, 83
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import NIST/EPA/NIH  171
import spectral database  171
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installation
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ionization methods  185
Isotope Pattern module
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J
JCD (Joint Component Detection)  301
Joint Component Detection (JCD)  301

K
Knowledge Base  201
Kohonen networks  343

L
library

backup  165
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converting  168
creating  160
Database Manager  36
delete records  180
HighChem spectral tree  176
installing  161
refresh  170
reindex  167
restore  165
save changes  177
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licenses, types of  xi
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Linear fit method  279
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Mass Differences page  42
Mass Frontier Server Manager  154
Mass Spectral Database  171
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matrix conversion  273
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name search  91
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accessing spectra  374
description  13
neuron distances  371
open/save  373
scale the lattice  372
zoom and pan features  372

neural networks, classification  343
neuron distances  371
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noise elimination algorithm  285
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parameters

Active Spectrum  43
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NIST  78, 83
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Sync Best Match  44

Top Level Only  78, 83
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Periodic Table module
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precision  384
previewing  193
principal component analysis (PCA)  341
processing extracted spectra  318
processing MSn data  323

R
Rapid Component Detection (RCD)  309
RCD (Rapid Component Detection)  309
reaction formalism  194
reaction restrictions  198
Reaction Restrictions dialog box  213
reaction symbols  236
reconfigure previous version  170
records in Database Manager  37
refresh library  170
reindex library  167
remove server  158, 158
Report Creator module

creating reports  393
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window  394
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restore library  165
retention time search  101
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scans average  257
search

CAS number  97
constraints  103
fragmentation libraries  239
ID number  96
name  91
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spectral tree  74, 120
spectrum  79
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utilities  72
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selecting multiple records  47, 47
Self-organizing maps (SOM)  343
Server Manager
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set up  155

shrink library  168
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simulate fragmentation process  218
smoothing  290
SOM classification  343
Source CID Spectra parameter  77, 82
Spectra classification methods  339
Spectra Classifier module

classification methods  338
classifying mass spectra  337
description  11
maintain groups of spectra  345
open spectra classifier  346
window  355

spectra deconvolution  299
Spectra Projector module  361

3D projection mode  364
accessing spectra  367
add external spectra to projection  368
classification results  366
description  12
generating spectra projector  360
zoom and pan features  363

spectra, maintaining groups  345
spectra, processing extracted  318
Spectral Tree module

add node  114
arrangement  106
chromatograms  123
create spectral tree  114
deconvolution  114
define precursor m/z value  115
edit spectral tree  114
generation  109
import trees  110
layout  108
node spectra  119
reconstruction from raw files  110
reconstruction from single file  112
search  120

spectral tree search  74
spectrum search  79
spreadsheet in Database Manager  67
SQL server, reconfigure  170

Structure Editor module
Atom Properties dialog box  141
bond multiplicity  144
bond properties  144
build templates  138
check structure  150
clean structure  149
copy structure  147
description  4
Ellipse tool  145
mirror structure  149
move structure  140
MS calculations  151
open  127
open structure  129
paste structure  148
resize structure  147
restore default settings  128
save structure  129
select atoms or bonds  139
structure formats  126
structure text note  135
template structure  137
unspecified bond location  145
unspecified charge site  145

substituents  235
substructure

search  84
search rules  89

Substructure Best Match parameter  87
Substructure Match Ring Bonds parameter  88
Substructure parameter  87
Sync Best Match parameter  44
system activation  xi

T
TECD (Total Extraction Component Detection) algorithm  
313

Thresholding method  276
TIC chromatogram  251
Top Level Only parameter  78, 83
Total Best Match parameter  44
Total Extraction Component Detection (TECD) algorithm  
313

Total Ion Current (TIC) chromatograms  251
Type parameter  44

U
unexplained peaks  219
unimolecular linear reaction mechanisms  184
unimolecular reactions  193
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X
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